Catégorie : Actualités Internet

Le code du service de vérification des mots de passe HaveIBeenPwned est maintenant ouvert

Troy Hunt a ouvert le code source du service de vérification de mots de passe compromis «Have I Been Pwned?» (haveibeenpwned.com), qui permet de vérifier une base de données contenant 11,2 milliards de comptes compromis à la suite de violations de 538 sites. L'annonce de l'intention d'ouvrir le code du projet a été faite en août dernier, mais le processus a pris du temps et le code n'a été publié que maintenant. Le code du service est écrit en […]

Mozilla a résumé ses plans pour prendre en charge la troisième version du manifeste Chrome dans Firefox

Mozilla a publié son plan de mise en œuvre de la troisième version du manifeste Chrome dans Firefox, définissant les capacités et ressources accessibles aux extensions. La troisième version du manifeste a été critiquée pour avoir perturbé le fonctionnement de nombreuses extensions de blocage de contenu indésirable et de sécurité. Firefox prévoit de mettre en œuvre presque toutes les fonctionnalités et restrictions du nouveau manifeste, y compris l'API déclarative pour le filtrage de contenu (declarativeNetRequest), […]

Le protocole QUIC a obtenu le statut de norme proposée

Le Comité IETF (Internet Engineering Task Force), qui s'occupe du développement des protocoles et de l'architecture de l'internet, a finalisé la formation de la RFC pour le protocole QUIC et a publié les spécifications associées sous les identifiants RFC 8999 (propriétés du protocole indépendantes de la version), RFC 9000 (transport sur UDP), RFC 9001 (chiffrement TLS du canal de communication QUIC) et RFC 9002 (gestion de la surcharge et détection de la perte de paquets lors de la transmission de données). […]

La société Virtuozzo a publié une distribution VzLinux, visant à remplacer CentOS 8

La société Virtuozzo (anciennement une division de Parallels), spécialisée dans le développement de logiciels serveur pour la virtualisation basés sur des projets open source, a commencé la distribution publique de la distribution VzLinux, qui était auparavant utilisée comme système d'exploitation de base pour la plateforme de virtualisation développée par l'entreprise et divers produits commerciaux. Désormais, VzLinux est disponible pour tous et se positionne comme un substitut à CentOS 8, prêt pour des déploiements en production. Pour le téléchargement […]

Lancement de la distribution Simply Linux 9.1

La société Basalt SPO a annoncé la sortie de la distribution Simply Linux 9.1, construite sur la base de la neuvième plateforme ALT. Le produit est distribué dans le cadre d'un contrat de licence qui ne transfère pas le droit de distribution de la distribution, mais qui permet une utilisation illimitée du système par des personnes physiques et morales. La distribution est fournie dans des versions pour les architectures x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (bêta) et peut […]

La base de données immudb 1.0 a été publiée, offrant une protection contre la falsification des données.

Une version significative de la base de données immudb 1.0 a été présentée, garantissant l'immuabilité et la conservation de toutes les données ajoutées auparavant, ainsi que la protection contre les modifications rétroactives et permettant la preuve cryptographique de la propriété des données. À l'origine, le projet s'est développé en tant que stockage NoSQL spécialisé, manipulant les données au format clé/valeur, mais depuis la version 1.0, immudb se positionne comme une base de données complète avec support SQL. Le code […]

La distribution AlmaLinux 8.4 est disponible, poursuivant le développement de CentOS 8

La version de la distribution AlmaLinux 8.4 a été présentée, synchronisée avec la distribution Red Hat Enterprise Linux 8.4. Les versions sont préparées pour l'architecture x86_64 sous forme d'image amorçable (709 Mo), minimale (1,9 Go) et complète (9,8 Go). Des versions pour l'architecture ARM seront également publiées prochainement. La distribution est reconnue comme prête pour des déploiements en production et est entièrement identique à RHEL en termes de fonctionnalité, sauf […]

Publication de la distribution Oracle Linux 8.4

La société Oracle a publié la version de la distribution Oracle Linux 8.4, créée sur la base des paquets de Red Hat Enterprise Linux 8.4. Pour un téléchargement sans restriction, une image ISO d'installation de 8,6 Go a été préparée pour les architectures x86_64 et ARM64 (aarch64). Oracle Linux peut accéder librement et sans restriction au dépôt yum avec des mises à jour binaires de paquets pour corriger des erreurs (errata) et des problèmes […]

Incident de perte de contrôle des canaux dans le réseau IRC FreeNode

La nouvelle équipe du réseau IRC FreeNode a exprimé ses regrets concernant l'incident survenu hier, qui a été perçu par certaines communautés comme la prise de contrôle de leurs canaux IRC. Par exemple, des projets tels qu'Ubuntu, Gentoo, HardenedBSD, LibreELEC, FSFE et Void Linux ont déclaré quitter FreeNode en raison de la perte de contrôle de leurs canaux. Après le départ de l'équipe d'administrateurs, qui a fondé le nouveau réseau Libera.Chat en raison d'un conflit avec le propriétaire des domaines, certaines communautés ouvertes […]

Sortie de Chrome 91

La société Google a présenté la version 91 du navigateur web Chrome. En parallèle, la version stable du projet open-source Chromium, qui sert de base à Chrome, est également disponible. Le navigateur Chrome se distingue par l'utilisation des logos de Google, un système d'envoi de notifications en cas de plantage, des modules pour la lecture de contenu vidéo protégé (DRM), un système de mise à jour automatique et la transmission de paramètres RLZ lors de la recherche. La prochaine version de Chrome 92 est prévue pour le 20 juillet. Les principales modifications […]

Publication du filtre de paquets nftables 0.9.9

La version 0.9.9 du filtre de paquets nftables a été publiée, unifiant les interfaces de filtrage des paquets pour IPv4, IPv6, ARP et les ponts réseau (visant à remplacer iptables, ip6tables, arptables et ebtables). La version de la bibliothèque associée libnftnl 1.2.0, fournissant une API de bas niveau pour interagir avec le sous-système nf_tables, a également été publiée. Les modifications nécessaires au fonctionnement de la version nftables 0.9.9 sont incluses dans le noyau Linux 5.13-rc1. Dans le paquet […]

Lancement de la distribution OSGeo-Live 14.0 avec une sélection de systèmes d'information géographique

La distribution OSGeo-Live 14.0 a été présentée, développée par l'organisation à but non lucratif OSGeo dans le but de permettre une découverte rapide de divers systèmes d'information géographique open-source, sans nécessiter leur installation. La distribution est basée sur la plateforme Lubuntu. La taille de l'image de démarrage est de 4,4 Go (amd64, ainsi qu'une image pour les systèmes de virtualisation VirtualBox, VMWare, KVM, etc.). Elle comprend environ 50 applications open-source […]

Acheter un hébergement fiable pour les sites avec protection DDoS, serveurs VPS VDS 🔥 Acheter un hébergement fiable pour les sites avec protection DDoS, serveurs VPS VDS | ProHoster