Publication de FreeBSD 12.3

La version FreeBSD 12.3 a été publiée pour les architectures amd64, i386, powerpc, powerpc64, powerpcspe, sparc64 ainsi que armv6, armv7 et aarch64. Des images pour des systèmes de virtualisation (QCOW2, VHD, VMDK, raw) et des environnements cloud Amazon EC2 ont également été préparées. La version FreeBSD 13.1 est prévue pour le printemps 2022.

Nouveautés clés :

  • Un script /etc/rc.final a été ajouté, qui s'exécute à la dernière étape après la fin de tous les processus utilisateurs.
  • Le filtre ipfw inclut maintenant la commande dnctl pour gérer les paramètres du système de contrôle du trafic dummynet.
  • Ajout de sysctl kern.crypto pour gérer la sous-système cryptographique du noyau, ainsi que le sysctl de débogage debug.uma_reclaim.
  • Ajout de sysctl net.inet.tcp.tolerate_missing_ts, permettant les paquets TCP sans horodatages (option timestamp, RFC 1323/RFC 7323).
  • Dans le noyau GENERIC pour l'architecture amd64, l'option COMPAT_LINUXKPI a été activée et le pilote mlx5en (NVIDIA Mellanox ConnectX-4/5/6) a été activé.
  • Le chargeur a été amélioré avec la possibilité de charger le système d'exploitation depuis un ram-disk, ainsi que le support des options ZFS com.delphix:bookmark_written et com.datto:bookmark_v2.
  • La bibliothèque fetch a ajouté le support du proxy FTP sur HTTPS.
  • Dans le gestionnaire de paquets pkg, les commandes « bootstrap » et « add » supportent désormais le drapeau « -r » pour spécifier le dépôt. L'utilisation des variables d'environnement depuis le fichier pkg.conf a été assurée.
  • L'outil growfs permet désormais de travailler avec des systèmes de fichiers montés en mode lecture et écriture.
  • L'outil etcupdate a mis en œuvre un mode de retour en arrière pour récupérer un ou plusieurs fichiers. Un drapeau « -D » a été ajouté pour spécifier le répertoire cible. L'extraction des données à l'aide d'un répertoire temporaire a été assurée et la gestion de SIGINT a été ajoutée.
  • Les outils freebsd-update et freebsd-version offrent désormais le drapeau « -j » pour prendre en charge les environnements jail.
  • L'outil cpuset peut désormais être utilisé dans des environnements jail pour modifier les paramètres des jail enfants.
  • L'outil cmp a ajouté des options : « -b » (—print-bytes) pour afficher les octets différents, « -i » (—ignore-initial) pour ignorer un certain nombre d'octets initiaux, « -n » (—bytes) pour limiter le nombre d'octets comparés.
  • L'outil daemon a ajouté le drapeau « -H » pour gérer SIGHUP et réouvrir le fichier dans lequel la sortie est effectuée (ajouté pour le support de newsyslog).
  • L'outil fstyp a ajouté le drapeau « -l » pour identifier et afficher les systèmes de fichiers exFAT.
  • L'outil mergemaster gère les liens symboliques lors de la mise à jour.
  • L'outil newsyslog a ajouté le drapeau «E» pour désactiver la rotation des journaux vides.
  • L'outil tcpdump permet maintenant le décodage des paquets sur les interfaces pfsync.
  • L'outil top a ajouté une commande de filtre «/» pour afficher uniquement les processus ou arguments correspondant à une chaîne donnée.
  • Unzip a ajouté le support des archives protégées par mot de passe.
  • Amélioration de la prise en charge du matériel. Des identifiants PCI pour les contrôleurs AHCI ASMedia ASM116x et les contrôleurs I2C Intel Gemini Lake ont été ajoutés. Support des adaptateurs réseau Mikrotik 10/25G et des cartes sans fil Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14. Nouveau pilote igc ajouté pour les contrôleurs ethernet Intel I225 2.5G/1G/100MB/10MB.
  • Le nœud Netgraph ng_bridge a été adapté pour les systèmes SMP. Le nœud ng_nat a ajouté le support de CGN (Carrier Grade NAT, RFC 6598). Il est désormais possible de substituer le nœud ng_source à n'importe quelle partie du réseau Netgraph.
  • Dans le pilote rctl, utilisé pour limiter les ressources, la possibilité d'établir une limite de consommation des ressources à 0 a été ajoutée.
  • L'interface vlan a ajouté le support d'un système de prioritisation du trafic et de gestion de la bande passante ALTQ.
  • Les pilotes amdtemp et amdsmn ont introduit le support des CPU Zen 3 «Vermeer» et APU Ryzen 4000 (Zen 2, «Renoir»).
  • Les versions des applications tierces incluses dans le système de base ont été mises à jour : awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. L'outil unzip a été synchronisé avec la base de code NetBSD.

Source : opennet.ru

Acheter un hébergement fiable pour les sites avec protection DDoS, serveurs VPS VDS 🔥 Acheter un hébergement fiable pour les sites avec protection DDoS, serveurs VPS VDS | ProHoster