La version légère du serveur http lighttpd 1.4.65 a été publiée, visant à allier haute performance, sécurité, conformité aux normes et flexibilité de configuration. Lighttpd est adapté pour une utilisation sur des systèmes très chargés et ciblé sur une faible consommation de mémoire et de ressources CPU. La nouvelle version introduit 173 changements. Le code du projet est écrit en C et est distribué sous licence BSD.
Les principales nouveautés :
- Ajout de la prise en charge de WebSocket sur HTTP/2, ainsi que la mise en œuvre de la RFC 8441, décrivant le mécanisme pour lancer le protocole WebSockets dans un seul flux au sein d'une connexion HTTP/2.
- Mise en œuvre d'un schéma de gestion des priorités amélioré, permettant au client d'influencer la priorité des réponses transférées (RFC 9218), ainsi que de gérer les priorités lors de la redirection des requêtes. Pour HTTP/2, le support du cadre PRIORITY_UPDATE est assuré. serveur Dans les réglages de lighttpd.conf, prise en charge des correspondances conditionnelles liées au début (=^) et à la fin (=$) de la chaîne. De telles vérifications de chaînes sont significativement plus rapides que les expressions régulières et suffisent pour de nombreuses vérifications simples.
- Dans mod_webdav, ajout de la prise en charge des opérations PUT partielles (celles couvrant une partie des données à l'aide de l'en-tête Range). Pour l'activer, vous pouvez utiliser l'option ‘webdav.opts += («partial-put-copy-modify’ => «enable»).
- Dans mod_accesslog, ajout de l'option ‘accesslog.escaping = ‘json’.
- Dans mod_deflate, ajout du support de la compilation avec libdeflate.
- Accélération de l'envoi du corps de la requête via HTTP/2.
- La valeur par défaut du paramètre server.max-keep-alive-requests a été modifiée de 100 à 1000.
- Dans la liste des types MIME, «application/javascript» a été remplacé par «text/javascript» (RFC 9239).
- Pour l'avenir, il est prévu d'appliquer des réglages de chiffrement plus stricts pour TLS et de désactiver par défaut les chiffrages obsolètes. Le réglage CipherString sera changé de «HIGH» à «EECDH+AESGCM:AES256+EECDH:CHACHA20:SHA256:!SHA384». Il est également prévu de supprimer les options obsolètes TLS :
.honor-cipher-order, ssl.dh-file, ssl.ec-curve, ssl.disable-client-renegotiation, ssl.use-sslv2, ssl.use-sslv3. De plus, le nettoyage des mini-modules continuera, pouvant être remplacés par une réalisation Lua plus flexible du mod_magnet. En particulier, les modules mod_evasive, mod_secdownload, mod_uploadprogress et mod_usertrack sont prévus pour être supprimés. sslDistribution SUSE Linux Enterprise 15 SP4 disponible
Source : opennet.ru
