La version principale d'nginx 1.23.4 a été publiée, dans le cadre de laquelle le développement de nouvelles fonctionnalités se poursuit. Dans la branche stable 1.22.x, qui est maintenue en parallèle, seules les modifications liées à la correction de bogues graves et de vulnérabilités sont apportées. À l'avenir, une branche stable 1.24 sera formée sur la base de la branche principale 1.23.x.
Parmi les changements :
- Le protocole TLSv1.3 est activé par défaut.
- Un avertissement est émis en cas de redéfinition des paramètres des protocoles utilisés pour le socket d'écoute.
- Lorsqu'un client utilise le mode « pipelining », la fermeture des connexions en attente de données supplémentaires (lingering close) est assurée.
- La prise en charge des plages d'octets (byte range) a été ajoutée au module ngx_http_gzip_static_module.
- Le niveau de journalisation a été modifié de « crit » à « info » pour SSLles erreurs « data length too long », « length too short », « bad legacy version », « no shared signature algorithms », « bad digest length », « missing sigalgs extension », « encrypted length too long », « bad length », « bad key update », « mixed handshake and non handshake data », « ccs received early », « data between ccs and finished », « packet length too long », « too many warn alerts », « record too small » et « got a fin before a ccs ».
- Le travail sur les plages de ports dans la directive listen a été établi.
- Un problème a été résolu concernant le choix d'un bloc location incorrect lors de l'utilisation d'un préfixe location de plus de 255 caractères.
- Dans les modules ngx_http_autoindex_module et ngx_http_dav_module, ainsi que dans la directive include, la prise en charge des caractères non-ASCII dans les noms de fichiers sur la plateforme Windows a été ajoutée.
- Une fuite de sockets lors de l'utilisation de HTTP/2 et de la directive error_page pour rediriger les erreurs avec le code 400 a été corrigée.
Source : opennet.ru
