Publication d'OpenBSD 6.9

La version de l systĂšme d'exploitation OpenBSD 6.9, qui est une plateforme UNIX libre et multi-plateforme, a Ă©tĂ© lancĂ©e. Il est Ă  noter qu'il s'agit de la 50e version du projet, qui fĂȘtera cette annĂ©e ses 26 ans. Le projet OpenBSD a Ă©tĂ© fondĂ© par Theo de Raadt en 1995 aprĂšs un conflit avec les dĂ©veloppeurs de NetBSD, ce qui a entraĂźnĂ© la fermeture de son accĂšs au dĂ©pĂŽt CVS de NetBSD. Par la suite, Theo de Raadt, avec un groupe de personnes partageant ses idĂ©es, a créé Ă  partir de l'arbre de code source de NetBSD un nouveau systĂšme d'exploitation open source, dont les principaux objectifs de dĂ©veloppement sont la portabilitĂ© (supportant 13 plateformes matĂ©rielles), la normalisation, le bon fonctionnement, la sĂ©curitĂ© active et les outils cryptographiques intĂ©grĂ©s. La taille de l'image ISO d'installation complĂšte du systĂšme OpenBSD 6.9 est de 544 Mo.

En plus du systĂšme d'exploitation lui-mĂȘme, le projet OpenBSD est connu pour ses composants qui ont Ă©tĂ© adoptĂ©s dans d'autres systĂšmes et qui se sont avĂ©rĂ©s ĂȘtre parmi les solutions les plus sĂ»res et de la plus haute qualitĂ©. Parmi eux : LibreSSL (un fork d'OpenSSL), OpenSSH, le filtre de paquets PF, les dĂ©mons de routage OpenBGPD et OpenOSPFD, le serveur NTP OpenNTPD, le serveur de messagerie OpenSMTPD, le multiplexeur de terminal texte (similaire Ă  GNU screen) tmux, le dĂ©mon identd implĂ©mentant le protocole IDENT, une alternative BSDL au paquet GNU groff — mandoc, le protocole pour la mise en place de systĂšmes tolĂ©rants aux pannes CARP (Common Address Redundancy Protocol), un serveur HTTP lĂ©ger, et l'outil de synchronisation de fichiers OpenRSYNC.

Améliorations principales :

  • Le pilote softraid a ajoutĂ© le mode RAID1C avec une mise en Ɠuvre d'un RAID1 logiciel avec chiffrement des donnĂ©es.
  • Deux nouveaux processus en arriĂšre-plan ont Ă©tĂ© ajoutĂ©s — dhcpleased et resolvd, qui fonctionnent avec slaacd et unwind pour la configuration automatique des interfaces rĂ©seau et la rĂ©solution des noms dans DNS. Dans dhcpleased, le protocole DHCP a Ă©tĂ© implĂ©mentĂ© pour obtenir des adresses IP, tandis que resolvd gĂšre le contenu de resolv.conf basĂ© sur les donnĂ©es des serveurs de noms obtenues de dhcpleased, slaacd et de pilotes comme umb.
  • Un support initial pour les appareils Apple avec processeur M1 a Ă©tĂ© ajoutĂ©. Cela inclut la reconnaissance des cƓurs arm64 Apple Icestorm/Firestorm et le support des puces sans fil BCM4378 utilisĂ©es dans le SoC Apple M1.
  • Le support de la plateforme powerpc64, dĂ©veloppĂ©e pour les systĂšmes 64 bits basĂ©s sur les processeurs POWER8 et POWER9, a Ă©tĂ© amĂ©liorĂ©. ComparĂ© Ă  la version prĂ©cĂ©dente, le powerpc64 a ajoutĂ© le support du mĂ©canisme de protection RETGUARD, un pilote astfb pour le framebuffer Aspeed BMC a Ă©tĂ© ajoutĂ©, des problĂšmes avec les pilotes radeondrm et amdgpu sur les systĂšmes avec GPU AMD ont Ă©tĂ© rĂ©solus, la prise en charge du dĂ©marrage rĂ©seau a Ă©tĂ© ajoutĂ©e dans les builds du noyau pour le disque RAM, le support des modes d'Ă©conomie d'Ă©nergie CPU POWER9 a Ă©tĂ© inclus, et le support des exceptions gĂ©nĂ©rĂ©es lors des opĂ©rations en virgule flottante a Ă©tĂ© implĂ©mentĂ©. La prise en charge d’IPMI pour les systĂšmes PowerNV a Ă©galement Ă©tĂ© ajoutĂ©e.
  • La plateforme ARM64 prend en charge les CPU Cortex-A78AE, Cortex-X1 et Neoverse V1. Des variantes optimisĂ©es pour ARM64 des appels copyin, copyout et kcopy ont Ă©tĂ© mises en Ɠuvre, un pilote cryptox a Ă©tĂ© ajoutĂ© pour soutenir les extensions cryptographiques ARMv8, ainsi qu'un pilote smmu pour RM System MMU avec prise en charge de la page de garde. La prise en charge des appareils Raspberry Pi, Rock Pi N10, NanoPi et Pinebook Pro a Ă©tĂ© amĂ©liorĂ©e.
  • Le pilote video a ajoutĂ© un paramĂštre sysctl kern.video.record, qui, comme kern.audio.record, gĂšre l'activation de la sortie d'une image vide lors de la capture vidĂ©o (pour autoriser la capture, il faut changer la valeur Ă  1). Les processus peuvent maintenant ouvrir plusieurs fois le pĂ©riphĂ©rique vidĂ©o, rĂ©solvant ainsi les problĂšmes d'utilisation de la webcam dans Firefox et BigBlueButton.
  • Des points de traçage pour les appels malloc et free ont Ă©tĂ© ajoutĂ©s, permettant de suivre l'activitĂ© liĂ©e Ă  la rĂ©partition de la mĂ©moire Ă  l'aide de dt et btrace. Une option ‘-n’ a Ă©tĂ© ajoutĂ©e dans btrace pour analyser le programme sans effectuer d'actions.
  • La prise en charge des systĂšmes multiprocesseurs (SMP) a Ă©tĂ© amĂ©liorĂ©e. L'implĂ©mentation des sockets UNIX a Ă©tĂ© extraite du verrouillage global du noyau, un mutex partagĂ© a Ă©tĂ© ajoutĂ© pour sĂ©rialiser les opĂ©rations avec msgbuf, l'appel uvm_pagealloc a Ă©tĂ© rendu mp-safe, et les appels getppid et sendsyslog ont Ă©tĂ© dĂ©pouillĂ©s de leurs verrous.
  • Des corrections ont Ă©tĂ© apportĂ©es aux composants DRM (Direct Rendering Manager), notamment des pannes dans le pilote radeondrm sur les systĂšmes Powerbook5/6 et RV350. La prise en charge de DRI3 a Ă©tĂ© Ă©tablie dans les pilotes amdgpu et ati, et la crĂ©ation de pĂ©riphĂ©riques dans le rĂ©pertoire /dev/dri/ a Ă©tĂ© mise en Ɠuvre pour assurer la compatibilitĂ© avec Linux.
  • Des amĂ©liorations ont Ă©tĂ© apportĂ©es Ă  l'hyperviseur VMM. Dans le backend pour la gestion des machines virtuelles vmd, la prise en charge du dĂ©marrage Ă  partir de disques RAM compressĂ©s a Ă©tĂ© ajoutĂ©e.
  • Des amĂ©liorations ont Ă©tĂ© apportĂ©es au sous-systĂšme audio. La possibilitĂ© de fixer sĂ©parĂ©ment les pĂ©riphĂ©riques audio sndio uniquement pour la lecture et uniquement pour l'enregistrement a Ă©tĂ© fournie. Dans sndiod, un filtre passe-bas avec une rĂ©ponse impulsionnelle finie (filtre IIR) d'ordre huit a Ă©tĂ© utilisĂ©, ce qui a permis de rĂ©duire les bruits dus au chevauchement des spectres lors du rééchantillonnage. La fonction de rĂ©duction automatique du volume, lorsque un nouveau programme commence Ă  jouer (autovolume), est dĂ©sactivĂ©e par dĂ©faut, avec un niveau de volume par dĂ©faut fixĂ© Ă  127. Le mixage audio Ă  partir de pĂ©riphĂ©riques alternatifs, ayant un niveau de fonctionnalitĂ© soutenu diffĂ©rent dans sndiod, est autorisĂ©.
  • L'assemblage et l'installation du dĂ©bogueur LLDB sont activĂ©s par dĂ©faut.
  • Un support pour le gestionnaire de journaux a Ă©tĂ© ajoutĂ© Ă  rcctl, rc.subr et rc.d, permettant d'organiser la sortie des journaux des processus en arriĂšre-plan envoyant des donnĂ©es vers stdout/stderr.
  • Pour les pavĂ©s tactiles, une option de configuration de la disposition des boutons a Ă©tĂ© fournie via wsconsctl. La gestion des touchers simultanĂ©s a Ă©tĂ© amĂ©liorĂ©e dans wscons.
  • Pour les appareils ARM64, la possibilitĂ© d'utiliser APM pour obtenir des informations sur la consommation d'Ă©nergie et la charge de la batterie a Ă©tĂ© mise en Ɠuvre. Un appel Ă  unveil a Ă©tĂ© utilisĂ© pour limiter l'accĂšs du processus apmd au systĂšme de fichiers.
  • Le support matĂ©riel a Ă©tĂ© Ă©tendu. De nouveaux pilotes acpige (pour gĂ©rer les Ă©vĂ©nements ACPI comme l'appui sur le bouton d'alimentation), pchgpio (pour les contrĂŽleurs GPIO Ă©quipant les PC modernes Intel PCH), ujoy (pour les manettes de jeu), uhidpp (pour les dispositifs Logitech HID++). Le support des extensions AMD Vi et Intel VTD IOMMU pour l'isolation des appareils PCI et la prĂ©vention d'un accĂšs incorrect Ă  la mĂ©moire a Ă©tĂ© ajoutĂ©. Le support des ordinateurs Lynloong LM9002/9003 et LM9013 a Ă©tĂ© ajoutĂ©. Les pilotes pcamux et imxiic ont Ă©tĂ© Ă©tendus pour supporter l'ACPI.
  • Le support des adaptateurs rĂ©seau a Ă©tĂ© amĂ©liorĂ© : mvpp (SFP+ et 10G pour Marvel Armada Ethernet), mvneta (1000base-x et 2500base-x), mvsw (commutateurs Marvel SOHO), rge (support Wake on LAN), Netgear ProSecure UTM25. Pour les pilotes sans fil iwm, iwn et athn, un support pour RA (Adaptation du taux de transmission 802.11n) a Ă©tĂ© ajoutĂ©. Dans la pile sans fil, la sĂ©lection automatique des modes 11a/b/g/n/ac a Ă©tĂ© mise en place lors de l'utilisation de l'interface rĂ©seau comme point d'accĂšs.
  • Dans la pile rĂ©seau, un pilote veb (Virtual Ethernet Bridge) a Ă©tĂ© mis en Ɠuvre. Le support du mode de surveillance a Ă©tĂ© rĂ©alisĂ©, oĂč les paquets entrants sur l'interface rĂ©seau ne sont pas transfĂ©rĂ©s Ă  la pile rĂ©seau pour traitement, mais peuvent faire l'objet d'analyses de trafic, comme BPF. Un nouveau type d'interfaces rĂ©seau, etherbridge, a Ă©tĂ© ajoutĂ©. La possibilitĂ© de redĂ©finir l'adresse source (commande route sourceaddr) pour les programmes, en contournant l'algorithme standard de sĂ©lection des adresses, a Ă©tĂ© fournie. adresses IP L'activation automatique des interfaces rĂ©seau lors de l'activation du mode de configuration automatique (AUTOCONF4 et AUTOCONF6) a Ă©tĂ© assurĂ©e.
  • Dans l'installateur, la fourniture d'une image compressĂ©e du disque RAM (bsd.rd) a Ă©tĂ© mise en Ɠuvre sur toutes les plateformes supportant un tel chargement.
  • La sortie via syslog d'un avertissement concernant l'utilisation dans printf de la substitution de format de chaĂźne «%n» a Ă©tĂ© mise en Ɠuvre.
  • Le dĂ©mon de routage OpenBGPD a ajoutĂ© le support du protocole RTR (Resource Public Key Infrastructure (RPKI) to Router Protocol). La commande « bgpctl show rtr » a Ă©tĂ© ajoutĂ©e pour afficher les informations principales sur les sessions RTR.
  • Le code de ospfd et ospf6d a Ă©tĂ© restructurĂ© pour les unifier avec d'autres dĂ©mons de routage et simplifier leur maintenance. Le support des interfaces rĂ©seau en mode point-Ă -point a Ă©tĂ© mis en place.
  • Le serveur HTTP intĂ©grĂ© httpd a implĂ©mentĂ© de nouvelles options « location (found|notfound) » pour vĂ©rifier l'existence des ressources.
  • L'utilitaire rpki-client a ajoutĂ© le support du protocole RRDP (The RPKI Repository Delta Protocol, RFC 8182). Il est dĂ©sormais possible de spĂ©cifier plusieurs URI dans le fichier TAL.
  • L'utilitaire dig a intĂ©grĂ© le support de RFC 8914 (Extended DNS Error) et RFC 8976 (ZONEMD).
  • Le dhclient a Ă©tĂ© amĂ©liorĂ© pour permettre la spĂ©cification d'options dans les fichiers hostname.if, en utilisant les chaĂźnes « dhcp ».
  • Le dĂ©mon snmpd a implĂ©mentĂ© un support complet de la conversion Trapv1 en Trapv2 (RFC 3584). De nouveaux mots-clĂ©s read, write et notify ont Ă©tĂ© ajoutĂ©s dans snmpd.conf. L'utilitaire snmp prend en charge les Ă©numĂ©rations SMI.
  • Le rĂ©solveur DNS unwind a ajoutĂ© le support de DNS64 et la rĂ©ception de connexions via le port TCP.
  • L'utilitaire ftp a introduit le support des redirections permanentes (RFC 7538) et la possibilitĂ© d'envoyer l'en-tĂȘte If-Modified-Since lors de l'envoi de requĂȘtes HTTP/HTTPS.
  • Dans OpenSMTPD, une nouvelle option « -a » a Ă©tĂ© ajoutĂ©e pour effectuer l'authentification avant l'envoi du message. Les outils de cryptage ont Ă©tĂ© dĂ©placĂ©s pour utiliser la bibliothĂšque libtls. Dans les sockets d'Ă©coute pour TLS, il est dĂ©sormais possible de configurer plusieurs certificats sĂ©lectionnĂ©s en fonction du nom de domaine (SNI).
  • LibreSSL a ajoutĂ© le support du protocole DTLSv1.2. Il est dĂ©sormais possible de compiler uniquement libtls (‘—enable-libtls-only’) sans libcrypto et libssl.
  • Le paquet OpenSSH a Ă©tĂ© mis Ă  jour. Un aperçu dĂ©taillĂ© des amĂ©liorations peut ĂȘtre consultĂ© ici : OpenSSH 8.5, OpenSSH 8.6.
  • Le nombre de ports pour l'architecture AMD64 est de 11310, pour aarch64 — 10943, pour i386 — 10468. Parmi les versions des applications dans les ports : Xfce 4.16, Asterisk 18.3.0, Chromium 90.0.4430.72, FFmpeg 4.3.2, GCC 8.4.0, GNOME 3.38, Go 1.16.2, KDE Applications 20.12.3, Krita 4.4.3, LLVM/Clang 10.0.1, LibreOffice 7.0.5.2, Lua 5.3.6, MariaDB 10.5.9, Firefox 88.0 et ESR 78.10.0, Thunderbird 78.10.0, Node.js 12.16.1, PHP 8.0.3, Postfix 3.5.10, PostgreSQL 13.2, Python 3.9.2, Ruby 3.0.1, Rust 1.51.0.

    Les composants de tiers inclus dans OpenBSD 6.9 ont été mis à jour :

    • Le stack graphique Xenocara basĂ© sur X.Org 7.7 avec xserver 1.20.10 + patches, freetype 2.10.4, fontconfig 2.12.4, Mesa 20.0.8, xterm 367, xkeyboard-config 2.20, fonttosfnt 1.2.1.
    • LLVM/Clang 10.0.1 (+ correctifs)
    • GCC 4.2.1 (+ patchs) et 3.3.6 (+ patchs)
    • Perl 5.32.1 (+ patchs)
    • NSD 4.3.6
    • Unbound 1.13.1
    • Ncurses 5.7
    • Binutils 2.17 (+ correctifs)
    • Gdb 6.3 (+ patch)
    • Awk 18.12.2020
    • Expat 2.2.10

La sortie de la version OpenBSD 6.9 s'accompagne d'une nouvelle chanson « Vetera Novis ».

Source : opennet.ru

Acheter un hĂ©bergement fiable pour les sites avec protection DDoS, serveurs VPS VDS đŸ”„ Acheter un hĂ©bergement fiable pour les sites avec protection DDoS, serveurs VPS VDS | ProHoster