Catégorie : Blog

Sortie d'OpenRGB 0.6, un outil de gestion des appareils RGB

Un nouveau lancement d'OpenRGB 0.6, un outil libre de gestion des appareils équipés de rétroéclairage RGB, a été publié. Le paquet prend en charge les cartes mères ASUS, Gigabyte, ASRock et MSI avec une sous-système RGB pour l'éclairage du boîtier, les modules de mémoire rétroéclairés de ASUS, Patriot, Corsair et HyperX, les cartes graphiques ASUS Aura/ROG, MSI GeForce, Sapphire Nitro et Gigabyte Aorus, et divers contrôleurs de bande LED (ThermalTake, Corsair, NZXT Hue+), […]

Pour le langage D, un runtime pour la programmation des microcontrôleurs a été présenté.

Dylan Graham a présenté un runtime léger LWDR pour la programmation en D sur des microcontrôleurs équipés d'un système d'exploitation temps réel (RTOS). La version actuelle cible les microcontrôleurs ARM Cortex-M. Le développement ne vise pas une couverture complète de toutes les capacités de D, mais fournit des outils de base. La gestion de la mémoire est effectuée manuellement (new / delete), le ramasse-miettes n'est pas implémenté, mais un certain nombre de hooks sont disponibles pour […]

Sortie du serveur d'applications NGINX Unit 1.24.0

La version 1.24 du serveur d'applications NGINX Unit a été publiée, développant une solution pour le démarrage d'applications web dans plusieurs langages de programmation (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js et Java). Sous NGINX Unit, plusieurs applications dans différents langages peuvent s'exécuter simultanément, et les paramètres de démarrage peuvent être modifiés dynamiquement sans avoir besoin de modifier les fichiers de configuration et de redémarrer. Le code […]

Version Electron 13.0.0, plateforme de création d'applications basée sur le moteur Chromium

La version 13.0.0 de la plateforme Electron a été préparée, fournissant un cadre autonome pour le développement d'applications utilisateurs multiplateformes, utilisant les composants Chromium, V8 et Node.js comme base. Le changement significatif de numéro de version est dû à la mise à jour vers la base de code Chromium 91, la plateforme Node.js 14.16 et le moteur JavaScript V8 9.1. Parmi les changements dans cette nouvelle version : Ajout de la propriété process.contextIsolated pour déterminer l'exécution actuelle […]

Sortie de la bibliothèque PCRE2 10.37

La version 10.37 de la bibliothèque PCRE2 a été publiée, offrant un ensemble de fonctions en langage C pour la mise en œuvre des expressions régulières et des outils de correspondance de motifs, proches en syntaxe et en sémantique des expressions régulières du langage Perl 5. PCRE2 constitue une réécriture de la bibliothèque originale PCRE avec une API incompatible et des fonctionnalités étendues. La bibliothèque a été développée par les créateurs du serveur de messagerie Exim et est distribuée […]

Microsoft a lancé le gestionnaire de paquets Windows Package Manager 1.0, similaire à apt et dnf.

Microsoft a publié la version 1.0 (winget) de son gestionnaire de paquets Windows Package Manager, offrant des outils pour installer des applications via la ligne de commande. Le code est écrit en C++ et est distribué sous licence MIT. Les paquets sont installés depuis un dépôt soutenu par la communauté. Contrairement à l'installation de programmes à partir du Microsoft Store, winget permet d'installer des applications sans marketing excessif et […]

Publications de la version 6.0 du gestionnaire de paquets Pacman et de l'installateur Archinstall 2.2.0

De nouvelles versions du gestionnaire de paquets Pacman 6.0.0 et de l'installateur Archinstall 2.2.0, utilisés dans la distribution Arch Linux, sont disponibles. Les principales modifications dans Pacman 6.0 incluent : ajout de la prise en charge du téléchargement de fichiers sur plusieurs flux parallèles, mise en œuvre d'une chaîne d'affichage indiquant la progression des téléchargements. Pour désactiver l'indicateur de progression, il est possible d'indiquer l'option «—noprogressbar» dans pacman.conf. Un contournement automatique des miroirs est assuré en cas de problèmes d'accès à ces derniers […]

Le code du service de vérification des mots de passe HaveIBeenPwned est maintenant ouvert

Troy Hunt a ouvert le code source du service de vérification de mots de passe compromis «Have I Been Pwned?» (haveibeenpwned.com), qui permet de vérifier une base de données contenant 11,2 milliards de comptes compromis à la suite de violations de 538 sites. L'annonce de l'intention d'ouvrir le code du projet a été faite en août dernier, mais le processus a pris du temps et le code n'a été publié que maintenant. Le code du service est écrit en […]

Mozilla a résumé ses plans pour prendre en charge la troisième version du manifeste Chrome dans Firefox

Mozilla a publié son plan de mise en œuvre de la troisième version du manifeste Chrome dans Firefox, définissant les capacités et ressources accessibles aux extensions. La troisième version du manifeste a été critiquée pour avoir perturbé le fonctionnement de nombreuses extensions de blocage de contenu indésirable et de sécurité. Firefox prévoit de mettre en œuvre presque toutes les fonctionnalités et restrictions du nouveau manifeste, y compris l'API déclarative pour le filtrage de contenu (declarativeNetRequest), […]

Le protocole QUIC a obtenu le statut de norme proposée

Le Comité IETF (Internet Engineering Task Force), qui s'occupe du développement des protocoles et de l'architecture de l'internet, a finalisé la formation de la RFC pour le protocole QUIC et a publié les spécifications associées sous les identifiants RFC 8999 (propriétés du protocole indépendantes de la version), RFC 9000 (transport sur UDP), RFC 9001 (chiffrement TLS du canal de communication QUIC) et RFC 9002 (gestion de la surcharge et détection de la perte de paquets lors de la transmission de données). […]

La société Virtuozzo a publié une distribution VzLinux, visant à remplacer CentOS 8

La société Virtuozzo (anciennement une division de Parallels), spécialisée dans le développement de logiciels serveur pour la virtualisation basés sur des projets open source, a commencé la distribution publique de la distribution VzLinux, qui était auparavant utilisée comme système d'exploitation de base pour la plateforme de virtualisation développée par l'entreprise et divers produits commerciaux. Désormais, VzLinux est disponible pour tous et se positionne comme un substitut à CentOS 8, prêt pour des déploiements en production. Pour le téléchargement […]

Lancement de la distribution Simply Linux 9.1

La société Basalt SPO a annoncé la sortie de la distribution Simply Linux 9.1, construite sur la base de la neuvième plateforme ALT. Le produit est distribué dans le cadre d'un contrat de licence qui ne transfère pas le droit de distribution de la distribution, mais qui permet une utilisation illimitée du système par des personnes physiques et morales. La distribution est fournie dans des versions pour les architectures x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (bêta) et peut […]

Acheter un hébergement fiable pour les sites avec protection DDoS, serveurs VPS VDS 🔥 Acheter un hébergement fiable pour les sites avec protection DDoS, serveurs VPS VDS | ProHoster