{"id":111732,"date":"2023-11-24T15:10:17","date_gmt":"2023-11-24T13:10:17","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic"},"modified":"2023-11-24T15:10:17","modified_gmt":"2023-11-24T13:10:17","slug":"vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","status":"publish","type":"post","link":"https:\/\/prohoster.info\/fr\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","title":{"rendered":"Sortie d'OpenSSL 3.2.0 avec support client du protocole QUIC","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>Apr\u00e8s huit mois de d\u00e9veloppement, la version de la biblioth\u00e8que OpenSSL 3.2.0 a \u00e9t\u00e9 finalis\u00e9e avec l'impl\u00e9mentation des protocoles SSL\/TLS et de divers algorithmes de cryptage. Le support d'OpenSSL 3.2 sera assur\u00e9 jusqu'au 23 novembre 2025. Le support des anciennes branches OpenSSL 3.1 et 3.0 LTS se prolongera jusqu'en mars 2025 et septembre 2026 respectivement. Le support de la branche 1.1.1 a cess\u00e9 en septembre de cette ann\u00e9e. Le code du projet est distribu\u00e9 sous la licence Apache 2.0.    <\/p>\n<p>Principales nouveaut\u00e9s d'OpenSSL 3.2.0 :   <\/p>\n<ul>\n<li class=\"l\"> Ajout du support client pour le protocole QUIC (RFC 9000), utilis\u00e9 comme transport dans le protocole HTTP\/3. La mise en \u0153uvre inclut notamment la possibilit\u00e9 de transmettre plusieurs flux sur un seul canal de communication. Les composants pour l'utilisation de QUIC sur <a class=\"wpil_keyword_link\" href=\"https:\/\/prohoster.info\/fr\/server\/dts-gdansk\/\"   title=\"serveurs\" data-wpil-keyword-link=\"linked\"  data-wpil-monitor-id=\"4541\">serveurs<\/a> seront inclus dans la version OpenSSL 3.3, qui est pr\u00e9vue pour \u00eatre publi\u00e9e au plus tard le 30 avril 2024.\n<p>QUIC est une superstructure sur le protocole UDP, supportant le multiplexage de plusieurs connexions et offrant des m\u00e9thodes de chiffrement \u00e9quivalentes \u00e0 TLS\/SSL. Le protocole a \u00e9t\u00e9 cr\u00e9\u00e9 en 2013 par Google comme une alternative \u00e0 la combinaison TCP+TLS pour le Web, afin de r\u00e9soudre les probl\u00e8mes de latence dans l'\u00e9tablissement et la n\u00e9gociation des connexions TCP et d'\u00e9liminer les retards caus\u00e9s par la perte de paquets lors de la transmission des donn\u00e9es.       <\/p>\n<li class=\"l\"> Le TLS a mis en \u0153uvre le support de l'extension pour la compression des certificats lors de l'\u00e9tape de n\u00e9gociation des connexions (RFC 8879), permettant d'acc\u00e9l\u00e9rer l'\u00e9tablissement de la connexion, car la transmission des donn\u00e9es des certificats repr\u00e9sente une part importante du trafic \u00e0 cette \u00e9tape. La compression est support\u00e9e en utilisant les biblioth\u00e8ques zlib, zstd et Brotli.\n<li class=\"l\"> Ajout du support d'une variante d\u00e9terministe des signatures num\u00e9riques ECDSA (Deterministic ECDSA, RFC 6979) o\u00f9, au lieu d'une s\u00e9quence al\u00e9atoire lors de la g\u00e9n\u00e9ration de la signature, un hachage HMAC-SHA256 de la cl\u00e9 priv\u00e9e et du texte du message sign\u00e9 est utilis\u00e9, ce qui permet d'obtenir toujours la m\u00eame signature dans diff\u00e9rentes op\u00e9rations de signature, mais emp\u00eache les fuites d'informations pouvant \u00eatre utilis\u00e9es pour d\u00e9duire la cl\u00e9 priv\u00e9e (la cl\u00e9 priv\u00e9e peut \u00eatre d\u00e9duite si au moins deux signatures pour des donn\u00e9es diff\u00e9rentes sont g\u00e9n\u00e9r\u00e9es \u00e0 l'aide d'une s\u00e9quence al\u00e9atoire r\u00e9p\u00e9t\u00e9e).\n<li class=\"l\"> Ajout du support de variantes \u00e9tendues des signatures num\u00e9riques \u00e0 cl\u00e9 publique Ed25519 et Ed448 : Ed25519ctx, Ed25519ph et Ed448ph (RFC 8032).\n<li class=\"l\"> Prise en charge du mode de cryptage AES-GCM-SIV (RFC 8452), qui combine les performances \u00e9lev\u00e9es du mode GCM (Galois\/Counter Mode) avec la r\u00e9sistance aux fuites lors de la r\u00e9utilisation du code nonce.\n<li class=\"l\"> Impl\u00e9mentation de la fonction de g\u00e9n\u00e9ration de cl\u00e9 Argon2 (RFC 9106), qui a remport\u00e9 le concours de fonctions de hachage de mots de passe en 2015. Ajout de la possibilit\u00e9 d'utiliser un pool de threads.\n<li class=\"l\"> Ajout de la prise en charge du cryptage hybride bas\u00e9 sur le m\u00e9canisme HPKE (Hybrid Public Key Encryption, RFC 9180), combinant la simplicit\u00e9 de la transmission de cl\u00e9 dans le cryptage \u00e0 cl\u00e9 publique avec la haute performance du cryptage sym\u00e9trique (les donn\u00e9es sont chiffr\u00e9es avec une cl\u00e9 sym\u00e9trique rapide, tandis que cette cl\u00e9 est chiffr\u00e9e avec une cl\u00e9 asym\u00e9trique lente).\n<li class=\"l\"> TLS permet l'utilisation de cl\u00e9s publiques \u00ab brutes \u00bb (raw) (RFC 7250).\n<li class=\"l\"> Ajout du support du m\u00e9canisme d'ouverture rapide des connexions TCP (TFO \u2014 TCP Fast Open, RFC 7413), qui r\u00e9duit le nombre d'\u00e9tapes d'\u00e9tablissement de la connexion en combinant en une seule requ\u00eate les premi\u00e8re et deuxi\u00e8me \u00e9tapes du processus classique d'\u00e9tablissement de connexion en trois \u00e9tapes, et permet l'envoi de donn\u00e9es d\u00e8s le d\u00e9but de l'\u00e9tablissement de la connexion.\n<li class=\"l\"> Dans TLS, prise en charge de sch\u00e9mas de signature num\u00e9rique connectables, permettant d'utiliser des impl\u00e9mentations tierces d'algorithmes, par exemple, pour utiliser dans TLS des algorithmes r\u00e9sistants \u00e0 la recherche sur des ordinateurs quantiques.\n<li class=\"l\"> Dans TLS 1.3, ajout de la prise en charge des courbes elliptiques prot\u00e9g\u00e9es Brainpool.\n<li class=\"l\"> Ajout du support des instructions de processeur SM4-XTS.\n<li class=\"l\"> Sur la plateforme Windows, il est possible d'utiliser le magasin syst\u00e8me des certificats racines (d\u00e9sactiv\u00e9 par d\u00e9faut). Pour acc\u00e9der aux certificats dans le magasin Windows, un URI \u00ab org.openssl.winstore:\/\/ \u00bb est propos\u00e9.     <\/ul>\n<p>Source : <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=60174\">opennet.ru<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 \u043f\u0440\u043e\u0448\u043b\u044b\u0445 \u0432\u0435\u0442\u043e\u043a OpenSSL 3.1 \u0438 3.0 LTS \u043f\u0440\u043e\u0434\u043b\u0438\u0442\u0441\u044f \u0434\u043e \u043c\u0430\u0440\u0442\u0430 2025 \u0433\u043e\u0434\u0430 \u0438 \u0441\u0435\u043d\u0442\u044f\u0431\u0440\u044f 2026 \u0433\u043e\u0434\u0430 \u0441\u043e\u043e\u0442\u0432\u0435\u0442\u0441\u0442\u0432\u0435\u043d\u043d\u043e. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 \u0432\u0435\u0442\u043a\u0438 1.1.1 \u043f\u0440\u0435\u043a\u0440\u0430\u0449\u0435\u043d\u0430 \u0432 \u0441\u0435\u043d\u0442\u044f\u0431\u0440\u0435 \u044d\u0442\u043e\u0433\u043e \u0433\u043e\u0434\u0430. \u041a\u043e\u0434 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-111732","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.2.1 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/fr\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic\" \/>\n\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.2.1\" \/>\n\t\t<meta property=\"og:locale\" content=\"fr_FR\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u0412\u044b\u043f\u0443\u0441\u043a OpenSSL 3.2.0 \u0441 \u043a\u043b\u0438\u0435\u043d\u0442\u0441\u043a\u043e\u0439 \u043f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u043e\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/fr\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-11-24T13:10:17+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-11-24T13:10:17+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47Lancement d'OpenSSL 3.2.0 avec prise en charge client du protocole QUIC | ProHoster","description":"Apr\u00e8s huit mois de d\u00e9veloppement, la version de la biblioth\u00e8que OpenSSL 3.2.0 a \u00e9t\u00e9 finalis\u00e9e avec la mise en \u0153uvre des protocoles SSL\/TLS et divers algorithmes de cryptage. La prise en charge d'OpenSSL 3.2 sera assur\u00e9e jusqu'au 23 novembre 2025.","canonical_url":"https:\/\/prohoster.info\/fr\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"fr_FR","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u0412\u044b\u043f\u0443\u0441\u043a OpenSSL 3.2.0 \u0441 \u043a\u043b\u0438\u0435\u043d\u0442\u0441\u043a\u043e\u0439 \u043f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u043e\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC | ProHoster","og:description":"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.","og:url":"https:\/\/prohoster.info\/fr\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-11-24T13:10:17+00:00","article:modified_time":"2023-11-24T13:10:17+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/posts\/111732","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/comments?post=111732"}],"version-history":[{"count":1,"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/posts\/111732\/revisions"}],"predecessor-version":[{"id":164419,"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/posts\/111732\/revisions\/164419"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/media?parent=111732"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/categories?post=111732"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/tags?post=111732"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}