{"id":112077,"date":"2023-12-08T15:10:14","date_gmt":"2023-12-08T13:10:14","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp"},"modified":"2023-12-08T15:10:14","modified_gmt":"2023-12-08T13:10:14","slug":"avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","status":"publish","type":"post","link":"https:\/\/prohoster.info\/fr\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","title":{"rendered":"L'auteur de GnuPG a fond\u00e9 LibrePGP, fork de la norme OpenPGP","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>Werner Koch, le d\u00e9veloppeur principal et cr\u00e9ateur du projet GnuPG (GNU Privacy Guard), a fond\u00e9 le projet LibrePGP, ax\u00e9 sur le d\u00e9veloppement d'une sp\u00e9cification mise \u00e0 jour, alternative \u00e0 la norme OpenPGP. Le fork a \u00e9t\u00e9 cr\u00e9\u00e9 en r\u00e9ponse aux changements pr\u00e9vus par le groupe de travail IETF pour la prochaine mise \u00e0 jour de la sp\u00e9cification OpenPGP (RFC-4880) et que Koch consid\u00e8re comme douteux en ce qui concerne la compatibilit\u00e9 et la s\u00e9curit\u00e9. Les d\u00e9veloppeurs soutenant le fork provenant des projets GnuPG, RNP (la mise en \u0153uvre OpenPGP de Thunderbird) et Gpg4win craignent que les changements propos\u00e9s nuisent aux mises en \u0153uvre existantes des applications bas\u00e9es sur OpenPGP, dont les utilisateurs comptent sur la stabilit\u00e9 de la sp\u00e9cification \u00e0 long terme et ne sont pas pr\u00eats \u00e0 accepter des modifications compromettant la compatibilit\u00e9.    <\/p>\n<p>LibrePGP comprend des am\u00e9liorations utiles, d\u00e9velopp\u00e9es ces derni\u00e8res ann\u00e9es pour une future version de la sp\u00e9cification OpenPGP, tout en excluant les modifications ayant un impact n\u00e9gatif sur la compatibilit\u00e9. Par exemple, par rapport \u00e0 la norme actuelle RFC-4880, LibrePGP a adopt\u00e9 les fonctionnalit\u00e9s suivantes :  <\/p>\n<ul>\n<li class=\"l\"> Prise en charge de l'algorithme de chiffrement Camellia (RFC-5581),\n<li class=\"l\"> Extensions ECC (Elliptic Curve Cryptography) pour OpenPGP (RFC-6637).\n<li class=\"l\"> Prise en charge obligatoire des hachages SHA2-256 (SHA-1 et MD5 sont consid\u00e9r\u00e9s comme non recommand\u00e9s, et la possibilit\u00e9 de d\u00e9chiffrer des donn\u00e9es sans v\u00e9rification d'int\u00e9grit\u00e9 est consid\u00e9r\u00e9e comme totalement obsol\u00e8te).\n<li class=\"l\"> Augmentation \u00e0 256 bits de la taille du fingerprint.\n<li class=\"l\"> Prise en charge du sch\u00e9ma de signatures num\u00e9riques EdDSA et des courbes elliptiques BrainpoolP256r1, BrainpoolP384r1, BrainpoolP512r1, Ed25519, Curve25519, Ed488 et X448.\n<li class=\"l\"> Prise en charge de l'algorithme CRYSTALS-Kyber, r\u00e9sistant aux attaques par ordinateurs quantiques.\n<li class=\"l\"> Prise en charge des modes de chiffrement authentifi\u00e9 OCB (Offset codebook mode).\n<li class=\"l\"> Impl\u00e9mentation de la cinqui\u00e8me version du format de signatures num\u00e9riques avec protection des m\u00e9tadonn\u00e9es.\n<li class=\"l\"> Prise en charge des sous-paquets \u00e9tendus avec des signatures num\u00e9riques.  <\/ul>\n<p>\u00c9l\u00e9ments principaux de la critique de la nouvelle sp\u00e9cification OpenPGP :  <\/p>\n<ul>\n<li class=\"l\"> Le groupe de travail IETF, au lieu de proc\u00e9der \u00e0 une mise \u00e0 jour incr\u00e9mentale progressive de la sp\u00e9cification, a tent\u00e9 de r\u00e9inventer compl\u00e8tement la norme et d'y apporter des changements significatifs qui compromettent la compatibilit\u00e9.\n<li class=\"l\"> Imposition de la prise en charge du mode de chiffrement sym\u00e9trique GCM (Galois\/Counter Mode), qui est difficile \u00e0 mettre en \u0153uvre correctement, en ignorant le mode OCB (Offset Codebook Mode), dont les brevets ont expir\u00e9 depuis plusieurs ann\u00e9es.\n<li class=\"l\"> Ajout de paquets optionnels avec un remplissage al\u00e9atoire suppl\u00e9mentaire pour \u00e9viter l'analyse du trafic. Selon les cr\u00e9ateurs de LibrePGP, de tels paquets avec un remplissage al\u00e9atoire initial non v\u00e9rifiable posent une menace d'utilisation pour cr\u00e9er des canaux de transmission de donn\u00e9es cach\u00e9s et contourner les syst\u00e8mes de pr\u00e9vention des fuites de donn\u00e9es. Auparavant, l'id\u00e9e d'inclure un remplissage suppl\u00e9mentaire \u00e9tait rejet\u00e9e, consid\u00e9r\u00e9e comme un enjeu non pas au niveau du chiffrement, mais au niveau de l'application.\n<li class=\"l\"> Utilisation d'un sch\u00e9ma de chiffrement ECDH modifi\u00e9 (changement de format OID), au lieu d'utiliser l'option d\u00e9j\u00e0 d\u00e9crite dans la RFC-6637 et mise en \u0153uvre dans PGP et GnuPG.\n<li class=\"l\"> Suppression de certaines fonctionnalit\u00e9s pratiques, telles que la m\u00e9thode classique de r\u00e9vocation des cl\u00e9s, le drapeau &#171;m&#187; pour marquer les donn\u00e9es MIME et le drapeau &#171;t&#187; pour s\u00e9parer les donn\u00e9es textuelles des donn\u00e9es binaires (le drapeau &#171;t&#187; a \u00e9t\u00e9 remplac\u00e9 par le drapeau &#171;u&#187; pour le texte en codage UTF-8).\n<li class=\"l\"> Refus d'inclure dans le nouveau format de signature la protection des m\u00e9tadonn\u00e9es du fichier sign\u00e9 (par exemple, il est possible de changer le nom du fichier sans violer la signature).\n<li class=\"l\"> Possibilit\u00e9 douteuse d'ajouter du &#171;sel&#187; aux signatures (Salted signature) pour renforcer la protection contre les attaques par collision avec un pr\u00e9fixe donn\u00e9. La valeur avec sel peut \u00eatre utilis\u00e9e comme un canal cach\u00e9 non d\u00e9sactivable pour transmettre 32 octets de donn\u00e9es dans la signature.\n<li class=\"l\"> D\u00e9placement de la norme vers une utilisation principale pour la communication en ligne, ignorant les besoins de conservation \u00e0 long terme des donn\u00e9es.  <\/ul>\n<p>Les partisans d'OpenPGP ont d\u00e9j\u00e0 publi\u00e9 des critiques \u00e0 l'encontre de cette critique. En cons\u00e9quence, si aucun compromis n'est trouv\u00e9, la scission pourrait entra\u00eener une augmentation des incompatibilit\u00e9s dans les mises en \u0153uvre d'OpenPGP\/LibrePGP. En partie pour r\u00e9soudre ce probl\u00e8me, les d\u00e9veloppeurs d'OpenPGP ont fix\u00e9 la cinqui\u00e8me version du format de signature de mani\u00e8re compatible avec LibrePGP et ont commenc\u00e9 \u00e0 travailler sur la sixi\u00e8me version.<br \/>\n<br \/>Source : <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=60256\">opennet.ru<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP. \u0424\u043e\u0440\u043a \u0431\u044b\u043b \u0441\u043e\u0437\u0434\u0430\u043d \u0432 \u043e\u0442\u0432\u0435\u0442 \u043d\u0430 \u0438\u0437\u043c\u0435\u043d\u0435\u043d\u0438\u044f, \u043d\u0430\u043c\u0435\u0447\u0435\u043d\u043d\u044b\u0435 \u0440\u0430\u0431\u043e\u0447\u0435\u0439 \u0433\u0440\u0443\u043f\u043f\u043e\u0439 IETF \u0434\u043b\u044f \u0432\u043d\u0435\u0441\u0435\u043d\u0438\u044f \u0432 \u0441\u043b\u0435\u0434\u0443\u044e\u0449\u0435\u0435 \u043e\u0431\u043d\u043e\u0432\u043b\u0435\u043d\u0438\u0435 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438 OpenPGP (RFC-4880) \u0438 \u0432\u043e\u0441\u043f\u0440\u0438\u043d\u044f\u0442\u044b\u0435 \u041a\u043e\u0445\u043e\u043c \u043a\u0430\u043a \u0441\u043e\u043c\u043d\u0438\u0442\u0435\u043b\u044c\u043d\u044b\u0435 \u0441 \u0442\u043e\u0447\u043a\u0438 \u0437\u0440\u0435\u043d\u0438\u044f \u0441\u043e\u0445\u0440\u0430\u043d\u0435\u043d\u0438\u044f \u0441\u043e\u0432\u043c\u0435\u0441\u0442\u0438\u043c\u043e\u0441\u0442\u0438 \u0438 \u043e\u0431\u0435\u0441\u043f\u0435\u0447\u0435\u043d\u0438\u044f [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-112077","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.2 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/fr\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp\" \/>\n\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.2\" \/>\n\t\t<meta property=\"og:locale\" content=\"fr_FR\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u0410\u0432\u0442\u043e\u0440 GnuPG \u043e\u0441\u043d\u043e\u0432\u0430\u043b LibrePGP, \u0444\u043e\u0440\u043a \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0430 OpenPGP | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/fr\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-12-08T13:10:14+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-12-08T13:10:14+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47L'auteur de GnuPG a fond\u00e9 LibrePGP, un fork de la norme OpenPGP | ProHoster","description":"Werner Koch, d\u00e9veloppeur principal et cr\u00e9ateur du projet GnuPG (GNU Privacy Guard), a fond\u00e9 le projet LibrePGP, ax\u00e9 sur le d\u00e9veloppement d'une sp\u00e9cification mise \u00e0 jour, alternative \u00e0 la norme OpenPGP.","canonical_url":"https:\/\/prohoster.info\/fr\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"fr_FR","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u0410\u0432\u0442\u043e\u0440 GnuPG \u043e\u0441\u043d\u043e\u0432\u0430\u043b LibrePGP, \u0444\u043e\u0440\u043a \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0430 OpenPGP | ProHoster","og:description":"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.","og:url":"https:\/\/prohoster.info\/fr\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-12-08T13:10:14+00:00","article:modified_time":"2023-12-08T13:10:14+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/posts\/112077","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/comments?post=112077"}],"version-history":[{"count":0,"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/posts\/112077\/revisions"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/media?parent=112077"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/categories?post=112077"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/fr\/wp-json\/wp\/v2\/tags?post=112077"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}