QUIC protokol dobio je status predloženog standarda

IETF (Internet Engineering Task Force), koji se bavi razvojem protokola i arhitekture interneta, završio je izradu RFC-a za QUIC protokol i objavio povezane specifikacije sa identifikatorima RFC 8999 (karakteristike protokola neovisne o verziji), RFC 9000 (transport preko UDP-a), RFC 9001 (TLS šifriranje QUIC komunikacijskog kanala) i RFC 9002 (upravljanje opterećenjem i određivanje gubitka paketa prilikom prijenosa podataka).

RFC-ovi su dobili status 'Predloženog standarda', nakon čega će započeti rad na stjecanju statusa nacrtnog standarda (Draft Standard), što zapravo znači potpunu stabilizaciju protokola i uvažavanje svih iznijetih komentara. HTTP/3 protokol, koji definira upotrebu QUIC protokola kao transporta za HTTP/2, trenutno je u fazi nacrtne specifikacije, ali i on će uskoro biti konačno standardiziran u IETF-u.

Očekuje se da će standardizacija QUIC-a potaknuti širu primjenu ovog protokola, kao i razvoj ekstenzija temeljenih na njemu, poput WebTransport (tehnologija za prijenos i primanje podataka između preglednika i serverom) i MASQUE (tehnologija za proksi veze koja proširuje mogućnosti SOCKS i HTTP CONNECT, koristeći HTTPS preko QUIC-a kao transport).

Podsjetimo, QUIC (Quick UDP Internet Connections) protokol razvija Google od 2013. godine kao alternativu kombinaciji TCP+TLS za web, rješavajući probleme s dugim vremenom uspostave i usklađivanja veza na TCP-u i eliminirajući latenciju pri gubitku paketa tijekom prijenosa podataka. QUIC predstavlja nadogradnju na UDP protokol, podržavajući multiplexiranje više veza i osiguravajući metode šifriranja ekvivalentne TLS/SSL-u. Tijekom razvoja standarda u IETF-u, protokol je podvrgnut promjenama, što je dovelo do postojanja dvije paralelne grane, jedna za HTTP/3, a druga koju podržava Google (Chrome podržava obje verzije, dok Firefox podržava samo verziju IETF-a).

Glavne značajke QUIC-a:

  • Visoka sigurnost, slična TLS-u (u suštini QUIC pruža mogućnost korištenja TLS-a preko UDP-a);
  • Kontrola cjelovitosti toka, koja sprječava gubitak paketa;
  • Mogućnost trenutne uspostave veze (0-RTT, podaci se u približno 75% slučajeva mogu prenositi odmah nakon slanja paketa za uspostavu veze) i osiguranje minimalnih kašnjenja između slanja zahtjeva i primanja odgovora (RTT, Round Trip Time);
  • Korištenje drugog broja sekvencijalnog paketa prilikom ponovnog slanja, što omogućava izbjegavanje nejasnoća prilikom određivanja primljenih paketa i eliminira vrijeme čekanja;
  • Gubitak paketa utječe samo na isporuku povezane struje i ne zaustavlja isporuku podataka u paralelno prijenosima kroz trenutno uspostavljene struje;
  • Sredstva za ispravak grešaka, koja minimiziraju kašnjenja uzrokovana ponovnim slanjem izgubljenih paketa. Korištenje specijalnih kodova za ispravak grešaka na razini paketa za smanjenje situacija koje zahtijevaju ponovno slanje podataka izgubljenog paketa.
  • Granice kriptografskih blokova su poravnate s granicama QUIC paketa, što smanjuje utjecaj gubitaka paketa na dekodiranje sadržaja sljedećih paketa;
  • Nema problema s blokiranjem TCP reda;
  • Podrška za identifikator veze, koji omogućava smanjenje vremena potrebnog za ponovnu uspostavu veze za mobilne klijente;
  • Mogućnost povezivanja s proširenim mehanizmima kontrole opterećenja veze;
  • Korištenje tehnike predviđanja propusnosti u svakom smjeru za osiguranje optimalne intenziteta slanja paketa, sprječavajući povratak u stanje preopterećenja u kojem se primjećuje gubitak paketa;
  • Značajan porast performansi i propusnosti u odnosu na TCP. Za videusluge poput YouTubea, primjena QUIC-a pokazala je smanjenje ponovnog buferiranja prilikom gledanja videa za 30%.

Izvor: opennet.ru

Kupite pouzdan hosting za web stranice s DDoS zaštitom, VPS VDS servere 🔥 Kupite pouzdan hosting za web stranice s DDoS zaštitom, VPS VDS servere | ProHoster