Izdanje FreeBSD 12.3

Objavljen je FreeBSD 12.3, koji je dostupan za arhitekture amd64, i386, powerpc, powerpc64, powerpcspe, sparc64 te armv6, armv7 i aarch64. Dodatno su pripremljeni imidži za virtualizacijske sustave (QCOW2, VHD, VMDK, raw) i Amazon EC2 cloud okruženja. Očekuje se objava FreeBSD 13.1 u proljeće 2022.

Ključne novine:

  • Dodana je skripta /etc/rc.final koja se pokreće u posljednjoj fazi rada nakon završetka svih korisničkih procesa.
  • U paketu filtra ipfw unesena je naredba dnctl za upravljanje postavkama sustava ograničenja prometa dummynet.
  • Dodana je sysctl kern.crypto za upravljanje kriptosustavom jezgre, kao i za debagiranje sysctl debug.uma_reclaim.
  • Dodana je sysctl net.inet.tcp.tolerate_missing_ts, koja dopušta TCP pakete bez vremenskih oznaka (opcija timestamp, RFC 1323/RFC 7323).
  • U jezgru GENERIC za arhitekturu amd64 uključena je opcija COMPAT_LINUXKPI i aktiviran je drajver mlx5en (NVIDIA Mellanox ConnectX-4/5/6).
  • U bootloader je dodana mogućnost pokretanja operacijskog sustava s RAM diska, kao i podrška za ZFS opcije com.delphix:bookmark_written i com.datto:bookmark_v2.
  • U biblioteku fetch dodana je podrška za proksiranje FTP-a preko HTTPS-a.
  • U paketu menadžera pkg za naredbe 'bootstrap' i 'add' uvedena je opcija '-r' za naznačavanje repozitorija. Osigurana je upotreba varijabli okruženja iz datoteke pkg.conf.
  • U alatu growfs dodana je mogućnost rada s datotečnim sustavima montiranim u režimu čitanja i pisanja.
  • U alatu etcupdate implementiran je način vraćanja promjena za obnavljanje jedne ili više datoteka. Dodana je opcija '-D' za određivanje ciljanog direktorija. Osigurano je vađenje podataka korištenjem privremenog direktorija i dodana obrada SIGINT.
  • U alatima freebsd-update i freebsd-version dodana je opcija '-j' za podršku jail okruženjima.
  • Alat cpuset sada se može koristiti u jail okruženjima za promjenu postavki podređenih jail-a.
  • U alatu cmp dodane su opcije: '-b' (—print-bytes) za ispis različitih bajtova, '-i' (—ignore-initial) za ignoriranje određenog broja početnih bajtova, '-n' (—bytes) za ograničenje broja uspoređenih bajtova.
  • U alatu daemon uvedena je opcija '-H' za obradu SIGHUP i ponovno otvaranje datoteke u kojoj se vrši ispis (dodano za podršku newsyslog).
  • U alatu fstyp uz opciju '-l' osigurano je određivanje i prikaz datotečnih sustava exFAT.
  • U alatu mergemaster implementirana je obrada simboličkih veza tijekom ažuriranja.
  • Alatu newsyslog dodana je opcija «E» za isključivanje rotacije praznih logova.
  • U alatu tcpdump sada je moguće dekodirati pakete na pfsync sučeljima.
  • U alatu top dodana je filtrirajuća naredba «/» za prikaz samo onih procesa ili argumenata koji odgovaraju zadanom stringu.
  • U unzip dodana je podrška za arhive zaštićene lozinkom.
  • Poboljšana je podrška za hardver. Dodani su PCI identifikatori za AHCI kontrolere ASMedia ASM116x i I2C kontrolere Intel Gemini Lake. Implementirana je podrška za mrežne adaptere Mikrotik 10/25G i bežične kartice Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14. Dodan je novi drajver igc za ethernet kontrolere Intel I225 2.5G/1G/100MB/10MB.
  • Netgraph čvor ng_bridge prilagođen je za SMP sustave. U čvoru ng_nat dodana je podrška za CGN (Carrier Grade NAT, RFC 6598). Omogućena je zamjena čvora ng_source u bilo kojem dijelu Netgraph mreže.
  • U drajveru rctl, koji se koristi za ograničavanje resursa, dodana je mogućnost postavljanja ograničenja potrošnje resursa na vrijednost 0.
  • U sučelju vlan dodana je podrška za sustav prioritizacije prometa i upravljanja propusnošću ALTQ.
  • U drajverima amdtemp i amdsmn implementirana je podrška za CPU Zen 3 «Vermeer» i APU Ryzen 4000 (Zen 2, «Renoir»).
  • Ažurirane su verzije aplikacija trećih strana uključenih u osnovni sustav: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. Alat unzip je sinkroniziran s kodnom bazom NetBSD.

Izvor: opennet.ru

Kupite pouzdan hosting za web stranice s DDoS zaštitom, VPS VDS servere 🔥 Kupite pouzdan hosting za web stranice s DDoS zaštitom, VPS VDS servere | ProHoster