Objavljena je knjižnica nghttp3 1.0 s implementacijom protokola HTTP/3

Dostupan je prvi stabilni izlaz projekta nghttp3, koji razvija biblioteku na jeziku C s implementacijom protokola HTTP/3. Razvijana varijanta biblioteke za protokol HTTP/2 koristi se kao osnova modula mod_http2, koji je deo http servera Apache. Radovi projekta su također uključeni u alat Curl. Kod biblioteke se distribuira pod MIT licencom.

HTTP/3 standard definira upotrebu protokola QUIC (Quick UDP Internet Connections) kao transport za HTTP/2. QUIC je nadogradnja na UDP protokol, koja podržava multiplexiranje više veza i pruža metode šifriranja ekvivalentne TLS/SSL. Protokol je stvorila kompanija Google 2013. godine kao alternativu kombinaciji TCP+TLS za web, rešavajući probleme sa velikim vremenom uspostavljanja i pregovaranja veza u TCP-u te eliminirajući kašnjenja prilikom gubitka paketa tokom prijenosa podataka.

U nghttp3 se pruža neovisna implementacija specifikacija RFC 9114 (HTTP/3 preko QUIC protokola), RFC 920 (tehnologija kompresije zaglavlja QPACK), RFC 9220 (prijenos WebSocket-a preko HTTP/3) i RFC 9218 (proširiva shema za upravljanje prioritetima slanja odgovora na klijentske zahtjeve). Biblioteka nije ovisna o određenim QUIC stakovima i podržava rad preko različitih implementacija transportnog protokola QUIC. Istovremeno, projekt također razvija vlastitu implementaciju QUIC protokola - ngtcp2, koja se koristi prema zadanim postavkama. Kao backendovi za šifriranje podataka u ngtcp2 podržani su quictls, GnuTLS, BoringSSL, Picotls i wolfSSL. U isto vrijeme s nghttp3 1.0 objavljen je i prvi stabilni izlaz ngtcp2 1.0.

Izvor: opennet.ru

Kupite pouzdan hosting za web stranice s DDoS zaštitom, VPS VDS servere 🔥 Kupite pouzdan hosting za web stranice s DDoS zaštitom, VPS VDS servere | ProHoster