Izdanje kriptografijske biblioteke OpenSSL 3.3.0

Nakon pet mjeseci razvoja, oblikovana je nova verzija biblioteke OpenSSL 3.3.0, koja implementira SSL/TLS protokole i razne algoritme šifriranja. Podrška za OpenSSL 3.3 će trajati do travnja 2026. godine. Podrška za prethodne verzije OpenSSL 3.2, 3.1 i 3.0 LTS trajat će do studenog 2025. godine, ožujka 2025. godine i rujna 2026. godine, redom. Izvorni kod projekta distribuirat će se pod Apache 2.0 licencom.

Glavne novosti OpenSSL 3.3.0:

  • Nastavljena je integracija podrške za QUIC protokol (RFC 9000), koji predstavlja nadogradnju na UDP protokol, korišten kao transport u HTTP/3 protokolu. U novom izdanju:
    • Dodana je podrška za praćenje QUIC veza putem dijagnostičkog logiranja u qlog formatu.
    • Dodana je podrška za polling u neblokirajućem režimu za QUIC veze i stream objekte.
    • Implementirana je mogućnost optimizirane generacije završnih okvirâ za QUIC veze.
    • Omogućeno je isključivanje obrade QUIC događaja prilikom pozivanja API-ja.
    • Dodana je podrška za postavku timeout-a za neaktivnost za QUIC.
    • Dodana je API funkcija za upit veličine i stupnja popunjenosti zapisnog buffera za QUIC stream-ove.
  • Implementirane su ekstenzije protokola za upravljanje certifikatima CMP (Certificate Management Protocol), definirane u RFC 9480 (definicija CMPv3 protokola) i RFC 9483 (lagani profil za uređaje s niskom potrošnjom).
  • Dodana je mogućnost isključivanja korištenja atexit funkcije tijekom faze kompilacije.
  • Dodana je SSL_SESSION API varijanta koja nije podložna problemu iz 2038. godine: dodane su funkcije SSL_SESSION_get_time_ex() i SSL_SESSION_set_time_ex(), koje koriste 64-bitni tip time_t na 32-bitnim sistemima.
  • U funkciji EVP_PKEY_fromdata implementirana je mogućnost automatskog dobivanja parametara kineske teoreme ostataka (CRT, Chinese Remainder Theorem).
  • Dodana je mogućnost ignoriranja nepoznatih naziva algoritama potpisa, definiranih u konfiguracijskim parametrima TLS SignatureAlgorithms i ClientSignatureAlgorithms.
  • Dodana je mogućnost postavljanja prioriteta korištenja PSK ključeva na serveru TLS 1.3 tijekom obnavljanja sesije.
  • Dodana je funkcija EVP_DigestSqueeze(), koja omogućuje smanjenje veličine SHAKE hash-a (uklanjanje viših bitova) koristeći više iteracija s različitim veličinama izlaza.
  • Dodana podrška za izvoz datoteka gradnje za CMake na Unix-sličnim sustavima i Windows (uz izvoz temeljen na pkg-config).
  • Izvršene su optimizacije performansi: Optimiziran je rad AES-GCM algoritma na uređajima s Microsoft Azure Cobalt 100 čipovima. U implementaciji AES-CTR dodana je podrška za ubrzanje korištenjem ARM Neoverse V1 i V2 ekstenzija. Uključene su optimizacije AES i SHA3 za Apple sustave s M3 čipovima. U različitim kriptografskim funkcijama korištene su vektorske ekstenzije RISC-V. Dodana je asemberska implementacija md5 za Loongarch64 CPU.

Izvor: opennet.ru

Kupite pouzdan hosting za web stranice s DDoS zaštitom, VPS VDS servere 🔥 Kupite pouzdan hosting za web stranice s DDoS zaštitom, VPS VDS servere | ProHoster