Implementacija kriptografskih algoritama GOST na jeziku Java

Objavljena je biblioteka crypto-gost s implementacijom kriptoalgoritama GOST na jeziku Java, koja ne koristi dodatne zavisnosti. Za razliku od implementacije GOST algoritama iz biblioteke Castle Bouncy Castle, u crypto-gost-u je poboljšana performansa šifriranja algoritmom 'Kuznečik', rešen je niz sigurnosnih problema i pružene su jednostavne obloge koje ne zahtevaju duboko znanje o kriptografiji. Kod se isporučuje pod sopstvenom dozvolom, koja omogućava distribuciju, modifikaciju i stvaranje derivativnih radova bez ograničenja.

Podržani algoritmi:

  • GOST R 34.11-2012 (RFC 6986) — heš funkcija 'Stribog' 256 i 512 bitova.
  • GOST R 34.12-2015 — blok šifriranje 'Kuznečik', ključ 256 bitova.
  • GOST R 34.13-2015 — režimi šifriranja CBC, CFB, CTR (GAMMA), OFB; imitosrava (CMAC).
  • GOST R 34.10-2012 (RFC 7091) — elektronski potpis 256 i 512 bitova.
  • HMAC-Stribog (RFC 7836, HMAC-Streebog-256 i HMAC-Streebog-512).
  • MGM (Multilinear Galois Mode) — AEAD-režim za Kuznečik (RFC 9058). Kompatibilan s OpenSSL.
  • SCrypt (RFC 7914) — funkcija formiranja ključa na osnovu lozinke.

Izvor: opennet.ru

Kupite pouzdan hosting za web stranice s DDoS zaštitom, VPS VDS servere 🔥 Kupite pouzdan hosting za web stranice s DDoS zaštitom, VPS VDS servere | ProHoster