Objavljen je lagani HTTP server lighttpd 1.4.65, koji pokušava spojiti visoke performanse, sigurnost, usklađenost sa standardima i fleksibilnost u konfiguraciji. Lighttpd je pogodan za korištenje u sustavima pod visokim opterećenjem i usmjeren je na nisku potrošnju memorije i CPU resursa. U novoj verziji predstavljene su 173 izmjene. Kod projekta napisan je na jeziku C i distribuira se pod BSD licencom.
Glavne novine:
- Dodana je podrška za WebSocket preko HTTP/2, kao i implementiran RFC 8441, koji opisuje mehanizam za pokretanje WebSocket protokola u jednom dretvi unutar HTTP/2 veze.
- Implementiran je prošireni sustav upravljanja prioritetima, koji omogućuje klijentu da utječe na prioritet prenosivih serverom odgovora (RFC 9218), a također upravlja prioritetima prilikom preusmjeravanja zahtjeva. Za HTTP/2 osigurana je podrška za okvir PRIORITY_UPDATE.
- U postavkama lighttpd.conf dodana je podrška za uvjetna podudaranja s vezom na početak (=^) i kraj (=$) niza. Ove provjere niza su znatno brže od regularnih izraza i dovoljne su za mnoge jednostavne provjere.
- U mod_webdav dodana je podrška za parcijalne operacije PUT (pokrivajući dio podataka pomoću zaglavlja Range). Za omogućavanje, možete koristiti opciju ‘webdav.opts += («partial-put-copy-modify’ => «enable»).
- U mod_accesslog dodana je opcija ‘accesslog.escaping = ‘json'’.
- U mod_deflate dodana je podrška za izgradnju s libdeflate.
- Poboljšan je prijenos tijela zahtjeva putem HTTP/2.
- Zadana vrijednost parametra server.max-keep-alive-requests promijenjena je sa 100 na 1000.
- Na popisu MIME tipova ‘application/javascript’ zamijenjen je s ‘text/javascript’ (RFC 9239).
Za budućnost planirana je primjena strožih postavki šifri za TLS i isključivanje zastarjelih šifri prema zadanim postavkama. Postavka CipherString bit će promijenjena s vrijednosti ‘HIGH’ na ‘EECDH+AESGCM:AES256+EECDH:CHACHA20:SHA256:!SHA384’. Također je planirano uklanjanje zastarjelih TLS opcija: Uklonjena je neiskorištena tabela INFORMATION_SCHEMA.TABLESPACES..honor-cipher-order, ssl.dh-file, ssl.ec-curve, ssl.disable-client-renegotiation, ssl.use-sslv2, ssl.use-sslv3. Dodatno, nastavit će se s čišćenjem mini-modula koji se mogu zamijeniti fleksibilnijom Lua implementacijom mod_magnet. Konkretno, planira se ukloniti module mod_evasive, mod_secdownload, mod_uploadprogress i mod_usertrack.
Izvor: opennet.ru
