Kategorija: Blog

Dostupan je JingOS 0.9, distribucija za tablet uređaje

Objavljen je izdanak JingOS 0.9, koji nudi okruženje posebno optimizirano za instalaciju na tabletima i prijenosnim računalima s dodirnim ekranom. Projekt razvija kineska tvrtka Jingling Tech, koja ima predstavništvo u Kaliforniji. Tim programera uključuje zaposlene koji su prethodno radili u tvrtkama Lenovo, Alibaba, Samsung, Canonical/Ubuntu i Trolltech. Veličina instalacijskog imidža iznosi 3 GB (x86_64). Rezultati projekta distribuiraju se pod licencom […]

Izdanje OpenRGB 0.6, alata za upravljanje uređajima s RGB osvjetljenjem

Objavljen je novi izdanak OpenRGB 0.6, slobodnog alata za upravljanje uređajima s RGB pozadinskim osvjetljenjem. Paket podržava matične ploče ASUS, Gigabyte, ASRock i MSI s RGB podsustavom za osvjetljavanje kućišta, memorijske module s osvjetljenjem od ASUS-a, Patriot-a, Corsair-a i HyperX-a, grafičke kartice ASUS Aura/ROG, MSI GeForce, Sapphire Nitro i Gigabyte Aorus, različite kontrolere LED traka (ThermalTake, Corsair, NZXT Hue+), […]

Za D jezik predstavljen runtime za programiranje mikrokontrolera

Dylan Graham predstavio je lagani runtime LWDR za programiranje na jeziku D mikrokontrolera opremljenih OS-om u stvarnom vremenu (RTOS). Trenutna verzija je usmjerena na mikrokontrolere ARM Cortex-M. Razvoj ne teži potpunom pokrivanju svih mogućnosti D, već pruža osnovna sredstva. Raspodjela memorije provodi se ručno (new / delete), sakupljač smeća nije implementiran, ali postoji niz hook-ova za […]

Izlaz aplikacijskog poslužitelja NGINX Unit 1.24.0

Objavljen je izdanak aplikacijskog poslužitelja NGINX Unit 1.24, u sklopu kojeg se razvija rješenje za pokretanje web aplikacija na različitim programskim jezicima (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js i Java). Pod upravljanjem NGINX Unit može istodobno raditi nekoliko aplikacija na različitim programskim jezicima, čije se parametre pokretanja može dinamički mijenjati bez potrebe za uređivanjem konfiguracijskih datoteka i ponovnim pokretanjem. Kod […]

Izdanje Electron 13.0.0, platforme za razvoj aplikacija temeljenih na Chromium engineu.

Pripremljeno je izdanje platforme Electron 13.0.0, koja pruža samodostatni okvir za razvoj višepatformskih korisničkih aplikacija, koristeći komponente Chromium, V8 i Node.js kao osnovu. Značajna promjena broja verzije povezana je s nadogradnjom na Chromium 91, Node.js 14.16 i JavaScript motor V8 9.1. Među promjenama u novom izdanju: Dodana je svojstvo process.contextIsolated za utvrđivanje izvođenja trenutnog […]

Izdanje biblioteke PCRE2 10.37

Objavljen je novi release PCRE2 biblioteke 10.37, koja pruža skup funkcija na C jeziku za implementaciju regularnih izraza i alata za usporedbu uzoraka (pattern matching) bliskih po sintaksi i semantici regularnim izrazima Perl 5. PCRE2 predstavlja revidiranu implementaciju originalne PCRE biblioteke s nekompatibilnim API-jem i proširenim mogućnostima. Biblioteku su razvili programeri poštanskog servera Exim i distribuira se […]

Microsoft je izdao Windows Package Manager 1.0, koji je sličan apt i dnf.

Tvrtka Microsoft objavila je izdanje Windows Package Manager 1.0 (winget), koji pruža alate za instalaciju aplikacija putem naredbenog retka. Kod je napisan na C++ jeziku i distribuira se pod MIT licencom. Paketi se instaliraju iz repozitorija koji se podržava uz pomoć zajednice. Za razliku od instalacije programa iz Microsoft Store kataloga, winget omogućuje instaliranje aplikacija bez suvišne marketinške buke […]

Izdanje paketnog menadžera Pacman 6.0 i instalatera Archinstall 2.2.0

Dostupni su novi izdanja paketa upravitelja Pacman 6.0.0 i instalatora Archinstall 2.2.0 koji se koriste u Arch Linux distribuciji. Glavne promjene u Pacman 6.0: Dodana je podrška za preuzimanje datoteka u više paralelnih tokova. Uvedena je linija za prikaz napretka preuzimanja podataka. Za isključivanje indikatora napretka, u pacman.conf se može odrediti opcija „—noprogressbar“. Osigurano je automatsko preskakanje zrcala, kada se na njih obraćaju […]

Otvoren kod servisa za provjeru lozinki HaveIBeenPwned

Troy Hunt je otvorio izvorne kodove usluge za provjeru kompromitiranih lozinki „Have I Been Pwned?” (haveibeenpwned.com), koja provjerava bazu od 11.2 milijardi računa ukradenih tijekom hakiranja 538 web stranica. Prvotno je najavljeno otvaranje koda projekta u kolovozu prošle godine, no postupak se odužio i kod je objavljen tek sada. Kod usluge je napisan na […]

Mozilla je sažela planove za podršku trećoj verziji Chrome manifestacije u Firefoxu

Tvrtka Mozilla objavila je plan implementacije treće verzije manifestacijskog dokumenta Chrome u Firefoxu, koji određuje mogućnosti i resurse dostupne dodatcima. Treća verzija manifestacije bila je predmet kritike zbog ometanja rada mnogih dodataka za blokiranje neželjenog sadržaja i osiguranje sigurnosti. U Firefoxu namjeravaju implementirati gotovo sve mogućnosti i ograničenja novog manifestacijskog dokumenta, uključujući deklarativni API za filtriranje sadržaja (declarativeNetRequest), […]

QUIC protokol dobio je status predloženog standarda

IETF (Internet Engineering Task Force) završio je razvoj RFC-a za QUIC protokol i objavio povezane specifikacije pod identifikatorima RFC 8999 (verzijski neovisne osobine protokola), RFC 9000 (transport preko UDP-a), RFC 9001 (TLS enkripcija QUIC komunikacijskog kanala) i RFC 9002 (upravljanje preopterećenjem i određivanje gubitka paketa tijekom prijenosa podataka). […]

Tvrtka Virtuozzo objavila je distribuciju VzLinux, usmjerenog na zamjenu CentOS 8.

Tvrtka Virtuozzo (bivša podružnica tvrtke Parallels), koja razvija softver za poslužitelje temeljen na virtualizaciji otvorenih projekata, započela je javnu distribuciju VzLinux distribucije, koja je ranije korištena kao osnovni operativni sustav za platformu virtualizacije razvijanu od strane tvrtke te različite komercijalne proizvode. Od sada je VzLinux dostupan svima i pozicionira se kao zamjena za CentOS 8, spreman za poslovne implementacije. Za preuzimanje […]

Kupite pouzdan hosting za web stranice s DDoS zaštitom, VPS VDS servere 🔥 Kupite pouzdan hosting za web stranice s DDoS zaštitom, VPS VDS servere | ProHoster