{"id":111732,"date":"2023-11-24T15:10:17","date_gmt":"2023-11-24T13:10:17","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic"},"modified":"2023-11-24T15:10:17","modified_gmt":"2023-11-24T13:10:17","slug":"vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","status":"publish","type":"post","link":"https:\/\/prohoster.info\/hr\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","title":{"rendered":"Izlazak OpenSSL 3.2.0 s podr\u0161kom za QUIC protokol","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>Nakon osam mjeseci razvoja, objavljen je OpenSSL 3.2.0 sa realizacijom SSL\/TLS protokola i razli\u010ditih kriptografskih algoritama. Podr\u0161ka za OpenSSL 3.2 bit \u0107e dostupna do 23. studenog 2025. godine. Podr\u0161ka za prethodne verzije OpenSSL 3.1 i 3.0 LTS trajat \u0107e do o\u017eujka 2025. i rujna 2026. godine, redom. Podr\u0161ka za verziju 1.1.1 prestala je u rujnu ove godine. Izvorni kod projekta distribuirat \u0107e se pod Apache 2.0 licencom.    <\/p>\n<p>Glavne novosti OpenSSL 3.2.0:   <\/p>\n<ul>\n<li class=\"l\"> Dodana je klijentska podr\u0161ka za QUIC protokol (RFC 9000), koji se koristi kao transport u HTTP\/3 protokolu. Implementacija uklju\u010duje, me\u0111u ostalim, mogu\u0107nost prijenosa vi\u0161e tokova kroz jedan komunikacijski kanal. Komponente za kori\u0161tenje QUIC-a na <a class=\"wpil_keyword_link\" href=\"https:\/\/prohoster.info\/hr\/server\/dts-gdansk\/\"   title=\"poslu\u017eiteljima\" data-wpil-keyword-link=\"linked\"  data-wpil-monitor-id=\"4541\">poslu\u017eiteljima<\/a> bit \u0107e uklju\u010dene u OpenSSL 3.3 koji planiraju objaviti najkasnije do 30. travnja 2024. godine.\n<p>QUIC predstavlja nadogradnju na UDP protokol, koja podr\u017eava multiplexiranje vi\u0161e veza i osigurava metode kriptiranja, ekvivalentne TLS\/SSL-u. Protokol je razvijen 2013. godine od strane Googlea kao alternativa TCP+TLS kombinaciji za web, rje\u0161avaju\u0107i probleme s velikim vremenom postavljanja i pregovaranja veza u TCP-u te uklanjanjem ka\u0161njenja prilikom gubitka paketa tijekom prijenosa podataka.       <\/p>\n<li class=\"l\"> U TLS-u je implementirana podr\u0161ka za pro\u0161irenje za kompresiju certifikata tijekom pregovaranja veza (RFC 8879), \u0161to omogu\u0107uje br\u017ee postavljanje veze jer prijenos certifikata \u010dini zna\u010dajan dio prometa tijekom faze pregovaranja. Podr\u017eava se kompresija koriste\u0107i zlib, zstd i Brotli biblioteke.\n<li class=\"l\"> Dodana je podr\u0161ka za deterministi\u010dku varijantu digitalnih potpisa ECDSA (Deterministic ECDSA, RFC 6979) u kojoj se umjesto nasumi\u010dne sekvence pri generiranju potpisa koristi HMAC-SHA256 hash od privatnog klju\u010da i teksta poruke koja se potpisuje, \u0161to omogu\u0107ava da se uvijek dobije isti potpis u razli\u010ditim operacijama potpisivanja, ali ne dopu\u0161ta curenje podataka koji se mogu koristiti za otkrivanje privatnog klju\u010da (privatni klju\u010d mo\u017ee biti otkriven ako su barem dva potpisa za razli\u010dite podatke generirana kori\u0161tenjem ponovljene nasumi\u010dne sekvence).\n<li class=\"l\"> Dodana je podr\u0161ka za pro\u0161irene varijante digitalnih potpisa s javnim klju\u010dem Ed25519 i Ed448: Ed25519ctx, Ed25519ph i Ed448ph (RFC 8032).\n<li class=\"l\"> Dodana je podr\u0161ka za AES-GCM-SIV na\u010din \u0161ifriranja (RFC 8452), koji kombinira visoke performanse GCM (Galois\/Counter Mode) s otporno\u0161\u0107u na curenje kod ponovne upotrebe slu\u010dajnog broja nonce.\n<li class=\"l\"> Implementirana je funkcija generiranja klju\u010da Argon2 (RFC 9106), koja je 2015. godine pobijedila na natje\u010daju za algoritme za hashiranje lozinki. Dodana je mogu\u0107nost kori\u0161tenja pool-a niti.\n<li class=\"l\"> Dodana je podr\u0161ka za hibridno \u0161ifriranje temeljenog na HPKE mehanizmu (Hybrid Public Key Encryption, RFC 9180), koji kombinira jednostavnost prijenosa klju\u010da u \u0161ifriranju s javnim klju\u010dem s visokom u\u010dinkovito\u0161\u0107u simetri\u010dnog \u0161ifriranja (podatci se \u0161ifriraju brzim simetri\u010dnim klju\u010dem, dok se sam klju\u010d \u0161ifrira sporijim asimetri\u010dnim).\n<li class=\"l\"> U TLS-u je omogu\u0107ena upotreba &#171;raw&#187; otvorenih klju\u010deva (RFC 7250).\n<li class=\"l\"> Dodana je podr\u0161ka za mehanizam brzog otvaranja TCP veza (TFO \u2014 TCP Fast Open, RFC 7413), koji smanjuje broj koraka uspostavljanja veze kombiniranjem prvog i drugog koraka klasi\u010dnog 3-koraknog postupka dogovaranja veze u jedan zahtjev, omogu\u0107uju\u0107i slanje podataka na po\u010detnoj fazi uspostavljanja veze.\n<li class=\"l\"> U TLS-u je implementirana podr\u0161ka za priklju\u010dive sheme digitalnog potpisivanja, \u0161to omogu\u0107ava kori\u0161tenje vanjskih implementacija algoritama, na primjer, za kori\u0161tenje algorima otpornima na napade kvantnih ra\u010dunala u TLS-u.\n<li class=\"l\"> U TLS 1.3 dodana je podr\u0161ka za za\u0161ti\u0107ene elipti\u010dne krivulje Brainpool.\n<li class=\"l\"> Dodana je podr\u0161ka za procesorske instrukcije SM4-XTS.\n<li class=\"l\"> Na Windows platformi omogu\u0107ena je upotreba sistemskog skladi\u0161ta korijenskih certifikata (po zadanom isklju\u010deno). Za pristup certifikatima u Windows skladi\u0161tu predlo\u017een je URI &#171;org.openssl.winstore:\/\/&#187;.     <\/ul>\n<p>Izvor: <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=60174\">opennet.ru<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 \u043f\u0440\u043e\u0448\u043b\u044b\u0445 \u0432\u0435\u0442\u043e\u043a OpenSSL 3.1 \u0438 3.0 LTS \u043f\u0440\u043e\u0434\u043b\u0438\u0442\u0441\u044f \u0434\u043e \u043c\u0430\u0440\u0442\u0430 2025 \u0433\u043e\u0434\u0430 \u0438 \u0441\u0435\u043d\u0442\u044f\u0431\u0440\u044f 2026 \u0433\u043e\u0434\u0430 \u0441\u043e\u043e\u0442\u0432\u0435\u0442\u0441\u0442\u0432\u0435\u043d\u043d\u043e. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 \u0432\u0435\u0442\u043a\u0438 1.1.1 \u043f\u0440\u0435\u043a\u0440\u0430\u0449\u0435\u043d\u0430 \u0432 \u0441\u0435\u043d\u0442\u044f\u0431\u0440\u0435 \u044d\u0442\u043e\u0433\u043e \u0433\u043e\u0434\u0430. \u041a\u043e\u0434 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-111732","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.4 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/hr\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic\" \/>\n\t\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.4\" \/>\n\t\t<meta property=\"og:locale\" content=\"hr_HR\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u0412\u044b\u043f\u0443\u0441\u043a OpenSSL 3.2.0 \u0441 \u043a\u043b\u0438\u0435\u043d\u0442\u0441\u043a\u043e\u0439 \u043f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u043e\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/hr\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-11-24T13:10:17+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-11-24T13:10:17+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47 Izdanje OpenSSL 3.2.0 s klijentom za podr\u0161ku QUIC protokolu | ProHoster","description":"Nakon osam mjeseci razvoja, formirano je izdanje biblioteke OpenSSL 3.2.0 s implementacijom SSL\/TLS protokola i raznih algoritama \u0161ifriranja. Podr\u0161ka za OpenSSL 3.2 \u0107e trajati do 23. novembra 2025. godine.","canonical_url":"https:\/\/prohoster.info\/hr\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"hr_HR","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u0412\u044b\u043f\u0443\u0441\u043a OpenSSL 3.2.0 \u0441 \u043a\u043b\u0438\u0435\u043d\u0442\u0441\u043a\u043e\u0439 \u043f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u043e\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC | ProHoster","og:description":"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.","og:url":"https:\/\/prohoster.info\/hr\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-11-24T13:10:17+00:00","article:modified_time":"2023-11-24T13:10:17+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/hr\/wp-json\/wp\/v2\/posts\/111732","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/hr\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/hr\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/hr\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/hr\/wp-json\/wp\/v2\/comments?post=111732"}],"version-history":[{"count":1,"href":"https:\/\/prohoster.info\/hr\/wp-json\/wp\/v2\/posts\/111732\/revisions"}],"predecessor-version":[{"id":164419,"href":"https:\/\/prohoster.info\/hr\/wp-json\/wp\/v2\/posts\/111732\/revisions\/164419"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/hr\/wp-json\/wp\/v2\/media?parent=111732"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/hr\/wp-json\/wp\/v2\/categories?post=111732"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/hr\/wp-json\/wp\/v2\/tags?post=111732"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}