Megjelent az OpenBSD 6.9

Bemutatásra került az OpenBSD 6.9, a szabad, többplatformos UNIX-szerű operációs rendszer kiadása. Megjegyzendő, hogy ez a projekt 50. kiadása, amely ebben az évben 26 éves lesz. Az OpenBSD projektet Theo de Raadt alapította 1995-ben, miután konfliktusba került a NetBSD fejlesztőivel, ami miatt Theo hozzáférése a NetBSD CVS-tárához megszűnt. Ezt követően Theo de Raadt és egy lelkes csapata új, nyílt operációs rendszert hozott létre a NetBSD forráskód-fájlfájának felhasználásával, amelynek fő fejlődési céljai a hordozhatóság (13 hardverplatformot támogat), a szabványosítás, a megbízhatóság, a fokozott biztonság és a beépített kriptográfiai eszközök voltak. Az OpenBSD 6.9 alapértelmezett telepítő ISO-képének mérete 544 MB.

Az operációs rendszeren kívül az OpenBSD projekt híres az olyan komponentseiről, amelyek más rendszerekben is elterjedtek és a legbiztonságosabb és legjobb minőségű megoldásokként szerepelnek. Ezek között található a LibreSSL (az OpenSSL fork), az OpenSSH, a csomagszűrő PF, az OpenBGPD és OpenOSPFD irányító démonok, az OpenNTPD NTP-szerver, az OpenSMTPD levelezőszerver, a tmux szöveges terminál-multiplexor (az GNU screen analógja), az IDENT protokollt megvalósító identd démon, a GNU groff BSDL-alternatívája — a mandoc, a CARP (Common Address Redundancy Protocol) protokoll a hibatűrő rendszerek szervezésére, valamint egy könnyű http-szerver és az OpenRSYNC fájlszinkronizáló segédprogram.

Fő fejlesztések:

  • A softraid driverhez RAID1C üzemmód került hozzáadásra, ami program alapú RAID1-et valósít meg titkosított adatokkal.
  • Két új háttérfolyamat került bevezetésre — a dhcpleased és a resolvd, amelyek a slaacd és az unwind mellett működnek a hálózati interfészek automatikus konfigurálása és DNS-azonosítók meghatározása érdekében. A dhcpleased a DHCP protokollt valósítja meg az IP-címek megszerzésére, míg a resolvd kezelés alatt tartja a resolv.conf tartalmát a dhcpleased, slaacd és hasonló driver-ekből származó névszerver adatok alapján.
  • Kezdő támogatás került hozzáadásra az Apple M1 processzorral rendelkező eszközökhöz. Ide tartozik az Apple Icestorm/Firestorm arm64 magok azonosítása és a BCM4378 vezeték nélküli chipek támogatásának biztosítása, amelyeket az Apple M1 SoC használ.
  • Javították a powerpc64 platform támogatását, amelyet a POWER8 és POWER9 processzorokra épülő 64 bites rendszerekhez fejlesztenek. Az előző kiadással összehasonlítva a powerpc64 esetében megvalósították a RETGUARD védelmi mechanizmus támogatását, hozzáadták az astfb meghajtót az Aspeed BMC framebufferhez, és megoldották az AMD GPU-val rendelkező rendszerekben a radeondrm és amdgpu meghajtók működésével kapcsolatos problémákat. A ram-lemezekhez készült kernel buildjéhez hozzáadták a hálózati indítás lehetőségét, támogatást nyújtanak a POWER9 CPU energiatakarékos üzemmódjaihoz, valamint megvalósították a lebegőpontos műveletek során generált kivételek támogatását, és IPMI támogatást realizáltak a PowerNV rendszerek számára.
  • Az ARM64 platformok számára támogatást nyújtanak a Cortex-A78AE, Cortex-X1 és Neoverse V1 CPU-hoz, megvalósították az ARM64-hez optimalizált copyin, copyout és kcopy hívások változatait, hozzáadták a cryptox meghajtót az ARMv8 titkosítási kiterjesztések támogatására, valamint a smmu meghajtót az RM System MMU Guard Page támogatásával. J javították a Raspberry Pi, Rock Pi N10, NanoPi és Pinebook Pro eszközök támogatását.
  • A video meghajtóhoz hozzáadták a kern.video.record sysctl paramétert, amely a kern.audio.record-hoz hasonlóan a videofelvétel közben a üres kép kiadásának vezérlésére szolgál (a felvételi felbontás megváltoztatásához a 1-es értékre kell állítani a paramétert). A folyamatok többször is megnyithatják a video eszközt (megoldja a webkamerák Firefoxban és BigBlueButtonben való használatával kapcsolatos problémákat).
  • Hozzáadtak nyomkövetési pontokat a malloc és free hívásokhoz, lehetővé téve a dt és btrace eszközök használatát a memóriaallokációval kapcsolatos tevékenység nyomon követésére. A btrace-hez hozzáadták az ‘-n’ opciót a program végrehajtása nélküli elemzéshez.
  • Fejlesztették a többprocesszoros rendszerek (SMP) támogatását. Az általános kernel zárolásából kivették az UNIX socket implementációt, hozzáadtak egy közös mutexet az msgbuf műveletek szinkronizálásához, az uvm_pagealloc hívást mp-safe-sé alakították, valamint eltávolították a zárolásokat a getppid és sendsyslog hívásokból.
  • Javították a DRM (Direct Rendering Manager) komponensek problémáit, beleértve a radeondrm meghajtó összeomlását a Powerbook5/6 és RV350 rendszereken, valamint megvalósították a DRI3 támogatást az amdgpu és ati meghajtókban, a Linux kompatibilitás miatt a /dev/dri/ könyvtárban eszközök létrehozását.
  • Fejlesztések történtek a VMM hipervizorban. A virtuális gépek kezelésére szolgáló backendben, a vmd-hez hozzáadták a tömörített RAM-lemezek indításának támogatását.
  • Javították a hangrendszert. Lehetőséget biztosítanak a sndio hangkészülékek külön rögzítésére kizárólag lejátszásra és csak felvételre. Az sndiod-ban egy nyolcadik rendű végső impulzusválaszú szűrőt (FIR szűrő) alkalmaztak, amely megszüntette a zajokat a spektrumok átfedése miatt a visszaformázás során. Alapértelmezetten le van tiltva az automatikus hangerőcsökkentés funkció, amikor egy új program elkezd lejátszani (autovolume), az alapértelmezett hangerőszint 127-re van beállítva. Engedélyezett a hang keverése alternatív eszközökből, amelyek eltérnek a sndiod által támogatott funkciók szintjétől.
  • Alapértelmezés szerint aktiválva van a LLDB hibakereső összegyűjtése és telepítése.
  • Az rcctl, rc.subr és rc.d fájlokba bekerült a logger kezelő támogatása, amely lehetővé teszi a háttérfolyamatokból származó logok stdout/stderr-ba való kimenetét.
  • A touchpadok számára lehetővé vált a gombkiosztás konfigurálása a wsconsctl segítségével. A wscons-ban javították a többérintéses események feldolgozását.
  • ARM64 eszközök esetén megvalósították az APM használatát az energiafogyasztás és az akkumulátor töltöttségének adatainak beszerzésére. Az apmd folyamat fájlrendszerhez való hozzáférésének korlátozása érdekében az unveil hívását alkalmazták.
  • Bővült a hardvertámogatás. Új drivereket adtak hozzá, például acpige (ACPI események, például a bekapcsológomb megnyomásának kezelésére), pchgpio (modern Intel PCH által vezérelt GPIO-k), ujoy (játékvezérlőkhez), uhidpp (Logitech HID++ eszközökhez). Támogatást kaptak az AMD Vi és az Intel VTD IOMMU kiterjesztések a PCI eszközök izolálására és a helytelen memóriahozzáférés blokkolására. Támogatják a Lynloong LM9002/9003 és LM9013 számítógépeket. Az pcamux és imxiic driverekhez hozzáadták az ACPI támogatást.
  • Javították a hálózati adapterek támogatását: mvpp (SFP+ és 10G a Marvel Armada Ethernet-hez), mvneta (1000base-x és 2500base-x), mvsw (Marvel SOHO switch-ek), rge (Wake on LAN támogatás), Netgear ProSecure UTM25. A vezeték nélküli driverek, iwm, iwn és athn számára hozzáadták az RA (802.11n Tx Rate Adaptation) támogatást. A vezeték nélküli stack-ben automatikus üzemmód kiválasztást állítottak be 11a/b/g/n/ac között, amikor a hálózati interfészt hozzáférési pontként használják.
  • A hálózati stackben megvalósításra került a veb (Virtual Ethernet Bridge) illesztőprogram. Implementálva lett a monitoring üzemmód támogatása, amelyben a hálózati interfészre érkező csomagok nem kerülnek továbbításra a hálózati stack-be feldolgozásra, de alkalmazhatók a forgalom elemzésének mechanizmusai, mint például a BPF. Új típusú hálózati interfészek lettek hozzáadva — etherbridge. Lehetővé vált a (route sourceaddr parancs) forrás cím felülírása a programok számára, megkerülve a szokásos címválasztási algoritmust. IP address Az automatikus konfigurálás üzemmód (AUTOCONF4 és AUTOCONF6) bekapcsolásakor a hálózati interfészek automatikus aktiválása biztosított.
  • Az installerben megvalósításra került a tömörített ram-lemez (bsd.rd) képe minden olyan platformon, amely támogatja az ilyen típusú betöltést.
  • Megvalósításra került a syslog-on keresztüli figyelmeztetés a printf sztring formázási helyettesítésének használatáról: «%n».
  • Az OpenBGPD útválasztó démonban hozzáadva lett az RTR (Resource Public Key Infrastructure (RPKI) to Router Protocol) támogatása. Az RTR-ülések alapinformációinak megjelenítésére hozzáadva lett a «bgpctl show rtr» parancs.
  • Az ospfd és ospf6d kódjának restrukturálása megtörtént a más útválasztó démonokkal való unifikálás és a karbantartás egyszerűsítése végett. Pont-pont üzemmódban kialakítva a hálózati interfészek támogatása.
  • A beépített HTTP-server httpd új opciókat valósított meg, mint a «location (found|notfound)» az erőforrások létezésének ellenőrzésére.
  • Az rpki-client programhoz hozzáadva lett az RRDP (The RPKI Repository Delta Protocol, RFC 8182) protokol támogatása. Lehetőség nyílt több URI megadására a TAL fájlban.
  • A dig utilitásban implementálva lett az RFC 8914 (Extended DNS Error) és az RFC 8976 (ZONEMD) támogatása.
  • A dhclient-ben megvalósítva lett a lehetőség opciók megadására a hostname.if fájlokban, a «dhcp» sorok használatával.
  • Az snmpd démonban teljes körű támogatást nyújtott a Trapv1 Trapv2 (RFC 3584) átalakításához. Az snmpd.conf fájlhoz új kulcsszavak, mint a read, write és notify lettek hozzáadva. Az snmp utilitásban megvalósítva lett a SMI enumerációk támogatása.
  • A DNS resolver unwind hozzáadta a DNS64 támogatását és a TCP-porton való kapcsolatok fogadását.
  • Az ftp utilitásban megvalósítva lett a tartós átirányítások támogatása (RFC 7538) és az If-Modified-Since fejléc küldésének lehetősége HTTP/HTTPS kérések küldésekor.
  • Az OpenSMTPD-be bevezették az '-a' opciót, amely lehetővé teszi az üzenetküldés előtti hitelesítést. A titkosítási eszközök átálltak a libtls könyvtár használatára. A TLS hallgató socketeknél lehetővé vált több tanúsítvány beállítása, amelyeket a név alapján lehet kiválasztani. domain (SNI).
  • A LibreSSL támogatást nyert a DTLSv1.2 protokollhoz. Lehetséges a libtls ('--enable-libtls-only') összeállítása libcrypto és libssl nélkül.
  • Frissült az OpenSSH csomag. Részletes áttekintés a fejlesztésekről itt tekinthető meg: OpenSSH 8.5, OpenSSH 8.6.
  • Az AMD64 architektúrához 11310 port, az aarch64-hez 10943, az i386-hoz pedig 10468 port tartozik. A portokban elérhető alkalmazásverziók közé tartozik: Xfce 4.16, Asterisk 18.3.0, Chromium 90.0.4430.72, FFmpeg 4.3.2, GCC 8.4.0, GNOME 3.38, Go 1.16.2, KDE Applications 20.12.3, Krita 4.4.3, LLVM/Clang 10.0.1, LibreOffice 7.0.5.2, Lua 5.3.6, MariaDB 10.5.9, Firefox 88.0 és ESR 78.10.0, Thunderbird 78.10.0, Node.js 12.16.1, PHP 8.0.3, Postfix 3.5.10, PostgreSQL 13.2, Python 3.9.2, Ruby 3.0.1, Rust 1.51.0.

    Frissültek a harmadik féltől származó komponensek, amelyek az OpenBSD 6.9 részei:

    • A Xenocara grafikai stack az X.Org 7.7 alapjain, xserver 1.20.10 + javítások, freetype 2.10.4, fontconfig 2.12.4, Mesa 20.0.8, xterm 367, xkeyboard-config 2.20, fonttosfnt 1.2.1.
    • LLVM/Clang 10.0.1 (+ javítások)
    • GCC 4.2.1 (+ javítások) és 3.3.6 (+ javítások)
    • Perl 5.32.1 (+ javítások)
    • NSD 4.3.6
    • Unbound 1.13.1
    • Ncurses 5.7
    • Binutils 2.17 (+ javítások)
    • Gdb 6.3 (+ javítás)
    • Awk 18.12.2020
    • Expat 2.2.10

Az OpenBSD 6.9 kiadásához kapcsolódik a 'Vetera Novis' című új dal.

Forrás: opennet.ru

Megbízható hosting vásárlása weboldalak számára, DDoS védelemmel, VPS VDS szerverek. 🔥 Megbízható webtárhely vásárlása DDoS védelemmel, VPS VDS szerverek | ProHoster