Megjelent a FreeBSD 12.3

Megjelent a FreeBSD 12.3, amely az amd64, i386, powerpc, powerpc64, powerpcspe, sparc64, valamint az armv6, armv7 és aarch64 architektúrákhoz készült. Továbbá elkészítettek képeket virtualizációs rendszerekhez (QCOW2, VHD, VMDK, raw) és az Amazon EC2 felhő környezetekhez. A FreeBSD 13.1 megjelenésére 2022 tavaszán lehet számítani.

Kulcsfontosságú újítások:

  • Hozzáadták az /etc/rc.final szkriptet, amely az utolsó fázisban indul el a felhasználói folyamatok befejezése után.
  • Az ipfw csomagszűrőbe bevezetésre került a dnctl parancs a dummynet forgalomnál korlátozó rendszer beállításának kezelésére.
  • Hozzáadták a kern.crypto sysctl-t a kernel kriptoszub rendszerének kezelésére, valamint a debug.uma_reclaim hibakeresési sysctl-t.
  • Hozzáadták a net.inet.tcp.tolerate_missing_ts sysctl-t, amely lehetővé teszi a TCP-csomagok használatát időbélyegzés nélkül (timestamp opció, RFC 1323/RFC 7323).
  • A GENERIC kernelhez az amd64 architektúrában be lett kapcsolva a COMPAT_LINUXKPI opció, és aktiválva lett az mlx5en meghajtó (NVIDIA Mellanox ConnectX-4/5/6).
  • A bootloaderhez hozzáadták a lehetőséget, hogy az operációs rendszert ram-lemezen indítsák, és támogatást valósítottak meg a ZFS opciókhoz: com.delphix:bookmark_written és com.datto:bookmark_v2.
  • A fetch könyvtárhoz támogatást adtak az FTP HTTPS fölötti proxyzásához.
  • A pkg csomagkezelőnél a 'bootstrap' és 'add' parancsokhoz megvalósították a '-r' flaget a repó jelölésére. Biztosítva lett a pkg.conf fájból való környezeti változók használata.
  • A growfs segédprogram képes lett fájlrendszerekkel dolgozni, amelyeket olvasási és írási módban csatoltak.
  • A etcupdate segédprogramban megvalósították a módosítások visszavonási módját egy vagy több fájl helyreállítására. Hozzáadták a '-D' flaget a célmappa megadásához. Biztosítva lett az adatok kinyerése ideiglenes könyvtár használatával, és hozzáadták a SIGINT kezelését.
  • A freebsd-update és freebsd-version segédprogramokhoz hozzáadták a '-j' flaget a jail környezetek támogatásához.
  • A cpuset segédprogram mostantól használható jail környezetekben a gyermek jails paraméterének megváltoztatásához.
  • A cmp segédprogramhoz hozzáadták az alábbi opciókat: '-b' (—print-bytes) a különböző byte-ok kiírásához, '-i' (—ignore-initial) egy adott számú kezdeti byte figyelmen kívül hagyásához, '-n' (—bytes) a hasonlításra kerülő byte-ok számának korlátozásához.
  • A daemon segédprogramban megjelent a '-H' flag a SIGHUP kezeléséhez és a kimeneti fájlok újranyitásához (hozzáadva a newsyslog támogatásához).
  • A fstyp segédprogramnál a '-l' flag megadása esetén biztosítva lett az exFAT fájlrendszerek meghatározása és megjelenítése.
  • A mergemaster segédprogramban megvalósították a szimbolikus linkek kezelését az frissítés során.
  • A newsyslog segédprogramhoz hozzáadták az „E” zászlót a üres naplók forgatásának letiltásához.
  • A tcpdump segédprogramban lehetőség nyílt a csomagok dekódolására a pfsync interfészeken.
  • A top segédprogramhoz hozzáadtak egy „/” szűrőparancsot, hogy csak az adott szövegre illeszkedő folyamatokat vagy argumentumokat jelenítse meg.
  • Az unzip segédprogramban támogatást adtak a jelszóval védett archívumokhoz.
  • Javították a hardvertámogatást. PCI-eszközazonosítókat adtak hozzá az ASMedia ASM116x AHCI vezérlőkhöz és az Intel Gemini Lake I2C vezérlőkhöz. Támogatást valósítottak meg a Mikrotik 10/25G hálózati adapterekhez és az Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14 vezeték nélküli kártyákhoz. Új igc meghajtót adtak hozzá az Intel I225 2.5G/1G/100MB/10MB ethernet vezérlőkhöz.
  • A Netgraph ng_bridge csomópontot SMP rendszerekhez alkalmazták. A ng_nat csomópontban támogatást adtak a CGN (Carrier Grade NAT, RFC 6598) számára. Lehetőség nyílt az ng_source csomópontot bármely Netgraph-hálózat részévé tenni.
  • Az rctl meghajtóban, amelyet az erőforrások korlátozására használnak, lehetőséget adtak az erőforrásfogyasztás 0-ra korlátozására.
  • A vlan interfészhez hozzáadták a forgalom priorizálási és sávszélesség-kezelési ALTQ rendszer támogatását.
  • Az amdtemp és amdsmn meghajtókban megvalósították a CPU Zen 3 „Vermeer” és APU Ryzen 4000 (Zen 2, „Renoir”) támogatását.
  • Frissítették a bázis rendszerhez tartozó külső alkalmazások verzióját: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. Az unzip segédprogram szinkronizálva lett a NetBSD kódbázissal.

Forrás: opennet.ru

Megbízható hosting vásárlása weboldalak számára, DDoS védelemmel, VPS VDS szerverek. 🔥 Megbízható webtárhely vásárlása DDoS védelemmel, VPS VDS szerverek | ProHoster