A QUIC protokoll tervezet státuszt kapott

Az IETF (Internet Engineering Task Force), amely az internet protokolljainak és architektúrájának fejlesztésével foglalkozik, befejezte a QUIC protokoll RFC-jének kidolgozását és közzétette a kapcsolódó specifikációkat az alábbi azonosítószámokkal: RFC 8999 (a protokoll verziófüggetlen tulajdonságai), RFC 9000 (szállítás UDP-n keresztül), RFC 9001 (QUIC kommunikációs csatornáját titkosító TLS) és RFC 9002 (a terhelés kezeléséről és az adatátvitel során bekövetkező csomagveszteség meghatározásáról).

Az RFC-k 'Javasolt szabvány' státuszt kaptak, ezt követően kezdődik meg az RFC-k 'Tervezet szabvány' (Draft Standard) státuszának elnyerésére irányuló munka, ami a protokoll teljes stabilizálását és az összes megjegyzés figyelembevételét jelenti. A QUIC protokollt használó HTTP/3 a tervezet specifikáció szakaszában van, de hamarosan ő is véglegesen szabványosításra kerül az IETF által.

Várható, hogy a QUIC szabványosítása ösztönözni fogja a protokoll szélesebb körű elterjedését, valamint a rajta alapuló kiterjesztések, mint például a WebTransport (technológia, amely lehetővé teszi az adatok küldését és fogadását a böngésző és szerverrel) és a MASQUE (kapcsolatproxy technológia, amely kiterjeszti a SOCKS és HTTP CONNECT lehetőségeit, és HTTPS-t használ a QUIC-en mint szállítót) fejlődését.

Emlékeztetünk rá, hogy a QUIC (Quick UDP Internet Connections) protokollt 2013 óta a Google fejleszti a TCP+TLS Web-es alternatívájaként, amely kezeli a TCP kapcsolatainak létrehozásával és megállapításával járó magas átfutási időt, és megszünteti a késedelmeket az adatátvitel során bekövetkező csomagveszteségek miatt. A QUIC egy UDP protokollra épülő kiegészítés, amely több kapcsolat multiplexelését támogatja, és titkosítási módszereket biztosít, amelyek megfelelnek a TLS/SSL-nek. Az IETF szabványának fejlesztése során a protokollon módosításokat hajtottak végre, ami két párhuzamosan létező ágazat létrejöttéhez vezetett, egy a HTTP/3 számára, a másik, amelyet a Google támogat (a Chrome mindkét változatot támogatja, míg a Firefox az IETF változatát).

A QUIC főbb jellemzői:

  • Magas biztonság, amely hasonló a TLS-hez (lényegében a QUIC lehetővé teszi a TLS használatát az UDP-n üstökölve);
  • A folyam integritásának ellenőrzése, amely megakadályozza a csomagok elvesztését;
  • A kapcsolat azonnali létrehozásának lehetősége (0-RTT, körülbelül 75%-ban az adatok azonnal átadhatók a kapcsolati telepítési csomag küldése után) és a kérés elküldése és a válasz megérkezése közötti minimális késleltetések biztosítása (RTT, Round Trip Time);
  • A csomagok új seq. számmal való újraküldésének lehetősége, amely lehetővé teszi a megkapott csomagok pontos azonosítását és megszünteti az időtúllépéseket;
  • Csomag elvesztése csak az ahhoz kapcsolódó folyamat szállítását befolyásolja, és nem állítja le az adatokat a párhuzamosan átkonvertált folyamatok szállításában;
  • Hibaellenőrző eszközök, amelyek minimalizálják a késéseket az elveszett csomagok újraküldése miatt. Speciális hibaellenőrző kódok használata csomagszinten a vesztes csomagok újraküldésének szükségességének csökkentésére.
  • A kriptográfiai blokkok határai a QUIC csomagok határaival össze vannak hangolva, ezáltal csökkenti a csomagvesztések hatását a következő csomagok tartalmának dekódolására;
  • Nincsenek problémák a TCP sorok blokkolásával;
  • Támogatja a kapcsolati azonosítót, amely lehetővé teszi a mobil kliensek számára a visszakapcsolódási idő csökkentését;
  • A kapcsolati túlterhelés-ellenőrzési mechanizmusok kiterjesztett lehetőségeinek csatlakoztatása;
  • Sávszélesség-előrejelzési technikák használata mindkét irányban a csomagok optimális küldési intenzitásának biztosítása érdekében, elkerülve a túlterheltségi állapotba való kerülést, amely csomagvesztést eredményez;
  • Jelentős teljesítménynövekedés és sávszélesség a TCP-hez képest. Videószolgáltatások, mint például a YouTube esetében a QUIC alkalmazása 30%-kal csökkentette a videók megtekintése során a puffereket.

Forrás: opennet.ru

Megbízható hosting vásárlása weboldalak számára, DDoS védelemmel, VPS VDS szerverek. 🔥 Megbízható webtárhely vásárlása DDoS védelemmel, VPS VDS szerverek | ProHoster