Megjelent a crypto-gost könyvtár, amely a GOST kriptoalgoritmusainak megvalósítását kínálja Java nyelven, anélkül, hogy további függőségeket igényelne. A Castle Bouncy Castle könyvtárból származó GOST algoritmusainak megvalósításától eltérően a crypto-gost javítja a "Küszöbölő" algoritmus titkosítási teljesítményét, megoldotta a biztonsági problémákat, és egyszerű, mély kriptográfiai tudást nem igénylő burkolatokat kínál. A kód saját engedélyező licenc alapján kerül forgalmazásra, amely lehetővé teszi a korlátozások nélküli terjesztést, módosítást és származtatott munkák létrehozását.
Támogatott algoritmusok:
- GOST R 34.11-2012 (RFC 6986) — "Scribog" hash-funkció 256 és 512 biten.
- GOST R 34.12-2015 — "Küszöbölő" blokkok titkosító algoritmus, 256 bites kulcs.
- GOST R 34.13-2015 — titkosítási módok: CBC, CFB, CTR (GAMMA), OFB; üzenetcímkék (CMAC).
- GOST R 34.10-2012 (RFC 7091) — 256 és 512 bites digitális aláírás.
- HMAC-Scribog (RFC 7836, HMAC-Streebog-256 és HMAC-Streebog-512).
- MGM (Multilinear Galois Mode) — AEAD üzemmód a Küszöbölő számára (RFC 9058). Kompatibilis az OpenSSL-lal.
- SCrypt (RFC 7914) — jelszóra alapozott kulcsgeneráló funkció.
Forrás: opennet.ru
