A Lighttpd 1.4.65 HTTP-szerver kiadása

Megjelent a Lighttpd 1.4.65, egy könnyű HTTP-szerver, amely a magas teljesítmény, biztonság, szabványoknak való megfelelés és a testreszabhatóság egyensúlyát próbálja megteremteni. A Lighttpd alkalmas nagy terhelésű rendszerek számára, és alacsony memória- és CPU-felhasználásra törekszik. Az új verzióban 173 módosítás található. A projekt kódja C nyelven készült és BSD licenc alatt terjesztik.

Főbb újítások:

  • Hozzáadva a WebSocket támogatása HTTP/2 felett, valamint megvalósítva a RFC 8441, amely leírja a WebSocket protokoll egy szálban való indításának mechanizmusát HTTP/2 kapcsolaton belül.
  • Megvalósítva a kibővített prioritáskezelési sémát, amely lehetővé teszi a kliens számára, hogy befolyásolja a továbbított szerverrel válaszok prioritását (RFC 9218), valamint irányítani a prioritásokat a kérések átirányításánál. A HTTP/2 számára támogatott a PRIORITY_UPDATE keret.
  • A lighttpd.conf beállításokba hozzáadva a kezdő (=^) és végső (=$) sorra való hivatkozás alapú feltételes egyezéseket. Az ilyen sorvizsgálatok jelentősen gyorsabbak, mint a reguláris kifejezések, és elegendőek sok egyszerű ellenőrzéshez.
  • A mod_webdav-ban hozzáadva a részleges PUT műveletek támogatása (amelyek részben adatok lefedésével és Range fejléccel történnek). Az aktiváláshoz használható az ‘webdav.opts += (
  • A mod_accesslog-khoz hozzáadva az ‘accesslog.escaping =
  • A mod_deflate-ban támogatás hozzáadva a libdeflate-hez való fordításhoz.
  • A kérés testének átvitele HTTP/2-n keresztül felgyorsult.
  • A server.max-keep-alive-requests paraméter alapértelmezett értéke 100-ról 1000-re változott.
  • A MIME-típusok listájában az „application/javascript” helyett a „text/javascript” került bevezetésre (RFC 9239).

A jövőben szigorúbb titkosítási beállítások alkalmazása, valamint az elavult titkosítók alapértelmezett letiltása tervezett. A CipherString beállítás értéke megváltozik „HIGH”-ról „EECDH+AESGCM:AES256+EECDH:CHACHA20:SHA256:!SHA384”-ra. Továbbá az elavult TLS opciók eltávolítása is tervezett. ssl.honor-cipher-order, ssl.dh-file, ssl.ec-curve, ssl.disable-client-renegotiation, ssl.use-sslv2, ssl.use-sslv3. Ezenkívül folytatódik a mini modulok tisztítása, amelyeket rugalmasabb Lua megvalósítással lehet helyettesíteni a mod_magnet keresztül. Különösen a mod_evasive, mod_secdownload, mod_uploadprogress és mod_usertrack modulok eltávolítása tervezett.

Forrás: opennet.ru

Megbízható hosting vásárlása weboldalak számára, DDoS védelemmel, VPS VDS szerverek. 🔥 Megbízható webtárhely vásárlása DDoS védelemmel, VPS VDS szerverek | ProHoster