Kategória: Blog

Megjelent az OpenRGB 0.6, az RGB világítással rendelkező eszközök irányításához szükséges eszköztár.

Megjelent az OpenRGB 0.6 új verziója, egy ingyenes eszköz, amely lehetővé teszi RGB világítással rendelkező eszközök vezérlését. A csomag támogatja az ASUS, Gigabyte, ASRock és MSI alaplapokat, RGB világítással a ház világításához, az ASUS, Patriot, Corsair és HyperX RAM modulokat, az ASUS Aura/ROG, MSI GeForce, Sapphire Nitro és Gigabyte Aorus grafikus kártyákat, valamint különböző LED szalagvezérlőket (ThermalTake, Corsair, NZXT Hue+), […]

A D nyelvhez bemutatásra került az mikrokontroller programozási futtatókörnyezet.

Dylan Graham bemutatta a LWDR nevű könnyű runtime-ot a D nyelvű programozáshoz valós idejű operációs rendszerek (RTOS) által felszerelt mikrovezérlők számára. A jelenlegi verzió az ARM Cortex-M mikrovezérlőkre összpontosít. A fejlesztés nem célozza meg a D nyelv minden képességének teljes lefedését, de alapvető eszközöket kínál. A memória allokáció manuálisan történik (new / delete), a szemétgyűjtő nincs megvalósítva, de van néhány horgony […]

Az NGINX Unit 1.24.0 alkalmazásszerver kiadása

Megjelent az NGINX Unit 1.24 alkalmazás-szerver, amely lehetővé teszi webalkalmazások futtatását különböző programozási nyelveken (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js és Java). Az NGINX Unit alatt több alkalmazás is futhat egyszerre különböző programozási nyelveken, és ezek indítási paramétereit dinamikusan módosíthatjuk anélkül, hogy szükség lenne a konfigurációs fájlok szerkesztésére vagy újraindításra. A kód […]

Az Electron 13.0.0 kiadása, a Chromium motorra épülő alkalmazásfejlesztő platform

Kiadásra került az Electron 13.0.0 platform, amely egy önálló keretrendszert biztosít többplatformos asztali alkalmazások fejlesztéséhez, Chromium, V8 és Node.js komponensekre alapozva. A verziószám jelentős megváltozása a Chromium 91 kódalapra, Node.js 14.16 platformra és a V8 9.1 JavaScript motorra való frissítéshez kapcsolódik. Az új verzióval kapcsolatos változások közé tartozik: a process.contextIsolated tulajdonság hozzáadása, amely meghatározza a jelenlegi […]

A PCRE2 10.37 könyvtár kiadása

Megjelent a PCRE2 10.37 könyvtár, amely C nyelven írt funkciók gyűjteményét nyújtja, és olyan reguláris kifejezéseket és minták keresésére szolgáló eszközöket valósít meg, amelyek szintaxisa és szemantikai hasonlóságot mutat a Perl 5 nyelv reguláris kifejezéseivel. A PCRE2 a régi PCRE könyvtár átdolgozott megvalósítása, amely nem kompatibilis API-t és kibővített képességeket kínál. A könyvtár az Exim levelezőszerver fejlesztői által készült, és […]

A Microsoft kiadta a Windows Package Manager 1.0 csomagkezelőt, amely hasonló az apt-hoz és dnf-hez.

A Microsoft közzétette a Windows Package Manager 1.0 (winget) verzióját, amely lehetővé teszi az alkalmazások telepítését parancssoron keresztül. A kód C++ nyelven íródott, és MIT licenc alatt érhető el. A csomagok egy közösségi támogatással fenntartott tárolóból kerülnek telepítésre. A Microsoft Store-ból történő programtelepítéssel ellentétben a winget lehetővé teszi az alkalmazások telepítését felesleges marketing nélkül […]

A Paketkezelő Pacman 6.0 és az Archinstall 2.2.0 kiadásai

Új verziók érhetők el a Pacman 6.0.0 csomagkezelőből és az Archinstall 2.2.0 telepítőből, amelyek az Arch Linux disztribúcióban használatosak. Főbb változások a Pacman 6.0-ban: Támogatás került a fájlok párhuzamos letöltéséhez. Megvalósításra került a letöltési folyamatot jelző sor kiírása. A letöltési előrehaladás jelzőjének kikapcsolásához a pacman.conf fájlban meg kell adni a „—noprogressbar” opciót. Automatikus átugrás biztosított a tükörtárak esetében, ha azok nem elérhetők […]

Megnyílt a HaveIBeenPwned jelszóellenőrző szolgáltatás forráskódja

Troy Hunt közzétette a «Have I Been Pwned?» (haveibeenpwned.com) jelszólopás ellenőrző szolgáltatás forráskódját, amely 11,2 milliárd eltulajdonított felhasználói fiók adatbázisából végez ellenőrzést, amelyet 538 weboldal hackelése során loptak el. A projekt forráskódjának nyilvánosságra hozásáról tavaly augusztusban tették közzé a bejelentést, de a folyamat elhúzódott, és a kód csak most került publikálásra. A szolgáltatás kódja […]

A Mozilla összefoglalta a Firefox Chrome harmadik verziójának támogatására vonatkozó terveit

A Mozilla közzétette a Firefox Chrome harmadik verziójának megvalósítási tervét, amely meghatározza a bővítmények által elérhető lehetőségeket és erőforrásokat. A harmadik verzió kritikát kapott, mivel sok, a nem kívánt tartalmak blokkolására és a biztonság növelésére szolgáló bővítményt megzavart. A Firefox szinte minden funkciót és korlátozást meg kíván valósítani az új manifesztumból, beleértve a tartalomszűréshez szükséges deklaratív API-t (declarativeNetRequest) […]

A QUIC protokoll tervezet státuszt kapott

Az IETF (Internet Engineering Task Force) bizottság, amely az internet protokolljainak és architektúrájának fejlesztésével foglalkozik, befejezte a QUIC protokoll RFC-jének kidolgozását és közzétette a kapcsolódó specifikációkat a következő azonosítókkal: RFC 8999 (verziófüggetlen protokolltulajdonságok), RFC 9000 (szállítás UDP-n keresztül), RFC 9001 (TLS-titkosítás a QUIC kommunikációs csatornán) és RFC 9002 (terheléskezelés és csomagvesztés meghatározása adatátvitel során) […]

A Virtuozzo cég kiadta a VzLinux disztribúciót, amely a CentOS 8 helyettesítésére készült

A Virtuozzo (korábban a Parallels leányvállalata), amely nyílt forráskódú projekteken alapuló szerver szoftvereket fejleszt, megkezdte a VzLinux disztribúció nyilvános terjesztését, amely korábban a cég által fejlesztett virtualizációs platform és különféle kereskedelmi termékek alapvető operációs rendszereként szolgált. A VzLinux mostantól bárki számára elérhetővé vált, és a CentOS 8 alternatívájaként pozicionálják, készen áll a munkahelyi bevezetésre. A letöltéshez […]

Simply Linux 9.1 kiadás

A Bázis SPÓ bejelentette a Simply Linux 9.1 kiadását, amely a kilencedik ALT platformra épül. A termék egy licencszerződés keretében terjeszthető, amely nem adja át a disztribúció terjesztésének jogát, de lehetővé teszi a rendszer korlátlan használatát természetes és jogi személyek számára. A disztribúció x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (béta) architektúrákhoz készült csomagokban érkezik, és […]

Megbízható hosting vásárlása weboldalak számára, DDoS védelemmel, VPS VDS szerverek. 🔥 Megbízható webtárhely vásárlása DDoS védelemmel, VPS VDS szerverek | ProHoster