{"id":111034,"date":"2023-10-22T09:10:35","date_gmt":"2023-10-22T07:10:35","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3"},"modified":"2023-10-22T09:10:35","modified_gmt":"2023-10-22T07:10:35","slug":"opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3","status":"publish","type":"post","link":"https:\/\/prohoster.info\/hu\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3","title":{"rendered":"Megjelent az nghttp3 1.0 k\u00f6nyvt\u00e1r az HTTP\/3 protokoll megval\u00f3s\u00edt\u00e1s\u00e1val","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>El\u00e9rhet\u0151 a nghttp3 projekt els\u0151 stabil kiad\u00e1sa, amely C nyelv\u0171 k\u00f6nyvt\u00e1rat fejleszt az HTTP\/3 protokoll megval\u00f3s\u00edt\u00e1s\u00e1val. Ugyanazon projekt \u00e1ltal fejlesztett k\u00f6nyvt\u00e1r HTTP\/2 protokollra vonatkoz\u00f3 v\u00e1ltozata az Apache http-szerverhez tartoz\u00f3 mod_http2 modul alapj\u00e1ul szolg\u00e1l. A projekt eredm\u00e9nyeit a Curl seg\u00e9dprogram is felhaszn\u00e1lja. A k\u00f6nyvt\u00e1r k\u00f3dj\u00e1t MIT licenc alatt terjesztik.    <\/p>\n<p>A HTTP\/3 szabv\u00e1ny a QUIC (Quick UDP Internet Connections) protokollt hat\u00e1rozza meg az HTTP\/2 sz\u00e1ll\u00edt\u00e1s\u00e1hoz. A QUIC az UDP protokollra \u00e9p\u00fcl, t\u00e1mogatja a t\u00f6bb kapcsolat egyidej\u0171 kezel\u00e9s\u00e9t, \u00e9s TLS\/SSL-nek megfelel\u0151 titkos\u00edt\u00e1si m\u00f3dszereket k\u00edn\u00e1l. A protokollt 2013-ban a Google fejlesztette ki a TCP+TLS webhelyhez ny\u00fajtott alternat\u00edvak\u00e9nt, hogy megoldja a TCP-csom\u00f3pontokkal kapcsolatos k\u00e9sleltet\u00e9seket \u00e9s megsz\u00fcntesse a csomagok elveszt\u00e9se sor\u00e1n fell\u00e9p\u0151 k\u00e9sedelmeket.           <\/p>\n<p>Az nghttp3 f\u00fcggetlen megval\u00f3s\u00edt\u00e1st k\u00edn\u00e1l a RFC 9114 (HTTP\/3 a QUIC protokoll felett), RFC 920 (QPACK fejl\u00e9cek t\u00f6m\u00f6r\u00edt\u00e9si technol\u00f3gia), RFC 9220 (WebSocketek \u00e1tvitele HTTP\/3 felett) \u00e9s RFC 9218 (kiterjeszthet\u0151 s\u00e9ma a v\u00e1laszok \u00fcgyf\u00e9lk\u00e9r\u00e9sek priorit\u00e1sainak kezel\u00e9s\u00e9re) specifik\u00e1ci\u00f3inak. A k\u00f6nyvt\u00e1r nem f\u00fcgg bizonyos QUIC veremekt\u0151l, \u00e9s t\u00e1mogatja a k\u00fcl\u00f6nb\u00f6z\u0151 QUIC sz\u00e1ll\u00edt\u00e1si protokoll megval\u00f3s\u00edt\u00e1sok felett val\u00f3 m\u0171k\u00f6d\u00e9st. Egyidej\u0171leg a projekttel saj\u00e1t QUIC protokoll megval\u00f3s\u00edt\u00e1s is fejl\u0151dik \u2014 az ngtcp2, amely alap\u00e9rtelmezetten haszn\u00e1latos. Az adatok titkos\u00edt\u00e1s\u00e1hoz az ngtcp2 t\u00e1mogatja a quictls, GnuTLS, BoringSSL, Picotls \u00e9s wolfSSL backendeket. Az nghttp3 1.0 egyidej\u0171leg megjelent az els\u0151 stabil ngtcp2 1.0 kiad\u00e1ssal is.<br \/>\n<br \/>Forr\u00e1s: <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=59973\">opennet.ru<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u0414\u043e\u0441\u0442\u0443\u043f\u0435\u043d \u043f\u0435\u0440\u0432\u044b\u0439 \u0441\u0442\u0430\u0431\u0438\u043b\u044c\u043d\u044b\u0439 \u0440\u0435\u043b\u0438\u0437 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 nghttp3, \u0440\u0430\u0437\u0432\u0438\u0432\u0430\u044e\u0449\u0435\u0433\u043e \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0443 \u043d\u0430 \u044f\u0437\u044b\u043a\u0435 \u0421\u0438 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3. \u0420\u0430\u0437\u0432\u0438\u0432\u0430\u0435\u043c\u044b\u0439 \u0442\u0435\u043c \u0436\u0435 \u043f\u0440\u043e\u0435\u043a\u0442\u043e\u043c \u0432\u0430\u0440\u0438\u0430\u043d\u0442 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 \u0434\u043b\u044f \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/2 \u0438\u0441\u043f\u043e\u043b\u044c\u0437\u0443\u0435\u0442\u0441\u044f \u0432 \u043a\u0430\u0447\u0435\u0441\u0442\u0432\u0435 \u043e\u0441\u043d\u043e\u0432\u044b \u043c\u043e\u0434\u0443\u043b\u044f mod_http2, \u0432\u0445\u043e\u0434\u044f\u0449\u0435\u0433\u043e \u0432 \u0441\u043e\u0441\u0442\u0430\u0432 http-\u0441\u0435\u0440\u0432\u0435\u0440\u0430 Apache. \u041d\u0430\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 \u0442\u0430\u043a\u0436\u0435 \u0437\u0430\u0434\u0435\u0439\u0441\u0442\u0432\u043e\u0432\u0430\u043d\u044b \u0432 \u0443\u0442\u0438\u043b\u0438\u0442\u0435 Curl. \u041a\u043e\u0434 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 \u0440\u0430\u0441\u043f\u0440\u043e\u0441\u0442\u0440\u0430\u043d\u044f\u0435\u0442\u0441\u044f \u043f\u043e\u0434 \u043b\u0438\u0446\u0435\u043d\u0437\u0438\u0435\u0439 MIT. \u0421\u0442\u0430\u043d\u0434\u0430\u0440\u0442 HTTP\/3 \u043e\u043f\u0440\u0435\u0434\u0435\u043b\u044f\u0435\u0442 \u0438\u0441\u043f\u043e\u043b\u044c\u0437\u043e\u0432\u0430\u043d\u0438\u0435 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC (Quick [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-111034","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.3 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u0414\u043e\u0441\u0442\u0443\u043f\u0435\u043d \u043f\u0435\u0440\u0432\u044b\u0439 \u0441\u0442\u0430\u0431\u0438\u043b\u044c\u043d\u044b\u0439 \u0440\u0435\u043b\u0438\u0437 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 nghttp3, \u0440\u0430\u0437\u0432\u0438\u0432\u0430\u044e\u0449\u0435\u0433\u043e \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0443 \u043d\u0430 \u044f\u0437\u044b\u043a\u0435 \u0421\u0438 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/hu\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3\" \/>\n\t\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.3\" \/>\n\t\t<meta property=\"og:locale\" content=\"hu_HU\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u041e\u043f\u0443\u0431\u043b\u0438\u043a\u043e\u0432\u0430\u043d\u0430 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0430 nghttp3 1.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3 | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u0414\u043e\u0441\u0442\u0443\u043f\u0435\u043d \u043f\u0435\u0440\u0432\u044b\u0439 \u0441\u0442\u0430\u0431\u0438\u043b\u044c\u043d\u044b\u0439 \u0440\u0435\u043b\u0438\u0437 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 nghttp3, \u0440\u0430\u0437\u0432\u0438\u0432\u0430\u044e\u0449\u0435\u0433\u043e \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0443 \u043d\u0430 \u044f\u0437\u044b\u043a\u0435 \u0421\u0438 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/hu\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-10-22T07:10:35+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-10-22T07:10:35+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47K\u00f6zz\u00e9tett\u00e9k a nghttp3 1.0 k\u00f6nyvt\u00e1rat az HTTP\/3 protokoll megval\u00f3s\u00edt\u00e1s\u00e1val | ProHoster","description":"El\u00e9rhet\u0151 a nghttp3 projekt els\u0151 stabil kiad\u00e1sa, amely C nyelv\u0171 k\u00f6nyvt\u00e1rat fejleszt az HTTP\/3 protokoll megval\u00f3s\u00edt\u00e1s\u00e1val.","canonical_url":"https:\/\/prohoster.info\/hu\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"hu_HU","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u041e\u043f\u0443\u0431\u043b\u0438\u043a\u043e\u0432\u0430\u043d\u0430 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0430 nghttp3 1.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3 | ProHoster","og:description":"\u0414\u043e\u0441\u0442\u0443\u043f\u0435\u043d \u043f\u0435\u0440\u0432\u044b\u0439 \u0441\u0442\u0430\u0431\u0438\u043b\u044c\u043d\u044b\u0439 \u0440\u0435\u043b\u0438\u0437 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 nghttp3, \u0440\u0430\u0437\u0432\u0438\u0432\u0430\u044e\u0449\u0435\u0433\u043e \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0443 \u043d\u0430 \u044f\u0437\u044b\u043a\u0435 \u0421\u0438 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3.","og:url":"https:\/\/prohoster.info\/hu\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-10-22T07:10:35+00:00","article:modified_time":"2023-10-22T07:10:35+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/posts\/111034","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/comments?post=111034"}],"version-history":[{"count":0,"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/posts\/111034\/revisions"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/media?parent=111034"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/categories?post=111034"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/tags?post=111034"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}