{"id":112077,"date":"2023-12-08T15:10:14","date_gmt":"2023-12-08T13:10:14","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp"},"modified":"2023-12-08T15:10:14","modified_gmt":"2023-12-08T13:10:14","slug":"avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","status":"publish","type":"post","link":"https:\/\/prohoster.info\/hu\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","title":{"rendered":"A GnuPG szerz\u0151je megalap\u00edtotta a LibrePGP-t, az OpenPGP szabv\u00e1ny forkj\u00e1t","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>Werner Koch, a principal developer and creator of the GnuPG project, founded the LibrePGP project, focused on developing an updated specification that serves as an alternative to the OpenPGP standard. The fork was created in response to changes proposed by the IETF working group for the next update of the OpenPGP specification (RFC-4880), which Koch regarded as questionable in terms of maintaining compatibility and ensuring security. Developers from GnuPG, RNP (the OpenPGP implementation for Thunderbird), and Gpg4win who supported the fork are concerned that these proposed changes could be detrimental to existing OpenPGP-based application implementations, whose users depend on the long-term stability of the specification and are not willing to accept compatibility-breaking changes.    <\/p>\n<p>LibrePGP includes useful enhancements that have been developed in recent years for the future version of the OpenPGP specification, while excluding changes that negatively impact compatibility. For example, compared to the current standard RFC-4880, LibrePGP accepts features such as:  <\/p>\n<ul>\n<li class=\"l\"> Support for the Camellia encryption algorithm (RFC-5581),\n<li class=\"l\"> ECC (Elliptic Curve Cryptography) extensions for OpenPGP (RFC-6637).\n<li class=\"l\"> Mandatory support for SHA2-256 hashes (SHA-1 and MD5 are categorized as deprecated, and the possibility of decrypting data without integrity verification is considered completely obsolete).\n<li class=\"l\"> An increase of the fingerprint size to 256 bits.\n<li class=\"l\"> Support for EdDSA digital signature schemes and elliptic curves BrainpoolP256r1, BrainpoolP384r1, BrainpoolP512r1, Ed25519, Curve25519, Ed488, and X448.\n<li class=\"l\"> Support for the CRYSTALS-Kyber algorithm, which is resistant to quantum computer attacks.\n<li class=\"l\"> Support for authenticated encryption modes OCB (Offset Codebook Mode).\n<li class=\"l\"> Implementation of the fifth version of the digital signatures format with metadata protection.\n<li class=\"l\"> Support for extended subpackets with digital signatures.  <\/ul>\n<p>Key points of criticism towards the new OpenPGP specification:  <\/p>\n<ul>\n<li class=\"l\"> The IETF working group attempted to reinvent the standard instead of making gradual incremental updates to the specification, resulting in significant changes that disrupt compatibility.\n<li class=\"l\"> A szimmetrikus GCM (Galois\/Counter Mode) titkos\u00edt\u00e1si m\u00f3d t\u00e1mogat\u00e1s\u00e1nak bevezet\u00e9se, amelyet neh\u00e9z helyesen megval\u00f3s\u00edtani, figyelmen k\u00edv\u00fcl hagyva az OCB (Offset codebook mode) m\u00f3dot, amelynek szabadalma m\u00e1r \u00e9vekkel ezel\u0151tt lej\u00e1rt.\n<li class=\"l\"> Opcion\u00e1lis csomagok hozz\u00e1ad\u00e1sa v\u00e9letlenszer\u0171 kieg\u00e9sz\u00edt\u0151 kit\u00f6lt\u00e9ssel a forgalomelemz\u00e9s elleni v\u00e9delem \u00e9rdek\u00e9ben. A LibrePGP k\u00e9sz\u00edt\u0151i szerint az ilyen csomagok, amelyek ellen\u0151rizhetetlen kezdeti v\u00e9letlenszer\u0171 kit\u00f6lt\u00e9st tartalmaznak, vesz\u00e9lyt jelentenek a rejtett adatsug\u00e1rz\u00e1si csatorn\u00e1k l\u00e9trehoz\u00e1sa \u00e9s az adatsziv\u00e1rg\u00e1s-ellen\u0151rz\u0151 rendszerek megker\u00fcl\u00e9se szempontj\u00e1b\u00f3l. Kor\u00e1bban a kieg\u00e9sz\u00edt\u0151 kit\u00f6lt\u00e9s bevezet\u00e9s\u00e9nek \u00f6tlete elutas\u00edt\u00e1sra ker\u00fclt, mivel az nem a titkos\u00edt\u00e1s szintj\u00e9n, hanem az alkalmaz\u00e1s szintj\u00e9n zajlott.\n<li class=\"l\"> A m\u00f3dos\u00edtott ECDH titkos\u00edt\u00e1si s\u00e9ma alkalmaz\u00e1sa (OID form\u00e1tum m\u00f3dos\u00edt\u00e1sa), a RFC-6637-ban le\u00edrt \u00e9s a PGP-ben, valamint a GnuPG-ben megval\u00f3s\u00edtott v\u00e1ltozat helyett.\n<li class=\"l\"> N\u00e9h\u00e1ny gyakorlati funkci\u00f3 elt\u00e1vol\u00edt\u00e1sa, mint p\u00e9ld\u00e1ul a klasszikus kulcsvisszavon\u00e1si m\u00f3dszer, az &#171;m&#187; jelz\u0151 a MIME-adatok megjel\u00f6l\u00e9s\u00e9re \u00e9s az &#171;t&#187; jelz\u0151 a sz\u00f6veges adatok elv\u00e1laszt\u00e1s\u00e1ra a bin\u00e1risokt\u00f3l (az &#171;t&#187; jelz\u0151 hely\u00e9re az &#171;u&#187; jelz\u0151 l\u00e9pett a UTF-8 k\u00f3dol\u00e1s\u00fa sz\u00f6veghez).\n<li class=\"l\"> A leg\u00fajabb al\u00e1\u00edr\u00e1si form\u00e1tumban a al\u00e1\u00edrt f\u00e1jl metaadatainak v\u00e9delme kiz\u00e1rva (p\u00e9ld\u00e1ul a f\u00e1jlnevet a al\u00e1\u00edr\u00e1s megs\u00e9rt\u00e9se n\u00e9lk\u00fcl meg lehet v\u00e1ltoztatni).\n<li class=\"l\"> K\u00e9ts\u00e9ges lehet\u0151s\u00e9g a &#171;s\u00f3&#187; hozz\u00e1ad\u00e1s\u00e1ra az al\u00e1\u00edr\u00e1sokhoz (Salted signature) a megadott prefix-szel v\u00e9gzett \u00fctk\u00f6z\u00e9si t\u00e1mad\u00e1sok v\u00e9delm\u00e9nek fokoz\u00e1sa \u00e9rdek\u00e9ben. A s\u00f3val ell\u00e1tott \u00e9rt\u00e9k nem letilthat\u00f3 rejtett csatornak\u00e9nt haszn\u00e1lhat\u00f3 32 byte adat tov\u00e1bb\u00edt\u00e1s\u00e1ra az al\u00e1\u00edr\u00e1sban.\n<li class=\"l\"> A szabv\u00e1ny elmozdul\u00e1sa az online kommunik\u00e1ci\u00f3 alapvet\u0151 haszn\u00e1lata fel\u00e9, figyelmen k\u00edv\u00fcl hagyva az adatok hossz\u00fa t\u00e1v\u00fa t\u00e1rol\u00e1s\u00e1nak ig\u00e9nyeit.  <\/ul>\n<p>Az OpenPGP t\u00e1mogat\u00f3i m\u00e1r k\u00f6zz\u00e9tett\u00e9k kritik\u00e1jukat a kritik\u00e1ra. V\u00e9gs\u0151 soron, ha nem siker\u00fcl meg\u00e1llapod\u00e1st tal\u00e1lni, a sz\u00e9tszakad\u00e1s n\u00f6velheti az OpenPGP\/LibrePGP megval\u00f3s\u00edt\u00e1sok k\u00f6z\u00f6tti inkompatibilit\u00e1sokat. R\u00e9szben e probl\u00e9ma megold\u00e1sa \u00e9rdek\u00e9ben az OpenPGP fejleszt\u0151i r\u00f6gz\u00edtett\u00e9k az al\u00e1\u00edr\u00e1sok \u00f6t\u00f6dik verzi\u00f3j\u00e1t, amely kompatibilis a LibrePGP-vel, \u00e9s elkezdt\u00e9k a hatodik verzi\u00f3ra val\u00f3 \u00e1t\u00e1ll\u00e1st.<br \/>\n<br \/>Forr\u00e1s: <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=60256\">opennet.ru<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP. \u0424\u043e\u0440\u043a \u0431\u044b\u043b \u0441\u043e\u0437\u0434\u0430\u043d \u0432 \u043e\u0442\u0432\u0435\u0442 \u043d\u0430 \u0438\u0437\u043c\u0435\u043d\u0435\u043d\u0438\u044f, \u043d\u0430\u043c\u0435\u0447\u0435\u043d\u043d\u044b\u0435 \u0440\u0430\u0431\u043e\u0447\u0435\u0439 \u0433\u0440\u0443\u043f\u043f\u043e\u0439 IETF \u0434\u043b\u044f \u0432\u043d\u0435\u0441\u0435\u043d\u0438\u044f \u0432 \u0441\u043b\u0435\u0434\u0443\u044e\u0449\u0435\u0435 \u043e\u0431\u043d\u043e\u0432\u043b\u0435\u043d\u0438\u0435 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438 OpenPGP (RFC-4880) \u0438 \u0432\u043e\u0441\u043f\u0440\u0438\u043d\u044f\u0442\u044b\u0435 \u041a\u043e\u0445\u043e\u043c \u043a\u0430\u043a \u0441\u043e\u043c\u043d\u0438\u0442\u0435\u043b\u044c\u043d\u044b\u0435 \u0441 \u0442\u043e\u0447\u043a\u0438 \u0437\u0440\u0435\u043d\u0438\u044f \u0441\u043e\u0445\u0440\u0430\u043d\u0435\u043d\u0438\u044f \u0441\u043e\u0432\u043c\u0435\u0441\u0442\u0438\u043c\u043e\u0441\u0442\u0438 \u0438 \u043e\u0431\u0435\u0441\u043f\u0435\u0447\u0435\u043d\u0438\u044f [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-112077","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.3 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/hu\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp\" \/>\n\t\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.3\" \/>\n\t\t<meta property=\"og:locale\" content=\"hu_HU\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u0410\u0432\u0442\u043e\u0440 GnuPG \u043e\u0441\u043d\u043e\u0432\u0430\u043b LibrePGP, \u0444\u043e\u0440\u043a \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0430 OpenPGP | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/hu\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-12-08T13:10:14+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-12-08T13:10:14+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47A GnuPG szerz\u0151je alap\u00edtotta a LibrePGP-t, az OpenPGP szabv\u00e1ny forkj\u00e1t | ProHoster","description":"Werner Koch, a GnuPG (GNU Privacy Guard) projekt f\u0151 fejleszt\u0151je \u00e9s alap\u00edt\u00f3ja l\u00e9trehozta a LibrePGP projektet, amely az OpenPGP szabv\u00e1ny alternat\u00edv\u00e1j\u00e1nak fejleszt\u00e9s\u00e9re \u00f6sszpontos\u00edt.","canonical_url":"https:\/\/prohoster.info\/hu\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"hu_HU","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u0410\u0432\u0442\u043e\u0440 GnuPG \u043e\u0441\u043d\u043e\u0432\u0430\u043b LibrePGP, \u0444\u043e\u0440\u043a \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0430 OpenPGP | ProHoster","og:description":"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.","og:url":"https:\/\/prohoster.info\/hu\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-12-08T13:10:14+00:00","article:modified_time":"2023-12-08T13:10:14+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/posts\/112077","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/comments?post=112077"}],"version-history":[{"count":0,"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/posts\/112077\/revisions"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/media?parent=112077"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/categories?post=112077"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/hu\/wp-json\/wp\/v2\/tags?post=112077"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}