Rilascio di Issuerd 0.1.17, un server di gestione delle identità e degli accessi compatibile con Keycloak.

È stata pubblicata la versione Issuerd 0.1.17 - server di gestione dell'identità e dell'accesso (IAM), che implementa i protocolli OpenID Connect e OAuth 2.x ed è compatibile con la piattaforma Keycloak a livello di modello dei dati e con un'API REST di gestione. Sono stati implementati SSO, MFA (TOTP, WebAuthn/passkeys), federazione degli utenti da LDAP e Kerberos/SPNEGO, accesso tramite fornitori di identità esterni (OIDC, social network), pagine di accesso con design personalizzabile e localizzazione, configurazione iniziale dichiarativa tramite YAML al primo avvio. Il server è scritto in Rust (il codice non sicuro è vietato a livello di attributi), distribuito con licenza Apache 2.0 e fornito come un singolo file binario autonomo, che include una console di amministrazione e una console utente. Le build sono generate per le piattaforme Linux, Windows e macOS (amd64 e
arm64).

Una caratteristica chiave del progetto è la verifica continua della conformità
al set ufficiale di test della OpenID Foundation Conformance Suite (5.3.2). I test vengono eseguiti nel CI per ogni rilascio in un ambiente docker isolato. I risultati modulare sono conservati nel repository e un pacchetto completo di report è allegato a
ogni rilascio. Il parità con Keycloak è controllato mediante un set di test. È previsto il conseguimento della certificazione ufficiale.

Tra i protocolli richiesti negli scenari con agenti AI, sono stati implementati DPoP (RFC 9449, associazione del token alla chiave del presentatore), scambio di token (RFC 8693, restrizione dei permessi durante lo scambio del token) e CIBA (modalità poll, conferma delle azioni da parte dell'utente). Sono supportati anche PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), registrazione dinamica dei clienti (RFC 7591/7592), autorizzazione dei dispositivi (RFC 8628). L'importazione completa di 100.000 utenti da MS Active Directory richiede circa 30 secondi.

Fonte: opennet.ru

Acquista hosting affidabile per siti web con protezione DDoS, server VPS VDS 🔥 Acquista hosting affidabile per siti web con protezione DDoS, server VPS VDS - ProHoster