Ir izlaista brīva UNIX līdzīga operētājsistēma OpenBSD 7.2. OpenBSD projekts tika dibināts Teo de Raadt 1995. gadā pēc konflikta ar NetBSD izstrādātājiem, kā rezultātā Teo piekļuve CVS repozitorijam NetBSD tika bloķēta. Pēc tam Teo de Raadt kopā ar domubiedriem izveidoja jaunu atvērtu operētājsistēmu, balstoties uz NetBSD avota koka, kuras galvenie attīstības mērķi ir pārnesamība (atbalstītas 13 aparatūras platformas), standartizācija, korekta darbība, proaktīva drošība un integrēti kriptogrāfijas rīki. Pilnā OpenBSD 7.2 bāzes sistēmas instalācijas ISO attēla izmērs ir 556 MB.
Papildus paša operētājsistēmai OpenBSD projekts ir pazīstams ar saviem komponentiem, kuri ir izplatījušies citās sistēmās un ir pierādījuši sevi kā vienus no visdrošākajiem un kvalitatīvākajiem risinājumiem. Starp tiem: LibreSSL (OpenSSL atzars), OpenSSH, pakotņu filtrs PF, maršrutēšanas deamoni OpenBGPD un OpenOSPFD, NTP serveris OpenNTPD, e-pasta serveris OpenSMTPD, teksta termināla multiplikators (analogā GNU screen) tmux, identd deamons ar IDENT protokolu, BSDL alternatīva GNU groff paketam — mandoc, protokols, lai organizētu kļūdu toleranto sistēmu CARP (Common Address Redundancy Protocol), viegls http serveris, failu sinkronizācijas rīks OpenRSYNC.
Galvenie uzlabojumi:
- Uzlabota ARM arhitektūras sistēmu atbalsts, tostarp pievienots atbalsts Apple M2 un Ampere Altra ARM mikroshēmām. Pievienots atbalsts Lenovo ThinkPad x13s portatīvajam datoram un citiem iekārtām, kas balstītas uz Qualcomm Snapdragon 8cx Gen 3 (SC8280XP) SoC.
- Pievienota iespēja palaišanai Oracle Cloud vidē, izmantojot ram diska kodu (bsd.rd) un vairāku procesu sistēmām paredzēto kodu (bsd.mp).
- Iekļauts kstat instruments, kas eksportē statistiku par kodola darbību, ko var apskatīt, izmantojot kstat utilītu.
- Katram procesora kodolam, kas atbalsta MPERF/APERF, ir īstenoti CPU frekvences sensori. Strādājot ar akumulatoru, tiek aktivizēta CPU frekvences skalēšana atkarībā no slodzes.
- ARM64 sistēmās pievienota sākotnējā miega režīma atbalsts. Atbalstīto CPU skaits palielināts līdz 256. Ieviešana iespēja pārslēgties no rāmja bufera konsoles (glass console) uz sērijveida portu bāzes konsoli (serial console).
- Noņemta kodēšana, kas nosaka CPU 386sx/386dx, NexGen, Rise un veco Cyrix procesoru modeļus, kas izdoti pirms Cyrix M2 mikroshēmas.
- Uzlabots vairāku proceso sistēmu (SMP) atbalsts. Pārveidotas par mp-safe funkcijas, kas ierobežo caurlaidību (rate limit), ARP ierakstu meklēšanu un maršruta taimeri. Ieviesta paralēla šādu operāciju izpilde kā IPv4 pakotņu atkārtota savākšana un IP pakotņu pāradresācija. UDP un IP iebraukšanas pakotņu apstrādē pievienotas bloķēšanas uz vietas, izmantojot mutex. No sistēmas izsaukuma kbind un pledge izņemti bloķējumi. Ieviestas UNIX soketu bloķēšanas, kas darbojas atsevišķa soketa līmenī.
- DRM (Direct Rendering Manager) ietvars ir sinhronizēts ar Linux kodu 5.15.69 (iepriekšējā laidienā — 5.15.26). Intel intel drm draiverī ir pievienota atbalsts Intel mikroarhitektūras Alder Lake un Raptor Lake čipiem. Ir ieviesta atbalsts freambuferiem, kas nav izlīdzināti atmiņas lapu robežās (piemēram, MacBook Pro 2021 14″ un 16″).
- Ir uzlabota VMM hipervizora darbība. VMD ir pievienota atbalsts MMIO bāzes lietotāja telpas apstrādātājiem. VMM ieejas/izejas portu emulācija ir pārcelta uz lietotāja telpu. Ir unified iekšējās struktūras un saskarnes VMD, VMCTL un VMM. Ir pievienota uzraudzības iespēja virtuālo mašīnu ar SNMP AgentX, izmantojot VM-MIB parametrus (RFC7666).
- $rcexec mainīgais rc.d inicializācijas skriptā ir aizvietots ar rc_exec funkciju. Ir pievienots jauns mainīgais daemon_execdir, kas ļauj nomainīt katalogu pirms rc_exec funkcijas izpildes. rc.d un rcctl ir pievienota jaunā darbība configtest, lai pārbaudītu konfigurācijas sintaksi.
- Komplektā ir iekļauta utilīta ts, kas pievieno laiku pie katra standarta ievads virsraksta.
- Utilītē ps ir pievienota opcija „-f” procesu grupēšanai kokveidā, kas atspoguļo attiecības starp vecākiem un bērnu procesiem.
- Utilītē openrsync ir ieviesta opcija „—contimeout” savienojuma izveides taimeram.
- Utilītē pkg_add pēc noklusējuma ir iekļauta kešatmiņa, optimizēta pakotņu apstrāde un nodrošināta uzdevuma progresēšanas indikatoru izvadīšana datu pārraides laikā.
- fdisk ir uzlabota GPT un MBR tabulu apstrāde, pievienotas brīdinājumi, ja MBR un GPT nodalījumu izvietojums ir nepareizs.
- Utilītē disklabel ir pievienots atbalsts atslēgvārdu raid izmantošanai šablonos automātiskai RAID nodalījumu izvietošana. Atbalsts diskalliemētajai ģeometrijai ir izbeigts. Ir pārtraukta atbalsta nodrošināšana atribūtiem ‘bs’ (boot block size), ‘sb’ (superblock size) un d[0-4] (disk data).
- In katalogs /usr/share/btrace ir iekļauti noderīgi btrace skripti dinamiskai izsekot un aplikāciju pārbaudei.
- Skaņas bibliotēkā sndio ir pievienota funkcija sio_flush, kas ļauj nekavējoties pārtraukt atskaņošanu.
- Komplektā ir iekļauta utilīta llvm-profdata, kas darbojas ar profilēšanas datiem.
- Utilītē wc ir paātrināta vārdu skaitīšanas operācija.
- Pievienota atbalsta jauniem aparatūrai, tostarp iekļauti jauni draiveri:
- aplaudio (Apple skaņas apakšsistēma).
- aplmca (Apple MCA kontrolieris).
- aplsart (Apple SART).
- alpdc, apldchidev, apldckbd, apldcms, aplrtk (Apple M2 klaviatūra un skārienpaliktnis).
- qcgpio, qciic (GPIO un GENI I2C kontrolieri Qualcomm Snapdragon).
- sfgpio, stfclock, stfpinctrl, stftemp (draiveri GPIO, taimeriem un SiFive plates sensoriem).
- sxirintc (pārtraukumu kontrolieris Allwinner mikroshēmām).
- gpiorestart (draiveris atiestatīšanai caur GPIO).
- IPMI ir paplašinājis atbalstu barošanas sensoriem.
- ehci ir pievienots atbalsts kontrolierim, kas tiek izmantots Marvell 3720 plates.
- igc draiverī Intel I225 gigabita Ethernet adapteriem ir iekļauts aparatūras paātrinājums kontrolsumu aprēķināšanai IPv4, TCP un UDP. ix draiverī Intel 82598/82599/X540/X550 Ethernet adapteriem ir realizēts aparatūras paātrinājums TCP segmentu apstrādei (Lielā saņemšana bez nosacījumiem), kas tiek aktivizēts ar opciju tso ifconfig.
- iwx draiverī ir iekļauts atbalsts Intel AX210/AX211 mikroshēmām un paplašinātas atpazīstamo bezvadu ierīču iespējas.
- Pievienota iespēja startēt no programmatūras RAID 1 (softraid) sadaļām amd64, sparc64 un arm64 sistēmās.
- snmpd un xlock ir īstenota privilēģiju dalīšana.
- UNIX soketu bind un connect funkcijās ir nodrošināta izolācija, pamatojoties uz sistēmas izsaukumu unveil.
- Pievienota jauna sistēmas izsaukuma ypconnect, lai izveidotu soketu savienojuma izveidei ar serveri YP, izmantojot IP adresi no bloķētā faila ypbinding. ypldap ir pievienots 'local bind' režīms, kuru laikā RPC sokets ir piesaistīts loopback interfeisam, lai izslēgtu ārējās savienojumus ar serveri.
- Katalogā /sbin novietotās programmas hcpleased, mountd, nfsd, pflogd, resolvd, slaacd un unwind ir pārgājušas uz dinamisko saistīšanu papildus aizsardzības līdzekļu izmantošanai, kas attiecas uz dinamiski saistītām izpildāmām failēm.
- Tīkla kaudzes sistēmas izsaukumos ir realizēta sendmmsg un recvmmsg, kas ļauj nosūtīt un lasīt vairākus ziņojumus vienā sistēmas izsaukumā, kas iepriekš prasītu atsevišķus sendmsg un recvmsg izsaukumus.
- pf iepakotāja filtrā ir mainīta IGMP un ICMP6 MLD (Multicast Listener Discovery) paketu apstrāde, kas ļāva optimizēt darbību ar multicast paketu pārvaldības ziņojumiem noklusējuma konfigurācijā. Ir ieviesta stingrāka IGMP/MLD ziņojumu pārbaude.
- IPsec ir uzlabota sertifikātu apstrāde. Iked ir uzlabota saderība ar OpenIKED. Komandai ikectl show stats pievienots statistikas izvade par veiksmīgām un neveiksmīgām savienojumiem ar iked.
- BGPd pievienots filtrs max-communities, lai ierobežotu atļauto kopienu skaitu. Realizēts RFC 9234 (Maršruta noplūdes novēršana un noteikšana, izmantojot lomas UPDATE un OPEN ziņojumos) un nodrošināta pilnīga atbalsta ieviešana RFC 7911 (Vairāku ceļu reklamēšana BGP). Statiskie heši nomainīti pret RB-kokiem, lai uzlabotu lielo sistēmu veiktspēju. Pievienots bgplgd process ar FastCGI servera realizāciju, kas nodrošina REST API komandām bgpctl.
- RPKI-klientā atļauts izmantot vairāk par vienu CRL URI sertifikātos. Realizēts parametrs skiplist, lai ignorētu domēnus, pievienota ASPA (Autonomous System Provider Authorization) un sig-failu pārbaude, realizēts TAL dekodēšana (RFC 8630), pastiprināta EE sertifikātu pārbaude un uzlabota saderība ar HTTP specifikācijām.
- SNMPD atļauts snmpd.conf izmantot objektu nosaukumus, ne tikai OID. Ieviešot AgentX protokolu, pievienota atbalsta iespēja master aģentam.
- HTTPD piedāvāti jaunie MIME tipu definējumi.
- FTP rīks pārslēgts uz savienojumu izmantošanu, kas tiek apstrādāti nebloķējošā režīmā, izmantojot ppoll.
- Tmux („termināla multiplexer“) pievienota ACL izmantošanas iespēja, lai organizētu vairāku lietotāju pieslēgšanos caur vienu soketu.
- Atjaunināti LibreSSL un OpenSSH pakotnes. Detalizētu uzlabojumu apskatu var skatīt LibreSSL 3.6.0 un OpenSSH 9.1 apskatos.
- AMD64 arhitektūras portu skaits sasniedza 11451 (bija 11301), aarch64 – 11261 (bija 11081), i386 – 10225 (bija 10136). Starp lietojumprogrammu versijām portos:
- Asterisk 16.28.0, 18.14.0 un 19.6.0
- Audacity 2.4.2
- CMake 3.24.2
- Chromium 105.0.5195.125
- Emacs 28.2
- FFmpeg 4.4.2
- GCC 8.4.0 un 11.2.0
- GHC 9.2.4
- GNOME 42.4
- Go 1.19.1
- JDK 8u342, 11.0.16 un 17.0.4
- KDE Gear 22.08.1
- KDE Frameworks 5.98.0
- Krita 5.1.1
- LLVM/Clang 13.0.0
- LibreOffice 7.4.1.2
- Lua 5.1.5, 5.2.4 un 5.3.6
- MariaDB 10.9.3
- Mono 6.12.0.182
- Mozilla Firefox 105.0.1 un ESR 102.3.0
- Mozilla Thunderbird 102.3.0
- Mutt 2.2.7 un NeoMutt 20220429
- Node.js 16.17.1
- OCaml 4.12.1
- OpenLDAP 2.6.3
- PHP 7.4.30, 8.0.23 un 8.1.10
- Postfix 3.7.2
- PostgreSQL 14.5
- Python 2.7.18, 3.9.14 un 3.10.7
- Qt 5.15.6 un 6.3.1
- R 4.2.1
- Ruby 2.7.6, 3.0.4 un 3.1.2
- Rust 1.63.0
- SQLite 3.39.3
- Shotcut 22.06.23
- Sudo 1.9.11.2
- Suricata 6.0.6
- Tcl/Tk 8.5.19 un 8.6.12
- TeX Live 2021
- Vim 9.0.0192 un Neovim 0.7.2
- Xfce 4.16
- Atjaunināti trešo pušu komponenti, kas iekļauti OpenBSD 7.2:
- Grafiskais steks Xenocara, pamatojoties uz X.Org 7.7 ar xserver 1.21.4 + ielāpiem, freetype 2.12.1, fontconfig 2.13.94, Mesa 22.1.7, xterm 372, xkeyboard-config 2.20, fonttosfnt 1.2.2.
- LLVM/Clang 13.0.0 (+ ielādes)
- GCC 4.2.1 (+ ielādēm) un 3.3.6 (+ ielādēm)
- Perl 5.32.1 (+ labojumi)
- NSD 4.6.0
- Unbound 1.16.3
- Ncurses 5.7
- Binutils 2.17 (+ labojumi)
- Gdb 6.3 (+ labojums)
- Awk 12.9.2022
- Expat 2.4.9
Avots: opennet.lv
