DNS servera BIND 9.16.0 izlaidums

Pēc 11 mēneÅ”u izstrādes ISC konsorcijs prezentēja izlaida pirmo stabilo jaunās nozÄ«mÄ«gās BIND 9.16 DNS servera versijas laidienu. 9.16 versijas atbalsts tiks nodroÅ”ināts trÄ«s gadus lÄ«dz 2023. gada 2. ceturksnÄ«m kā daļa no paplaÅ”inātā atbalsta cikla. Atjauninājumi iepriekŔējai LTS versijai 9.11 turpinās tikt izsniegti lÄ«dz 2021. gada decembrim. 9.14 versijas atbalsts beigsies pēc trim mēneÅ”iem.

īpaŔības jaunumi:

  • Pievienots KASP (Key and Signing Policy), vienkārÅ”ota metode DNSSEC atslēgu un digitālo parakstu pārvaldÄ«bai, balstÄ«ta uz noteikumu definēŔanu ar ā€ždnssec-policyā€ direktÄ«vu. Å Ä« direktÄ«va ļauj konfigurēt jaunu atslēgu Ä£enerēŔanu DNS zonām un automātisku ZSK un KSK atslēgu piemēroÅ”anu.
  • Ievērojami pārbÅ«vēta tÄ«kla apakÅ”sistēma, kas pārgājusi uz asynchrone pieprasÄ«jumu apstrādes mehānismu, balstoties uz bibliotēku libuv.
    Pārbūve pagaidām nav novestas pie redzamām izmaiņām, taču turpmākajos laidienos tā ļaus īstenot dažas būtiskas veiktspējas optimizācijas un pievienot atbalstu jauniem protokoliem, piemēram, DNS over TLS.
  • Uzlabots DNSSEC uzticamo saistÄ«bu pārvaldÄ«bas process (Trust anchor, uzticama atslēga, kas piesaistÄ«ta zonai Ŕīs zonas autentiskuma pārbaudei). Tā vietā, lai izmantotu trusted-keys un managed-keys, kas tagad ir pasludināti par novecojuÅ”iem, piedāvāta jauna trust-anchors direktÄ«va, kas ļauj pārvaldÄ«t abus atslēgu tipus.

    Izmantojot trust-anchors ar atslēgvārdu initial-key, Ŕīs direktÄ«vas uzvedÄ«ba ir identiska managed-keys, t.i., nosaka uzticamo saistÄ«bu konfigurāciju saskaņā ar RFC 5011. Izmantojot trust-anchors ar atslēgvārdu static-key, uzvedÄ«ba atbilst trusted-keys direktÄ«vai, t.i., nosaka pastāvÄ«gu atslēgu, kas netiek automātiski atjaunināta. Tāpat trust-anchors piedāvā vēl divus atslēgvārdus initial-ds un static-ds, kas ļauj izmantot uzticamo saistÄ«bu formātā DS (Delegation Signer) vietā, DNSKEY, kas ļauj konfigurēt saistÄ«bas vēl nepublicētām atslēgām (nākotnē IANA plāno izmantot DS formātu centrālo zonu atslēgām).

  • RÄ«kos dig, mdig un delv pievienota opcija ā€ž+yamlā€ izejai YAML formātā.
  • RÄ«kam dig pievienota opcija ā€ž+[no]unexpectedā€, kas ļauj pieņemt atbildes no hostiem, kas atŔķiras no servera, kuram tika nosÅ«tÄ«ts pieprasÄ«jums.
  • RÄ«ka dig pievienota opcija Ā«+[no]expandaaaaĀ», kuras izmantoÅ”ana ļauj IPv6 adresēm ierakstos AAAA tikt parādÄ«tām pilnā 128 bitu attēlojumā, nevis RFC 5952 formātā.
  • Pievienota iespēja pārslēgt kanālu grupas statistiku.
  • DS un CDS ieraksti tagad tiek Ä£enerēti tikai, balstoties uz SHA-256 hash, izbeidzot SHA-1 Ä£enerāciju.
  • DNS Cookie (RFC 7873) noklusējuma algoritms ir SipHash 2-4, bet HMAC-SHA atbalsts ir izbeigts (AES atstāts).
  • Dnssec-signzone un dnssec-verify komandu izvade tagad tiek novirzÄ«ta uz standarta izejas plÅ«smu (STDOUT), bet STDERR tiek attēlota tikai kļūdu un brÄ«dinājumu informācija (norādot opciju Ā«-fĀ», tiek parādÄ«ta arÄ« parakstÄ«tā zona). Opcija Ā«-qĀ» pievienota tusēŔanai.
  • DNSSEC validācijas kods ir pārstrādāts, atbrÄ«vojoties no koda dublēŔanās ar citām apakÅ”sistēmām.
  • Statistikas izvade JSON formātā tagad var izmantot tikai JSON-C bibliotēku. Configure opcija «—with-libjsonĀ» pārdēvēta par «—with-json-cĀ».
  • Configure skriptā vairs automātiski netiek iestatÄ«ts parametrs «—sysconfdirĀ» uz /etc un «—localstatedirĀ» uz /var, ja nav norādÄ«ts «—prefixĀ». Pēc noklusējuma izmantoti ceļi $prefix/etc un $prefix/var, ko pielieto Autoconf.
  • Kods ar DLV (Domain Look-aside Verification, opcija dnssec-lookaside) pakalpojuma Ä«stenojumu ir izdzēsts, jo tas tika atzÄ«ts par novecojuÅ”u BIND 9.12, un ar to saistÄ«tais dlv.isc.org apstrādātājs tika izslēgts 2017. gadā. DLV izdzēŔana ļāva vienkārÅ”ot BIND kodu.

Avots: opennet.lv

Iegādājieties uzticamu tÄ«mekļa hostingu ar DDoS aizsardzÄ«bu, VPS VDS serveriem šŸ”„ Iegādājieties uzticamu tÄ«mekļa hostingu ar DDoS aizsardzÄ«bu, VPS VDS serveriem | ProHoster