Autors: Yuri Gagarins

Iznākuši Pacman 6.0 pakotņu pārvaldnieka un Archinstall 2.2.0 instalētāja laidumi.

Ir pieejami jauni Pacman 6.0.0 pakotņu pārvaldnieka un Archinstall 2.2.0 instalētāja laidieni, kas tiek izmantoti Arch Linux izplatījumā. Galvenās izmaiņas Pacman 6.0: Pievienota atbalsts failu lejupielādei vairākos paralēlos straumos. Ieviesta izvadstrīda ar lejupielādes progresu. Lai izslēgtu progresu rādītāju, pacman.conf var norādīt opciju «—noprogressbar». Nodrošināta automātiska spoguļu izlaišana, pie kuriem vēršoties […]

Atvērts HaveIBeenPwned paroles pārbaudes pakalpojuma kods

Trojs Hants (Troy Hunt) ir atvēris «Have I Been Pwned?» (haveibeenpwned.com) kompromiseju šoņu pierakstu pakalpojuma avota kodu, kas pārbauda 11,2 miljardu kontu datu bāzi, kas iegūta pēc 538 vietņu uzlaušanas. Sākotnēji izsludināts iecere atvērt projekta kodu pagājušā gada augustā, bet process bija ieilgušs un kods ir publicēts tikai tagad. Pakalpojuma kods ir rakstīts […]

Mozilla apkopoja plānus Chrome trešā manifesta atbalstam Firefox

Mozilla ir publicējusi plānu Chrome trešā manifesta īstenošanai Firefox, kas nosaka, kādas iespējas un resursus piedāvā paplašinājumiem. Trešais manifests ir pagājis cauri kritikai, jo tas pārtrauca daudzu nevēlamā satura bloķēšanas un drošības paplašinājumu darbību. Firefox plāno īstenot gandrīz visas jaunā manifesta iespējas un ierobežojumus, tostarp deklaratīvo AI satura filtrēšanai (declarativeNetRequest), […]

QUIC protokols ieguvis ieteicamo standartu statusu

IETF (Interneta inženierijas darba grupa), kas nodarbojas ar protokolu un interneta arhitektūras attīstību, ir noslēgusi QUIC protokola RFC izstrādi un publicējusi saistītās specifikācijas ar identifikatoriem RFC 8999 (protokola versijai neatkarīgas īpašības), RFC 9000 (pārvadājums virs UDP), RFC 9001 (TLS šifrēšana QUIC sakarā) un RFC 9002( pārslodzes vadība un pakešu zuduma noteikšana datu pārsūtīšanā). […]

Virtuozzo uzņēmums ir publicējis VzLinux izplatīšanas versiju, kas paredzēta CentOS 8 aizvietošanai.

Virtuozzo uzņēmums (bijušais Parallels uzņēmuma struktūrvienība), kas izstrādā serveru programmatūru virtualizācijai, pamatojoties uz atvērtajiem projektiem, ir uzsācis VzLinux izplatīšanas versijas publisko izplatīšanu, kas iepriekš tika izmantota kā pamata operētājsistēma izstrādātajā platformā virtualizācijai un dažādiem komerciāliem produktiem. Tagad VzLinux ir pieejams visiem interesentiem un tiek pozicionēts kā CentOS 8 aizvietotājs, gatavs darba ieviešanai. Lejupielādei […]

Izlaista Simply Linux 9.1 izplatīšana.

BASALT SP uzņēmums ir paziņojis par Simply Linux 9.1 izplatīšanas versijas iznākšanu, kas izstrādāta uz devītās ALT platformas pamata. Produkts tiek izplatīts saskaņā ar licencēšanas līgumu, kas nenodod izplatīšanas tiesības, bet ļauj fiziskām un juridiskām personām sistēmu izmantot bez ierobežojumiem. Izplatīšana tiek piedāvāta pakotnēs x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (beta) arhitektūrām un var […]

Publicēta datu bāze immudb 1.0, kas nodrošina aizsardzību pret datu sagrozīšanu.

Tika piedāvāts ievērojams datu bāzes immudb 1.0 izlaidums, kas garantē visu kādreiz pievienoto datu nemainīgumu un saglabāšanu, kā arī nodrošina aizsardzību pret atpakaļejošajiem grozījumiem un sniedz iespēju kriptogrāfiskai pierādīšanai par datu īpašumtiesībām. Projekts sākotnēji tika attīstīts kā specializēts NoSQL krātuve, kas manipulates datiem atslēga/vērtība formātā, bet sākot ar 1.0 izlaidumu immudb tiek pozicionēta kā pilnvērtīga datu bāze ar SQL atbalstu. Kods […]

Pieejama AlmaLinux 8.4 izplatīšanas versija, kas turpina CentOS 8 attīstību.

Iznākusi AlmaLinux 8.4 izplatīšanas versija, kas sinhronizēta ar Red Hat Enterprise Linux 8.4 izplatīšanas versiju. Pakotnes ir sagatavotas x86_64 arhitektūrai kā boot (709 MB), minimālā (1.9 GB) un pilnā attēla (9.8 GB) formā. Drīzumā plānots publicēt arī pakotnes ARM arhitektūrai. Izplatīšana tiek atzīta par gatavu darba ieviešanai un pilnībā atbilst RHEL funkcionalitātei, par […]

Izlaista Oracle Linux 8.4 izplatīšana.

Oracle uzņēmums ir publicējis Oracle Linux 8.4 izdevumu, kas izveidots, pamatojoties uz Red Hat Enterprise Linux 8.4 pakotņu bāzi. Neierobežotai lejupielādei ir pieejams instalācijas iso-attēls, kura izmērs ir 8.6 GB, sagatavots x86_64 un ARM64 (aarch64) arhitektūrām. Oracle Linux nodrošina neierobežotu un bezmaksas piekļuvi yum-repozitorijam ar bināro pakotņu atjauninājumiem ar kļūdu novēršanu (errata) un problēmām […]

Incidents ar kontroli pār kanāliem IRC tīklā FreeNode

Jaunā FreeNode IRC komanda izteica nožēlu par notikušo incidentu, kuru daži kopienas uztvēra kā viņu IRC kanālu sagrābšanu. Piemēram, projekti Ubuntu, Gentoo, HardenedBSD, LibreELEC, FSFE un Void Linux paziņoja par šķiršanos no FreeNode saistībā ar kontroli pār saviem kanāliem. Pēc administratoru komandas aiziešanas, kuri izveidoja jaunu Libera.Chat tīklu konflikta ar domēnu īpašnieku dēļ, daži atklātie […]

Chrome 91 izlaide

Google ir prezentējusi web-pārlūkprogrammas Chrome 91 izlaidumu. Tajā pašā laikā ir pieejams stabils atbrīvojums no brīvā projekta Chromium, kas kalpo kā Chrome pamats. Chrome pārlūkprogramma izceļas ar izstrādātāju logotipiem, paziņojumu sistēmu, kad notiek avārija, moduļiem aizsargāta video satura (DRM) atskaņošanai, automātisko atjauninājumu instalēšanas sistēmu un RLZ-parametru pārsūtīšanu meklēšanas laikā. Nākamais Chrome 92 izlaidums plānots 20. jūlijā. Galvenās izmaiņas […]

Pakotņu filtrs nftables 0.9.9 izlaidums

Publicēts pakotņu filtra nftables 0.9.9 izlaidums, kas vieno pakotņu filtrācijas saskarnes IPv4, IPv6, ARP un tīkla tiltiem (mērķis ir aizstāt iptables, ip6table, arptables un ebtables). Tajā pašā laikā ir publicēts līdzekļi libnftnl 1.2.0, kas nodrošina zema līmeņa API mijiedarbībai ar nf_tables apakšsistēmu. Nepieciešamie izmaiņas, kas nepieciešamas nftables 0.9.9 darbināšanai, ir iekļautas Linux 5.13-rc1 kodolā. Pakotnes […]

Iegādājieties uzticamu tīmekļa hostingu ar DDoS aizsardzību, VPS VDS serveriem 🔥 Iegādājieties uzticamu tīmekļa hostingu ar DDoS aizsardzību, VPS VDS serveriem | ProHoster