GnuPG autors izveidoja LibrePGP, OpenPGP standarta forku.

Verners Kočs (Werner Koch), galvenais izstrādātājs un projekta GnuPG (GNU Privacy Guard) veidotājs, ir izveidojis projektu LibrePGP, kura mērķis ir attīstīt uzlabotu specifikāciju, kas ir alternatīva standarta OpenPGP. Forks tika izveidots, reaģējot uz izmaiņām, ko plānoja IETF darba grupa nākamajam OpenPGP specifikācijas (RFC-4880) atjauninājumam, kuras tika uztvertas kā apšaubāmas attiecībā uz saderības saglabāšanu un drošību. Projekta GnuPG, RNP (OpenPGP realizācija no Thunderbird) un Gpg4win atbalstošie izstrādātāji bažījās, ka ieplānotās izmaiņas varētu būt kaitīgas esošajām OpenPGP programmatūru ieviešanām, kuru lietotāji cer uz specifikācijas stabilitāti ilgtermiņā un nav gatavi pieņemt izmaiņas, kas pārkāpj saderību.

LibrePGP ietver noderīgas uzlabošanas, kas pēdējos gados tika attīstītas nākotnes OpenPGP specifikācijas variantam, bet tajā pašā laikā izslēdz izmaiņas, kas negatīvi ietekmē saderības nodrošināšanu. Piemēram, salīdzinot ar spēkā esošo standartu RFC-4880, LibrePGP ir pieņēmis šādas iespējas:

  • Atbalsts šifrēšanas algoritmam Camellia (RFC-5581),
  • ECC (Elliptic Curve Cryptography) paplašinājumi OpenPGP (RFC-6637).
  • Obligāts atbalsts heshē SHA2-256 (SHA-1 un MD5 ir klasificēti kā neiesakāmi, bet iespēja atšifrēt datus bez integritātes verifikācijas ir klasificēta kā pilnīgi novecojusi).
  • Palielinājums līdz 256 bitiem pārbaudes nospieduma (fingerprint) izmērā.
  • Atbalsts digitālo parakstu EdDSA shēmai un eliptiskajām virsmām BrainpoolP256r1, BrainpoolP384r1, BrainpoolP512r1, Ed25519, Curve25519, Ed488 un X448.
  • Atbalsts algoritmam CRYSTALS-Kyber, kas ir izturīgs pret kvantu datoru uzbrukumiem.
  • Atbalsts autentificētās šifrēšanas režīmiem OCB (Offset Codebook mode).
  • Piektās versijas digitālo parakstu formāta realizācija ar metadatu aizsardzību.
  • Atbalsts papildu subpaketēm ar digitālajiem parakstiem.

Galvenie iebildumi pret jauno OpenPGP specifikāciju:

  • IETF darba grupa, nevis pakāpeniski papildinot specifikāciju, mēģināja no jauna pārformulēt standartu un ieviest tajā nozīmīgas izmaiņas, kas pārkāpj saderību.
  • Atbalsta uzspiešana simetriskajam GCM (Galois/Counter Mode) šifrēšanas režīmam, kuru ir grūti pareizi īstenot, ignorējot OCB (Offset codebook mode) režīmu, kura patenti ir izsniegti pirms vairākiem gadiem.
  • Papildu opciju ieviest randomizētu papildus piepildījumu, lai aizsargātu pret satiksmes analīzi. LibrePGP izstrādātāju viedoklis ir tāds, ka šādi pakotnes ar nevalidējamu sākotnējo randomizētu piepildījumu rada apdraudējumu, to izmantojot slēptiem datu pārsūtīšanas kanāliem un datu noplūdes novēršanas sistēmu apietšanai. Agrāk šī papildu piepildījuma iekļaušanas ideja tika noraidīta, uzskatot to par lietojumprogrammas līmeņa nevis šifrēšanas līmeņa jautājumu.
  • Izmainīta ECDH šifrēšanas shēma (OID formāta izmaiņas) izmantošana, nevis jau iepriekš minētā versija, kas aprakstīta RFC-6637 un īstenota PGP un GnuPG.
  • Noteiktu praktisko iespēju izslēgšana, piemēram, klasiskā atslēgu atsaukšanas metode, MIME datu marķējuma flags «m» un flags «t» tekstu datu atdalīšanai no binārajiem (flagu «t» aizstāj flags «u» tekstiem UTF-8 kodējumā).
  • Jaunajā parakstu formātā netiek iekļauta aizsardzība pret parakstītā faila metadatiem (piemēram, var mainīt faila nosaukumu, neiznīcinot parakstu).
  • Apšaubāmā iespēja pievienot «sāli» parakstiem (Salted signature), lai uzlabotu aizsardzību pret kolīziju uzbrukumiem ar noteiktu prefiksu. Vērtība ar sāli var tikt izmantota kā neatstādināms slēpts kanāls 32 bitu datu pārsūtīšanai parakstā.
  • Standarta pārvietojums uz galveno izmantošanu tiešsaistes komunikācijās, ignorējot vajadzības pēc ilgstošas datu uzglabāšanas.

Atbalstītāji OpenPGP jau ir publicējuši kritiku pret kritiku. Galu galā, ja nav iespējams atrast kompromisu, šķelšanās var novest pie nesaskaņām OpenPGP/LibrePGP īstenojumos. Daļēji šīs problēmas risināšanai OpenPGP izstrādātāji fiksēja piekto parakstu formāta versiju, kas ir saderīga ar LibrePGP un pārgāja pie sestās versijas izstrādes.

Avots: opennet.lv

Iegādājieties uzticamu tīmekļa hostingu ar DDoS aizsardzību, VPS VDS serveriem 🔥 Iegādājieties uzticamu tīmekļa hostingu ar DDoS aizsardzību, VPS VDS serveriem | ProHoster