Kategorija: Interneta ziņas

Izlaidums NGINX Unit 1.24.0 lietojumservera

Iznācis NGINX Unit 1.24 lietojumserveris, kurā attīstās risinājums, lai nodrošinātu tīmekļa lietojumprogrammu palaišanu dažādās programmēšanas valodās (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js un Java). NGINX Unit var vienlaicīgi izpildīt vairākas lietojumprogrammas dažādās programmēšanas valodās, un to palaišanas parametrus var dinamiski mainīt, nemainot konfigurācijas failus un neveicot pārstartēšanu. Kods […]

Iznācis Electron 13.0.0, lietojumprogrammu izstrādes platforma, kas balstīta uz Chromium dzinēja.

Tika sagatavots Electron 13.0.0 platformas laidums, kas nodrošina pašpietiekamu ietvaru daudzplatformu lietojumprogrammu izstrādei, izmantojot Chromium, V8 un Node.js komponentus kā pamatu. Versijas numura būtiskā izmaiņa saistīta ar atjauninājumu uz Chromium 91 kodu bāzi, Node.js 14.16 platformu un V8 9.1 JavaScript dzinēju. Starp izmaiņām jaunajā laidumā: Pievienota process.contextIsolated īpašība, lai noteiktu pašreizējo […]

Iznācis PCRE2 10.37 bibliotēka.

Iznācis PCRE2 10.37 bibliotēka, kas nodrošina funkciju kopumu C valodā ar regulāro izteikumu un parauga saskaņošanas (pattern matching) īstenojumu, kas ir sintaktiski un semantiski līdzīgs Perl 5 regulārajiem izteikumiem. PCRE2 ir pārstrādāta oriģinālās PCRE bibliotēkas implementācija ar nesaderīgu API un paplašinātām iespējām. Bibliotēku izstrādājuši e-pasta servera Exim izstrādātāji un tā tiek izplatīta […]

Microsoft izlaida Windows Package Manager 1.0 pakotņu pārvaldnieku, kas līdzīgs apt un dnf.

Microsoft publicēja Windows Package Manager 1.0 (winget) laidumu, kas nodrošina rīkus lietojumprogrammu instalēšanai, izmantojot komandrindu. Kods ir uzrakstīts C++ valodā un tiek izplatīts saskaņā ar MIT licenci. Pakotnes tiek instalētas no kopienas atbalstīta krājuma. Atšķirībā no programmu instalēšanas no Microsoft Store katalogā, winget ļauj instalēt lietojumprogrammas bez lieka mārketinga un […]

Iznākuši Pacman 6.0 pakotņu pārvaldnieka un Archinstall 2.2.0 instalētāja laidumi.

Ir pieejami jauni Pacman 6.0.0 pakotņu pārvaldnieka un Archinstall 2.2.0 instalētāja laidieni, kas tiek izmantoti Arch Linux izplatījumā. Galvenās izmaiņas Pacman 6.0: Pievienota atbalsts failu lejupielādei vairākos paralēlos straumos. Ieviesta izvadstrīda ar lejupielādes progresu. Lai izslēgtu progresu rādītāju, pacman.conf var norādīt opciju «—noprogressbar». Nodrošināta automātiska spoguļu izlaišana, pie kuriem vēršoties […]

Atvērts HaveIBeenPwned paroles pārbaudes pakalpojuma kods

Trojs Hants (Troy Hunt) ir atvēris «Have I Been Pwned?» (haveibeenpwned.com) kompromiseju šoņu pierakstu pakalpojuma avota kodu, kas pārbauda 11,2 miljardu kontu datu bāzi, kas iegūta pēc 538 vietņu uzlaušanas. Sākotnēji izsludināts iecere atvērt projekta kodu pagājušā gada augustā, bet process bija ieilgušs un kods ir publicēts tikai tagad. Pakalpojuma kods ir rakstīts […]

Mozilla apkopoja plānus Chrome trešā manifesta atbalstam Firefox

Mozilla ir publicējusi plānu Chrome trešā manifesta īstenošanai Firefox, kas nosaka, kādas iespējas un resursus piedāvā paplašinājumiem. Trešais manifests ir pagājis cauri kritikai, jo tas pārtrauca daudzu nevēlamā satura bloķēšanas un drošības paplašinājumu darbību. Firefox plāno īstenot gandrīz visas jaunā manifesta iespējas un ierobežojumus, tostarp deklaratīvo AI satura filtrēšanai (declarativeNetRequest), […]

QUIC protokols ieguvis ieteicamo standartu statusu

IETF (Interneta inženierijas darba grupa), kas nodarbojas ar protokolu un interneta arhitektūras attīstību, ir noslēgusi QUIC protokola RFC izstrādi un publicējusi saistītās specifikācijas ar identifikatoriem RFC 8999 (protokola versijai neatkarīgas īpašības), RFC 9000 (pārvadājums virs UDP), RFC 9001 (TLS šifrēšana QUIC sakarā) un RFC 9002( pārslodzes vadība un pakešu zuduma noteikšana datu pārsūtīšanā). […]

Компания Virtuozzo опубликовала дистрибутив VzLinux, нацеленный на замену CentOS 8

Компания Virtuozzo (бывшее подразделение компании Parallels), разрабатывающая серверное ПО для виртуализации на основе открытых проектов, начала публичное распространение дистрибутива VzLinux, который ранее применялся в качестве базовой операционной системы для развиваемой компанией платформы виртуализации и различных коммерческих продуктов. Отныне VzLinux стал доступен всем желающим и позиционируется как замена CentOS 8, готовая для рабочих внедрений. Для загрузки […]

Выпуск дистрибутива Simply Linux 9.1

Компания Базальт СПО объявила о выходе дистрибутива Simply Linux 9.1, построенного на основе девятой платформы ALT. Продукт распространяется в рамках лицензионного договора, не передающего право на распространение дистрибутива, но позволяющего без ограничений использовать систему физическим и юридическим лицам. Дистрибутив поставляется в сборках для архитектур x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (бета) и может […]

Опубликована СУБД immudb 1.0, обеспечивающая защиту от искажения данных

Представлен значительный выпуск СУБД immudb 1.0, гарантирующей неизменность и сохранение всех когда-либо добавленных данных, а также предоставляющей защиту от внесения изменений задним числом и дающей возможность криптографического доказательства владения данными. Изначально проект развивался как специализированное NoSQL-хранилище, манипулирующее данными в формате ключ/значение, но начиная с выпуска 1.0 immudb позиционируется как полноценная СУБД с поддержкой SQL. Код […]

Доступен дистрибутив AlmaLinux 8.4, продолжающий развитие CentOS 8

Представлен выпуск дистрибутива AlmaLinux 8.4, синхронизированный c дистрибутивом Red Hat Enterprise Linux 8.4. Сборки подготовлены для архитектуры x86_64 в форме загрузочного (709 МБ), минимального (1.9 ГБ) и полного образа (9.8 ГБ). В ближайшее время планируется также опубликовать сборки для архитектуры ARM. Дистрибутив признан готовым для рабочих внедрений и полностью идентичен с RHEL по функциональности, за […]

Iegādājieties uzticamu tīmekļa hostingu ar DDoS aizsardzību, VPS VDS serveriem 🔥 Iegādājieties uzticamu tīmekļa hostingu ar DDoS aizsardzību, VPS VDS serveriem | ProHoster