Pēc piecu mēnešu izstrādes ir izlaists OpenSSH 8.5, atvērtā klienta un servera realizācija darbam ar SSH 2.0 un SFTP protokoliem.
OpenSSH izstrādātāji atgādina par drīzo pāreju uz novecojušo algoritmu statusu, kas izmanto SHA-1 hashi, ņemot vērā kolīziju uzbrukumu ar noteiktu prefiksu efektivitātes pieaugumu (kolīzijas atrašanas izmaksas tiek novērtētas aptuveni 50 tūkstošu dolāru apmērā). Nākamajos izdevumos plānots pēc noklusējuma atslēgt digitālo parakstu algoritmu ar atvērtu atslēgu „ssh-rsa”, kas tiek minēts oriģinālajā RFC SSH protokolam un joprojām ir plaši izplatīts praksē.
Lai pārbaudītu ssh-rsa izmantošanu savās sistēmās, var mēģināt pieslēgties, izmantojot ssh ar opciju „-oHostKeyAlgorithms=-ssh-rsa”. Taču nodrošinājums, ka pēc noklusējuma tiek atslēgti „ssh-rsa” digitālie paraksti, nenozīmē pilnīgu atteikšanos no RSA atslēgām, jo, izņemot SHA-1, SSH protokols atļauj izmantot arī citus hashu aprēķināšanas algoritmus. Piemēram, papildus „ssh-rsa” paliks iespēja izmantot saites „rsa-sha2-256” (RSA/SHA256) un „rsa-sha2-512” (RSA/SHA512).
Lai atvieglotu pāreju uz jauniem algoritmiem, OpenSSH 8.5 pēc noklusējuma ir aktivizēta iestatījums UpdateHostKeys, kas ļauj automātiski pārnest klientus uz drošākiem algoritmiem. Šis iestatījums aktivizē īpašu protokola paplašinājumu „hostkeys@openssh.com”, ļaujot serverim pēc autentifikācijas informēt klientu par visiem pieejamajiem viesu atslēgām. Klients var atspoguļot šīs atslēgas savā failā ~/ .ssh/known_hosts, kas ļauj organizēt viesu atslēgu atjaunošanu un vienkāršo atslēgu maiņu. serveri.
UpdateHostKeys izmantošana ir ierobežota ar dažām piezīmēm, kuras nākotnē var tikt atceltas: atslēgai jābūt minētai UserKnownHostsFile un nedrīkst tikt izmantotai GlobalKnownHostsFile; atslēgai jābūt tikai ar vienu nosaukumu; hosta atslēgas sertifikāts nedrīkst tikt pielietots; known_hosts nedrīkst izmantot maskas, pamatojoties uz hosta nosaukumu; jāatspējo iestatījums VerifyHostKeyDNS; jābūt aktivizētai UserKnownHostsFile parametram.
Starptautiskajās migrācijai ieteiktajos algoritmos ir minēti rsa-sha2-256/512, kas balstīti uz RFC8332 RSA SHA-2 (atbalsta OpenSSH 7.2 un tiek izmantots pēc noklusējuma), ssh-ed25519 (atbalsta OpenSSH 6.5) un ecdsa-sha2-nistp256/384/521, kas balstīti uz RFC5656 ECDSA (atbalsta OpenSSH 5.7).
Citi uzlabojumi:
- Izmaiņas, kas saistītas ar drošību:
- ssh-agent ir novērsta ievainojamība, ko izraisa jau atbrīvotas atmiņas zonas atkārtota atbrīvošana (double-free). Šī problēma izpaužas kopš OpenSSH 8.2 izlaišanas un to potenciāli var izmantot, ja uzbrucējam ir piekļuve ssh-agent soketam lokālajā sistēmā. Izmantošanu sarežģī tas, ka piekļuvi soketam ir tikai root un sākotnējam lietotājam. Visbiežākais uzbrukuma scenārijs ir aģenta novirzīšana uz kontu, kas ir uzbrucēja kontrolē, vai uz hostu, kuram uzbrucējam ir root piekļuve.
- SSHD tagad ir ieviesta aizsardzība pret ļoti lielu parametru pārsūtīšanu ar lietotājvārdu PAM apakšsistēmā, kas ļauj bloķēt ievainojamības PAM (Pluggable Authentication Module) sistēmiskajos moduļos. Piemēram, izmaiņa ļauj novērst SSHD izmantošanu kā vektoru nesen atklātai root ievainojamībai Solarisā (CVE-2020-14871).
- Izmaiņas, kas potenciāli pārkāpj saderību:
- SSH un SSHD ir pārstrādāta ekspermentālā atslēgu apmaiņas metode, kas ir izturīga pret kvant datoru uzbrukumiem. Kvant datoriem ir radikāli ātrākas iespējas atrisināt naturālo skaitļu faktorizācijas problēmu, kas ir mūsdienu asimetrisku šifrēšanas algoritmu pamats un efektīvi nav atrisināma uz klasiskajiem procesoriem. Izmantojot metodi, kas balstīta uz NTRU Prime algoritmu, kas ir izstrādāts postkvantu kriptosistēmām, un X25519 eliptisko krustošanas atslēgu apmaiņas metodi. Tagad metode identificēta kā sntrup761x25519-sha512@openssh.com (sntrup4591761 algoritms ir aizstāts ar sntrup761).
- SSH un SSHD ir mainīts atbalstošo digitālo parakstu algoritmu paziņošanas secība. Tagad pirmais tiek piedāvāts ED25519, nevis ECDSA.
- SSH un SSHD TOS/DSCP kvalitātes parametru iestatījumi interaktīvajiem sesijām tagad tiek veikti pirms TCP savienojuma izveides.
- SSH un SSHD ir pārtraukts rijndael-cbc@lysator.liu.se šifra atbalsts, kas ir identisks aes256-cbc un tika izmantots līdz RFC-4253 apstiprināšanai.
- Por default ir izslēgts CheckHostIP parameters, kuru ieguvums ir nenozīmīgs, taču tā izmantošana būtiski apgrūtina atslēgu rotāciju hostiem aiz slodzes līdzsvarotājiem.
- SSHD ir pievienotas PerSourceMaxStartups un PerSourceNetBlockSize konfigurācijas, lai ierobežotu apstrādātāju uzsākšanas intensitāti, sasaistot ar klienta adresi. Norādītie parametri ļauj precīzāk kontrolēt procesu uzsākšanas ierobežojumus salīdzinājumā ar vispārējo MaxStartups iestatījumu.
- SSH un SSHD ir pievienota jauna LogVerbose konfigurācija, kas ļauj piespiest palielināt reģistrēšanas līmeņa atkļūdošanas informāciju, ar iespēju filtrēt pēc šabloniem, funkcijām un failiem.
- SSH pieņemot jaunu hosta atslēgu nodrošina visu hostu nosaukumu rādīšanu un IP adreses, kas saistīti ar atslēgu.
- SSH atļauts norādīt opciju UserKnownHostsFile=none, lai atslēgtu known_hosts faila izmantošanu hosta atslēgu identifikācijā.
- ssh_config konfigūrācijā ir pievienota iestatījuma KnownHostsCommand funkcija, kas ļauj iegūt known_hosts datus no norādītās komandas izvades.
- ssh_config konfigūrācijā ir pievienota opcija PermitRemoteOpen, kas ļauj ierobežot mērķa punktu, izmantojot RemoteForward ar SOCKS opciju.
- ssh ar FIDO atslēgām nodrošina atkārtotu PIN pieprasījumu, ja digitālās parakstīšanas operācija neizdodas, jo PIN ir nepareizs un lietotājam nav pieprasīts PIN (piemēram, ja neizdodas iegūt pareizos biometrijas datus un ierīce atgriežas pie manuāla PIN ievada).
- sshd Linux platformā ir pievienots atbalsts papildu sistēmas izsaukumiem seccomp-bpf balstītajā procesu izolācijas mehānismā.
- Atjaunināta utilīta contrib/ssh-copy-id.
Avots: opennet.lv
