PÄc 11 mÄneÅ”u izstrÄdes ISC konsorcijs izlaida pirmo stabilo jaunÄs nozÄ«mÄ«gÄs BIND 9.16 DNS servera versijas laidienu. 9.16 versijas atbalsts tiks nodroÅ”inÄts trÄ«s gadus lÄ«dz 2023. gada 2. ceturksnÄ«m kÄ daļa no paplaÅ”inÄtÄ atbalsta cikla. AtjauninÄjumi iepriekÅ”Äjai LTS versijai 9.11 turpinÄs tikt izsniegti lÄ«dz 2021. gada decembrim. 9.14 versijas atbalsts beigsies pÄc trim mÄneÅ”iem.
īpaŔības :
- Pievienots KASP (Key and Signing Policy), vienkÄrÅ”ota metode DNSSEC atslÄgu un digitÄlo parakstu pÄrvaldÄ«bai, balstÄ«ta uz noteikumu definÄÅ”anu ar ādnssec-policyā direktÄ«vu. Å Ä« direktÄ«va ļauj konfigurÄt jaunu atslÄgu Ä£enerÄÅ”anu DNS zonÄm un automÄtisku ZSK un KSK atslÄgu piemÄroÅ”anu.
- IevÄrojami pÄrbÅ«vÄta tÄ«kla apakÅ”sistÄma, kas pÄrgÄjusi uz asynchrone pieprasÄ«jumu apstrÄdes mehÄnismu, balstoties uz bibliotÄku .
PÄrbÅ«ve pagaidÄm nav novestas pie redzamÄm izmaiÅÄm, taÄu turpmÄkajos laidienos tÄ Ä¼aus Ä«stenot dažas bÅ«tiskas veiktspÄjas optimizÄcijas un pievienot atbalstu jauniem protokoliem, piemÄram, DNS over TLS. - Uzlabots DNSSEC uzticamo saistÄ«bu pÄrvaldÄ«bas process (Trust anchor, uzticama atslÄga, kas piesaistÄ«ta zonai Ŕīs zonas autentiskuma pÄrbaudei). TÄ vietÄ, lai izmantotu trusted-keys un managed-keys, kas tagad ir pasludinÄti par novecojuÅ”iem, piedÄvÄta jauna trust-anchors direktÄ«va, kas ļauj pÄrvaldÄ«t abus atslÄgu tipus.
Izmantojot trust-anchors ar atslÄgvÄrdu initial-key, Ŕīs direktÄ«vas uzvedÄ«ba ir identiska managed-keys, t.i., nosaka uzticamo saistÄ«bu konfigurÄciju saskaÅÄ ar RFC 5011. Izmantojot trust-anchors ar atslÄgvÄrdu static-key, uzvedÄ«ba atbilst trusted-keys direktÄ«vai, t.i., nosaka pastÄvÄ«gu atslÄgu, kas netiek automÄtiski atjauninÄta. TÄpat trust-anchors piedÄvÄ vÄl divus atslÄgvÄrdus initial-ds un static-ds, kas ļauj izmantot uzticamo saistÄ«bu formÄtÄ (Delegation Signer) vietÄ, DNSKEY, kas ļauj konfigurÄt saistÄ«bas vÄl nepublicÄtÄm atslÄgÄm (nÄkotnÄ IANA plÄno izmantot DS formÄtu centrÄlo zonu atslÄgÄm).
- RÄ«kos dig, mdig un delv pievienota opcija ā+yamlā izejai YAML formÄtÄ.
- RÄ«kam dig pievienota opcija ā+[no]unexpectedā, kas ļauj pieÅemt atbildes no hostiem, kas atŔķiras no servera, kuram tika nosÅ«tÄ«ts pieprasÄ«jums.
- RÄ«ka dig pievienota opcija Ā«+[no]expandaaaaĀ», kuras izmantoÅ”ana ļauj IPv6 adresÄm ierakstos AAAA tikt parÄdÄ«tÄm pilnÄ 128 bitu attÄlojumÄ, nevis RFC 5952 formÄtÄ.
- Pievienota iespÄja pÄrslÄgt kanÄlu grupas statistiku.
- DS un CDS ieraksti tagad tiek Ä£enerÄti tikai, balstoties uz SHA-256 hash, izbeidzot SHA-1 Ä£enerÄciju.
- DNS Cookie (RFC 7873) noklusÄjuma algoritms ir SipHash 2-4, bet HMAC-SHA atbalsts ir izbeigts (AES atstÄts).
- Dnssec-signzone un dnssec-verify komandu izvade tagad tiek novirzÄ«ta uz standarta izejas plÅ«smu (STDOUT), bet STDERR tiek attÄlota tikai kļūdu un brÄ«dinÄjumu informÄcija (norÄdot opciju Ā«-fĀ», tiek parÄdÄ«ta arÄ« parakstÄ«tÄ zona). Opcija Ā«-qĀ» pievienota tusÄÅ”anai.
- DNSSEC validÄcijas kods ir pÄrstrÄdÄts, atbrÄ«vojoties no koda dublÄÅ”anÄs ar citÄm apakÅ”sistÄmÄm.
- Statistikas izvade JSON formÄtÄ tagad var izmantot tikai JSON-C bibliotÄku. Configure opcija Ā«āwith-libjsonĀ» pÄrdÄvÄta par Ā«āwith-json-cĀ».
- Configure skriptÄ vairs automÄtiski netiek iestatÄ«ts parametrs Ā«āsysconfdirĀ» uz /etc un Ā«ālocalstatedirĀ» uz /var, ja nav norÄdÄ«ts Ā«āprefixĀ». PÄc noklusÄjuma izmantoti ceļi $prefix/etc un $prefix/var, ko pielieto Autoconf.
- Kods ar DLV (Domain Look-aside Verification, opcija dnssec-lookaside) pakalpojuma Ä«stenojumu ir izdzÄsts, jo tas tika atzÄ«ts par novecojuÅ”u BIND 9.12, un ar to saistÄ«tais dlv.isc.org apstrÄdÄtÄjs tika izslÄgts 2017. gadÄ. DLV izdzÄÅ”ana ļÄva vienkÄrÅ”ot BIND kodu.
Avots: opennet.lv
