FreeBSD 12.3 iznākums

Tika prezentēts FreeBSD 12.3 izlaidums, kas publicēts arhitektūrām amd64, i386, powerpc, powerpc64, powerpcspe, sparc64 un armv6, armv7 un aarch64. Papildus ir sagatavoti attēli virtualizācijas sistēmām (QCOW2, VHD, VMDK, raw) un Amazon EC2 mākoņa vidēm. FreeBSD 13.1 izlaidums gaidāms 2022. gada pavasarī.

Galvenās jaunās funkcijas:

  • Tika pievienots skripts /etc/rc.final, kas tiek izpildīts pēdējā darba posmā pēc visu lietotāja procesu pabeigšanas.
  • Iepakojuma filtrā ipfw ir iekļauta komanda dnctl, lai pārvaldītu dummynet trafika ierobežojumu iestatījumus.
  • Tika pievienots sysctl kern.crypto, lai pārvaldītu kodola kriptosistēmu, kā arī atsevišķs atvēršanas sysctl debug.uma_reclaim.
  • Tika pievienots sysctl net.inet.tcp.tolerate_missing_ts, kas ļauj TCP paketēm bez laika zīmēm (timestamp opcija, RFC 1323/RFC 7323).
  • GENERIC kodolā amd64 arhitektūrai ir iekļauta opcija COMPAT_LINUXKPI un aktivizēts draiveris mlx5en (NVIDIA Mellanox ConnectX-4/5/6).
  • Ielādētājā pievienota operētājsistēmas ielādes iespēja no RAM diska, kā arī ieviesta ZFS opciju atbalsts com.delphix:bookmark_written un com.datto:bookmark_v2.
  • Fetch bibliotēkā pievienots atbalsts FTP proksēšanai virs HTTPS.
  • Paketēšanas pārvaldniekā pkg komandām 'bootstrap' un 'add' ieviests karogs '-r' repo zīlēšanai. Nodrošināta vides mainīgo izmantošana no faila pkg.conf.
  • Rīku growfs pievienota iespēja strādāt ar failu sistēmām, kas ir montētas lasīšanas un rakstīšanas režīmā.
  • Utīlītā etcupdate ir ieviests izmaiņu atjaunošanas režīms, lai atjaunotu vienu vai vairākus failus. Pievienots karogs '-D' mērķa kataloga norādīšanai. Nodrošināta datu iegūšana, izmantojot pagaidu katalogu, un pievienota SIGINT apstrāde.
  • Rīkos freebsd-update un freebsd-version pievienots karogs '-j' cietuma vidēm.
  • Rīku cpuset tagad var izmantot cietuma vidēs, lai mainītu apakšējo cietumu parametrus.
  • Rīku cmp pievienotas opcijas: '-b' (—print-bytes), lai izvairītos no atšķirīgajiem baitiem, '-i' (—ignore-initial), lai ignorētu noteiktu skaitu sākotnējo baitiem, '-n' (—bytes), lai ierobežotu salīdzināmo baitus skaitu.
  • Rīku daemon ieviests karogs '-H', lai apstrādātu SIGHUP un atkārtoti atvērtu failu, kurā tiek veiktas izlases (pievienots, lai atbalstītu newsyslog).
  • Rīku fstyp norādot karogu '-l' nodrošināta exFAT failu sistēmu noteikšana un attēlošana.
  • Rīkā mergemaster ir īstenota simbolisko saišu apstrāde atjaunināšanas procesā.
  • Rīkā newsyslog pievienota karoga «E» izslēgšanai tukšo žurnālu rotācijai.
  • Rīkā tcpdump pievienota iespēja dekodēt paketes pfsync saskarnēs.
  • Rīkā top pievienota filtrēšanas komanda «/» tikai tiem procesiem vai argumentiem, kas atbilst norādītajai virknei.
  • Rīkā unzip pievienota atbalsts paroles aizsargātiem arhīviem.
  • Uzlabots aparatūras atbalsts. Pievienoti PCI ierīču identifikatori AHCI kontrolieriem ASMedia ASM116x un I2C kontrolieriem Intel Gemini Lake. īstenota atbalsts tīkla adapteriem Mikrotik 10/25G un bezvadu kartēm Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14. Pievienots jauns igc draiveris Intel I225 2.5G/1G/100MB/10MB ethernet kontrolieriem.
  • Netgraph mezgls ng_bridge pielāgots SMP sistēmām. Mezglā ng_nat pievienots atbalsts CGN (Carrier Grade NAT, RFC 6598). Nodrošināta iespēja ievietot mezglu ng_source jebkurā Netgraph tīkla daļā.
  • Rīcī rctl, kas tiek izmantots resursu ierobežošanai, pievienota iespēja iestatīt resursu patēriņa ierobežojumu 0 vērtībai.
  • VLAN interfeisā pievienots atbalsts trafika prioritātes sistēmai un ALTQ caurlaidspējas kontrolei.
  • Draiveros amdtemp un amdsmn īstenots atbalsts CPU Zen 3 «Vermeer» un APU Ryzen 4000 (Zen 2, «Renoir»).
  • Atjauninātās versijas iekļautajām trešo pušu lietotnēm, kas ietilpst bāzes sistēmā: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. Rīks unzip synchronizēts ar NetBSD kodu bāzi.

Avots: opennet.lv

Iegādājieties uzticamu tīmekļa hostingu ar DDoS aizsardzību, VPS VDS serveriem 🔥 Iegādājieties uzticamu tīmekļa hostingu ar DDoS aizsardzību, VPS VDS serveriem | ProHoster