Notika vieglais http-server lighttpd 1.4.65, kas cenšas apvienot augstu veiktspēju, drošību, standartiem atbilstību un pielāgošanas elastību. Lighttpd ir piemērots augsti noslogotām sistēmām un mērķē uz zemu atmiņas un CPU resursu patēriņu. Jaunajā versijā ir 173 izmaiņas. Projekta kods ir uzrakstīts C valodā un tiek izplatīts saskaņā ar BSD licenci.
Galvenās jauninājumi:
- Pievienota WebSocket atbalsta funkcionalitāte virs HTTP/2, kā arī realizēts RFC 8441, kas apraksta mehānismu WebSocket protokola palaišanai vienā pavedienā HTTP/2 savienojuma iekšienē.
- Realizēta paplašināta prioritāšu vadības shēma, kas ļauj klientam ietekmēt pārsūtīto serveri atbilžu prioritātes (RFC 9218), kā arī pārvaldīt prioritātes pie pieprasījumu pāradresēšanas. HTTP/2 nodrošina atbalstu PRIORITY_UPDATE kadram.
- lighttpd.conf iestatījumos pievienota atbalsta iespēja nosacītajām saskaņām, piesaistot tās rindiņas sākumam (=^) un beigām (=$). Šādas rindiņu pārbaudes ir daudz ātrākas par regulāriem izteiksmes un ir pietiekamas daudzām vienkāršām pārbaudēm.
- mod_webdav pievienots daļēju PUT operāciju atbalsts (iekļaujot daļu datu ar Range galveni). To var iespējot, izmantojot opciju 'webdav.opts += ("partial-put-copy-modify" => "enable").
- mod_accesslog pievienota opcija 'accesslog.escaping = 'json'.
- mod_deflate pievienots atbalsts kompaktēšanai ar libdeflate.
- HTTP/2 pieprasījuma ķermeņa pārsūtīšana paātrināta.
- Parametra server.max-keep-alive-requests noklusējuma vērtība mainīta no 100 uz 1000.
- MIME tipu sarakstā 'application/javascript' aizstāts ar 'text/javascript' (RFC 9239).
Nākotnē plānots izmantot stingrākas šifrēšanas iestatījumus TLS un noklusējumā izslēgt novecojušās šifras. Iestatījums CipherString tiks mainīts no 'HIGH' uz 'EECDH+AESGCM:AES256+EECDH:CHACHA20:SHA256:!SHA384'. Tāpat ir paredzēts izņemt novecojušās TLS opcijas: ssl.honor-cipher-order, ssl.dh-file, ssl.ec-curve, ssl.disable-client-renegotiation, ssl.use-sslv2, ssl.use-sslv3. Papildus turpināsies mini-moduļu tīrīšana, kurus var aizstāt ar elastīgāku Lua realizāciju mod_magnet. Jo īpaši ir plānots izņemt mod_evasive, mod_secdownload, mod_uploadprogress un mod_usertrack moduļus.
Avots: opennet.lv
