{"id":112077,"date":"2023-12-08T15:10:14","date_gmt":"2023-12-08T13:10:14","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp"},"modified":"2023-12-08T15:10:14","modified_gmt":"2023-12-08T13:10:14","slug":"avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","status":"publish","type":"post","link":"https:\/\/prohoster.info\/lv\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","title":{"rendered":"GnuPG autors izveidoja LibrePGP, OpenPGP standarta forku.","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>Verners Ko\u010ds (Werner Koch), galvenais izstr\u0101d\u0101t\u0101js un projekta GnuPG (GNU Privacy Guard) veidot\u0101js, ir izveidojis projektu LibrePGP, kura m\u0113r\u0137is ir att\u012bst\u012bt uzlabotu specifik\u0101ciju, kas ir alternat\u012bva standarta OpenPGP. Forks tika izveidots, rea\u0123\u0113jot uz izmai\u0146\u0101m, ko pl\u0101noja IETF darba grupa n\u0101kamajam OpenPGP specifik\u0101cijas (RFC-4880) atjaunin\u0101jumam, kuras tika uztvertas k\u0101 ap\u0161aub\u0101mas attiec\u012bb\u0101 uz sader\u012bbas saglab\u0101\u0161anu un dro\u0161\u012bbu. Projekta GnuPG, RNP (OpenPGP realiz\u0101cija no Thunderbird) un Gpg4win atbalsto\u0161ie izstr\u0101d\u0101t\u0101ji ba\u017e\u012bj\u0101s, ka iepl\u0101not\u0101s izmai\u0146as var\u0113tu b\u016bt kait\u012bgas eso\u0161aj\u0101m OpenPGP programmat\u016bru ievie\u0161an\u0101m, kuru lietot\u0101ji cer uz specifik\u0101cijas stabilit\u0101ti ilgtermi\u0146\u0101 un nav gatavi pie\u0146emt izmai\u0146as, kas p\u0101rk\u0101pj sader\u012bbu.    <\/p>\n<p>LibrePGP ietver noder\u012bgas uzlabo\u0161anas, kas p\u0113d\u0113jos gados tika att\u012bst\u012btas n\u0101kotnes OpenPGP specifik\u0101cijas variantam, bet taj\u0101 pa\u0161\u0101 laik\u0101 izsl\u0113dz izmai\u0146as, kas negat\u012bvi ietekm\u0113 sader\u012bbas nodro\u0161in\u0101\u0161anu. Piem\u0113ram, sal\u012bdzinot ar sp\u0113k\u0101 eso\u0161o standartu RFC-4880, LibrePGP ir pie\u0146\u0113mis \u0161\u0101das iesp\u0113jas:  <\/p>\n<ul>\n<li class=\"l\"> Atbalsts \u0161ifr\u0113\u0161anas algoritmam Camellia (RFC-5581),\n<li class=\"l\"> ECC (Elliptic Curve Cryptography) papla\u0161in\u0101jumi OpenPGP (RFC-6637).\n<li class=\"l\"> Oblig\u0101ts atbalsts hesh\u0113 SHA2-256 (SHA-1 un MD5 ir klasific\u0113ti k\u0101 neiesak\u0101mi, bet iesp\u0113ja at\u0161ifr\u0113t datus bez integrit\u0101tes verifik\u0101cijas ir klasific\u0113ta k\u0101 piln\u012bgi novecojusi).\n<li class=\"l\"> Palielin\u0101jums l\u012bdz 256 bitiem p\u0101rbaudes nospieduma (fingerprint) izm\u0113r\u0101.\n<li class=\"l\"> Atbalsts digit\u0101lo parakstu EdDSA sh\u0113mai un eliptiskaj\u0101m virsm\u0101m BrainpoolP256r1, BrainpoolP384r1, BrainpoolP512r1, Ed25519, Curve25519, Ed488 un X448.\n<li class=\"l\"> Atbalsts algoritmam CRYSTALS-Kyber, kas ir iztur\u012bgs pret kvantu datoru uzbrukumiem.\n<li class=\"l\"> Atbalsts autentific\u0113t\u0101s \u0161ifr\u0113\u0161anas re\u017e\u012bmiem OCB (Offset Codebook mode).\n<li class=\"l\"> Piekt\u0101s versijas digit\u0101lo parakstu form\u0101ta realiz\u0101cija ar metadatu aizsardz\u012bbu.\n<li class=\"l\"> Atbalsts papildu subpaket\u0113m ar digit\u0101lajiem parakstiem.  <\/ul>\n<p>Galvenie iebildumi pret jauno OpenPGP specifik\u0101ciju:  <\/p>\n<ul>\n<li class=\"l\"> IETF darba grupa, nevis pak\u0101peniski papildinot specifik\u0101ciju, m\u0113\u0123in\u0101ja no jauna p\u0101rformul\u0113t standartu un ieviest taj\u0101 noz\u012bm\u012bgas izmai\u0146as, kas p\u0101rk\u0101pj sader\u012bbu.\n<li class=\"l\"> Atbalsta uzspie\u0161ana simetriskajam GCM (Galois\/Counter Mode) \u0161ifr\u0113\u0161anas re\u017e\u012bmam, kuru ir gr\u016bti pareizi \u012bstenot, ignor\u0113jot OCB (Offset codebook mode) re\u017e\u012bmu, kura patenti ir izsniegti pirms vair\u0101kiem gadiem.\n<li class=\"l\"> Papildu opciju ieviest randomiz\u0113tu papildus piepild\u012bjumu, lai aizsarg\u0101tu pret satiksmes anal\u012bzi. LibrePGP izstr\u0101d\u0101t\u0101ju viedoklis ir t\u0101ds, ka \u0161\u0101di pakotnes ar nevalid\u0113jamu s\u0101kotn\u0113jo randomiz\u0113tu piepild\u012bjumu rada apdraud\u0113jumu, to izmantojot sl\u0113ptiem datu p\u0101rs\u016bt\u012b\u0161anas kan\u0101liem un datu nopl\u016bdes nov\u0113r\u0161anas sist\u0113mu apiet\u0161anai. Agr\u0101k \u0161\u012b papildu piepild\u012bjuma iek\u013cau\u0161anas ideja tika noraid\u012bta, uzskatot to par lietojumprogrammas l\u012bme\u0146a nevis \u0161ifr\u0113\u0161anas l\u012bme\u0146a jaut\u0101jumu.\n<li class=\"l\"> Izmain\u012bta ECDH \u0161ifr\u0113\u0161anas sh\u0113ma (OID form\u0101ta izmai\u0146as) izmanto\u0161ana, nevis jau iepriek\u0161 min\u0113t\u0101 versija, kas aprakst\u012bta RFC-6637 un \u012bstenota PGP un GnuPG.\n<li class=\"l\"> Da\u017eu praktisko iesp\u0113ju, piem\u0113ram, klasisk\u0101 atsl\u0113gu atsauk\u0161anas metode, MIME datu mar\u0137\u0113\u0161anas flags &#171;m&#187; un flags &#171;t&#187; tekstu datu atdal\u012b\u0161anai no bin\u0101rajiem (flagu &#171;t&#187; viet\u0101 tika ieviests flags &#171;u&#187; UTF-8 kod\u0113\u0161anas tekstiem), iz\u0146em\u0161ana.\n<li class=\"l\"> Jaunaj\u0101 parakstu form\u0101t\u0101 netiek iek\u013cauta aizsardz\u012bba pret parakst\u012bt\u0101 faila metadatiem (piem\u0113ram, var main\u012bt faila nosaukumu, neizn\u012bcinot parakstu).\n<li class=\"l\"> Ap\u0161aub\u0101m\u0101 iesp\u0113ja pievienot &#171;s\u0101li&#187; parakstiem (Salted signature) aizsardz\u012bbas uzlabo\u0161anai pret kol\u012bzijas uzbrukumiem ar noteiktu prefiksu. S\u0101ls v\u0113rt\u012bba var tikt izmantota k\u0101 neizsl\u0113dzams sl\u0113ptais kan\u0101ls 32 baitu datu nos\u016bt\u012b\u0161anai parakst\u0101.\n<li class=\"l\"> Standarta p\u0101rvietojums uz galveno izmanto\u0161anu tie\u0161saistes komunik\u0101cij\u0101s, ignor\u0113jot vajadz\u012bbas p\u0113c ilgsto\u0161as datu uzglab\u0101\u0161anas.  <\/ul>\n<p>Atbalst\u012bt\u0101ji OpenPGP jau ir public\u0113ju\u0161i kritiku pret kritiku. Galu gal\u0101, ja nav iesp\u0113jams atrast kompromisu, \u0161\u0137el\u0161an\u0101s var novest pie nesaska\u0146\u0101m OpenPGP\/LibrePGP \u012bstenojumos. Da\u013c\u0113ji \u0161\u012bs probl\u0113mas risin\u0101\u0161anai OpenPGP izstr\u0101d\u0101t\u0101ji fiks\u0113ja piekto parakstu form\u0101ta versiju, kas ir sader\u012bga ar LibrePGP un p\u0101rg\u0101ja pie sest\u0101s versijas izstr\u0101des.<br \/>\n<br \/>Avots: <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=60256\">opennet.lv<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP. \u0424\u043e\u0440\u043a \u0431\u044b\u043b \u0441\u043e\u0437\u0434\u0430\u043d \u0432 \u043e\u0442\u0432\u0435\u0442 \u043d\u0430 \u0438\u0437\u043c\u0435\u043d\u0435\u043d\u0438\u044f, \u043d\u0430\u043c\u0435\u0447\u0435\u043d\u043d\u044b\u0435 \u0440\u0430\u0431\u043e\u0447\u0435\u0439 \u0433\u0440\u0443\u043f\u043f\u043e\u0439 IETF \u0434\u043b\u044f \u0432\u043d\u0435\u0441\u0435\u043d\u0438\u044f \u0432 \u0441\u043b\u0435\u0434\u0443\u044e\u0449\u0435\u0435 \u043e\u0431\u043d\u043e\u0432\u043b\u0435\u043d\u0438\u0435 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438 OpenPGP (RFC-4880) \u0438 \u0432\u043e\u0441\u043f\u0440\u0438\u043d\u044f\u0442\u044b\u0435 \u041a\u043e\u0445\u043e\u043c \u043a\u0430\u043a \u0441\u043e\u043c\u043d\u0438\u0442\u0435\u043b\u044c\u043d\u044b\u0435 \u0441 \u0442\u043e\u0447\u043a\u0438 \u0437\u0440\u0435\u043d\u0438\u044f \u0441\u043e\u0445\u0440\u0430\u043d\u0435\u043d\u0438\u044f \u0441\u043e\u0432\u043c\u0435\u0441\u0442\u0438\u043c\u043e\u0441\u0442\u0438 \u0438 \u043e\u0431\u0435\u0441\u043f\u0435\u0447\u0435\u043d\u0438\u044f [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-112077","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.5 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/lv\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp\" \/>\n\t\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.5\" \/>\n\t\t<meta property=\"og:locale\" content=\"lv_LV\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u0410\u0432\u0442\u043e\u0440 GnuPG \u043e\u0441\u043d\u043e\u0432\u0430\u043b LibrePGP, \u0444\u043e\u0440\u043a \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0430 OpenPGP | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/lv\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-12-08T13:10:14+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-12-08T13:10:14+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47GnuPG autors izveidoja LibrePGP, OpenPGP standarta forku | ProHoster","description":"Verners Koha (Werner Koch), galvenais izstr\u0101d\u0101t\u0101js un projekta GnuPG (GNU Privacy Guard) dibin\u0101t\u0101js, izveidoja projektu LibrePGP, koncentr\u0113joties uz atjaunin\u0101tas specifik\u0101cijas att\u012bst\u012bbu, alternat\u012bvu OpenPGP standartam.","canonical_url":"https:\/\/prohoster.info\/lv\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"lv_LV","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u0410\u0432\u0442\u043e\u0440 GnuPG \u043e\u0441\u043d\u043e\u0432\u0430\u043b LibrePGP, \u0444\u043e\u0440\u043a \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0430 OpenPGP | ProHoster","og:description":"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.","og:url":"https:\/\/prohoster.info\/lv\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-12-08T13:10:14+00:00","article:modified_time":"2023-12-08T13:10:14+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/lv\/wp-json\/wp\/v2\/posts\/112077","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/lv\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/lv\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/lv\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/lv\/wp-json\/wp\/v2\/comments?post=112077"}],"version-history":[{"count":0,"href":"https:\/\/prohoster.info\/lv\/wp-json\/wp\/v2\/posts\/112077\/revisions"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/lv\/wp-json\/wp\/v2\/media?parent=112077"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/lv\/wp-json\/wp\/v2\/categories?post=112077"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/lv\/wp-json\/wp\/v2\/tags?post=112077"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}