De release van de hoofdversie nginx 1.21.4 is geformuleerd, waarin de ontwikkeling van nieuwe mogelijkheden voortzet (in de parallel ondersteunde stabiele versie 1.20 worden alleen wijzigingen aangebracht die verband houden met het verhelpen van ernstige fouten en kwetsbaarheden).
Belangrijkste wijzigingen:
- De ondersteuning voor het instellen van HTTP/2-verbindingen met behulp van de extensie NPN (Next Protocol Negotiation) in plaats van ALPN is beëindigd;
- Zorg voor sluiting SSL-verbindingen bij gebruik van de extensie ALPN door de klant, als tijdens de onderhandeling over verbindingen geen ondersteund protocol is gekozen;
- In de directive «sendfile_max_chunk» is de standaardwaarde gewijzigd naar 2 megabyte.
- In de stream-module is de richtlijn proxy_half_close toegevoegd, waarmee het gedrag bij het sluiten van een proxied TCP-verbinding aan één kant kan worden ingesteld (‘TCP half-close’);
- In de stream-module is de richtlijn ssl_alpn toegevoegd voor het bepalen van de lijst van ondersteunde ALPN-protocollen (h2, http/1.1) en de variabele $ssl_alpn_protocol, die het met de klant overeengekomen ALPN-protocol weerspiegelt;
- Ondersteuning toegevoegd voor het aanroepen van SSL_sendfile() bij gebruik van OpenSSL 3.0;
- De richtlijn 'mp4_start_key_frame' is toegevoegd in de ngx_http_mp4_module voor het streamen van videobestanden, beginnend met een keyframe.
- De instelling van de variabele $content_length bij gebruik van chunked transfer encoding gecorrigeerd;
- Een fout in de caching van de verbinding is opgelost bij het ontvangen van een antwoord met een onjuiste lengte van de proxied backend;
- Logging is gecorrigeerd naar 'error' in plaats van 'info' bij onjuiste headers van backends;
- Fouten bij het vastlopen van verzoeken bij gebruik van HTTP/2 en de aio_write-directive gecorrigeerd.
Bron: opennet.ru
