Oracle heeft een corrigerende release gepubliceerd voor het virtualisatiesysteem VirtualBox 7.2.10, waarin 14 wijzigingen zijn doorgevoerd:
- In de aanvullingen voor gastsystemen en hostomgevingen met Linux is basisondersteuning voor kernel Linux 7.1 toegevoegd, zijn extra hersteloplossingen opgenomen voor de distributie RHEL 9.8, en is een fout verholpen bij het bouwen van kernelmodules in openSUSE 16.0. Ondersteuning is toegevoegd voor het bouwen van de broncode met behulp van de assembler NASM in plaats van YASM.
- In de aanvullingen voor hostomgevingen met Linux is een probleem opgelost dat de opstart verhinderde virtuele machines door fouten in de kernel.
- In de aanvullingen voor gastsystemen met Linux is basisondersteuning voor het Extended Data Control-protocol toegevoegd voor toegang tot het klembord in gastsystemen met KDE Plasma die Waland gebruiken. De bouw van de module vboxvideo is gestroomlijnd voor kernelversies 7.0 en 7.1.
- De opstartfout van virtuele machines met CentOS 10 die aangaf dat de CPU geen ondersteuning biedt voor de subarchitectuur x86-64-v3, is verholpen.
- Problemen met de opstart op ARM-systemen voor virtuele machines met minder dan 1024 MiB RAM zijn opgelost.
- Een probleem is verholpen waardoor het VIRTIO-SCSI-apparaat niet als SSD werd herkend in het gastbesturingssysteem.
- Problemen in de code van de E1000-netwerkadapteremulator, die het opstarten van OS/2 in het gastbesturingssysteem verhinderden, zijn opgelost.
- In de aanvullingen voor gastsystemen met OS/2 zijn problemen met de automatische montage van gedeelde mappen en de niet-functionerende klembord opgelost.
Bron: opennet.ru
