De mailserver Mox 0.0.15 is beschikbaar

De release van het Mox-project 0.0.15 is gepubliceerd, waarmee een uitgebreide oplossing wordt ontwikkeld voor het functioneren van mailservers. Dit omvat alle componenten die nodig zijn voor het verzenden en ontvangen van e-mail. Het biedt eigen implementaties van SMTP- en IMAP4-servers, een systeem voor het filteren van ongewenste inhoud, evenals webinterfaces voor zowel beheerders als gebruikers. De code van het project is geschreven in de programmeertaal Go en wordt verspreid onder de MIT-licentie.

Het doel van het project is om een "alles-in-ƩƩn" oplossing te creƫren die het eenvoudig maakt om een functionerende mailserver op te zetten zonder tijdrovende configuratie en zonder de noodzaak om verschillende afzonderlijke diensten en applicaties met elkaar te verbinden. Het wordt verwacht dat vanwege de complicaties bij het inzetten en onderhouden van mailservers, servers consumenten de voorkeur geven aan gecentraliseerde e-mailproviders, waardoor het idee van e-mail als een gedecentraliseerde service, bestaande uit talrijke eigen mailservers, wordt ondermijnd.

Mox maakt het mogelijk om binnen 10 minuten een beveiligde mailserver voor je domeinen in te stellen, die de moderne protocolstack ondersteunt en geen extra afhankelijkheden vereist. De software-update op de mailserver beperkt zich tot het downloaden van de nieuwe versie van mox en het herstarten. Ontvangst en updates TLS-certificaten gebeuren automatisch. Voor configuratie en het uitvoeren van onderhoudstaken kan de webinterface worden gebruikt, terwijl voor geavanceerde configuratie een configuratiebestand beschikbaar wordt gesteld.

Om veiligheidsproblemen te voorkomen die ontstaan bij laag-niveau geheugentoegang, wordt de programmeertaal Go gebruikt tijdens de ontwikkeling. Voor het behoud van een hoge kwaliteit van de codebasis worden handmatige en geautomatiseerde testen van de compatibiliteit met populaire mailservers en clients, unit-tests en fuzzing-tests toegepast, evenals uitgebreide documentatie van de code.

De belangrijkste functies van Mox:

  • Ondersteuning van de protocollen SMTP en IMAP4.
  • Gebruik van SPF-, DKIM- en DMARC-uitspraken voor de identificatie van maildomeinen, bevestiging van verzendbevoegdheden en authenticatie van berichten.
  • Monitoring van de reputatie van hosts, domeinen en afzenders. Gebruik van een Bayesiaanse classifier, DNSBL en grijze lijsten voor het filteren van ongewenste berichten.
  • Ondersteuning voor extensies voor het gebruik van Unicode en nationale alfabetten in namen en domeinen.
  • Automatische verwerving van TLS-certificaten in certificeringsinstanties die het ACME-protocol ondersteunen, zoals Let’s Encrypt.
  • Ondersteuning van DANE en MTA-STS mechanismen voor het versleutelen van inkomende en uitgaande berichten bovenop SMTP met de STARTTLS-uitbreiding.
  • Ingebouwde Webmail voor het lezen en verzenden van e-mail via een browser.
  • Ingebouwde webinterface voor beheerders om domeinen en accountinstellingen te beheren, SPF/DKIM/DMARC/TLSRPT/MTA-STS in te stellen, statistieken te bekijken en configuratieparameters te wijzigen.
  • Beschikbaarheid van een http-server voor het leveren van statische bestanden en het omleiden van verzoeken (reverse proxy).
  • Aanbieden van een HTTP/JSON API voor het verzenden/uploaden van e-mails en het ontvangen van gerelateerde afleveringsgebeurtenissen.
  • Export van metrics naar het monitoring systeem Prometheus.
  • Ondersteuning voor extensies voor de automatische configuratie van e-mailclients (DNS SRV, https://autoconfig.domein, QR-code).

Onder de wijzigingen in de nieuwe versie:

  • Ondersteuning voor IMAP-extensies toegevoegd:
    • NOTIFY (RFC 5465) voor het volgen van het verschijnen van berichten,
    • UIDONLY (RFC 9586) voor het opvragen van berichten per UID om de belasting op de server te verminderen.
    • MULTISEARCH (RFC 7203) voor het zoeken in postvakjes,
    • PREVIEW (RFC 8970) voor een snelle voorvertoning van berichten,
    • REPLACE (RFC 8508) voor het vervangen van inhoud in conceptberichten,
    • MULTIAPPEND (RFC 3502) voor het tegelijk toevoegen van meerdere berichten,
    • METADATA (RFC 5464) voor het opslaan van metadata,
    • INPROGRESS (RFC 9585) voor het doorgeven van statusinformatie over langdurige bewerkingen,
    • NAMESPACE (RFC 2342) voor het definiĆ«ren van naamruimtes voor postvakjes,
    • WITHIN (RFC 5032) voor zoeken binnen tijdsintervallen,
    • CREATE-SPECIAL-USE (RFC 6154) voor het aanmaken van speciale postvakjes, zoals ā€˜Inkomend’ en ā€˜Verzonden’,
    • SAVEDATE (RFC 8514) voor het bijhouden van de tijd waarop een bericht in het postvakje is opgeslagen.
  • Een instelling toegevoegd voor het verwerken van scheidingstekens ā€˜+’ en ā€˜-’ in e-mailadressen (you+anything@example.com en you-anything@example.com).
  • Een instelling toegevoegd voor het verbieden van het wijzigen van wachtwoorden (alleen autogeneratie van een betrouwbaar wachtwoord).
  • Een instelling toegevoegd voor het weigeren van inkomende afleveringen bij fouten in de SMTP-transactie.
  • In Webmail is een knop toegevoegd voor het downloaden van een bericht in het eml- of mbox/maildir-formaat in zip/tgz/tar-archieven, evenals knoppen om het postvakje als gelezen te markeren en om extra postvakjes aan te maken.

Bron: opennet.ru

Koop betrouwbare webhosting met bescherming tegen DDoS, VPS VDS servers šŸ”„ Koop betrouwbare webhosting met bescherming tegen DDoS, VPS VDS servers | ProHoster