Implementatie van cryptografische algoritmen GOST in de programmeertaal Java.

De crypto-gost-bibliotheek is uitgebracht met een implementatie van de GOST-cryptografische algoritmen in Java, zonder extra afhankelijkheden. In tegenstelling tot de implementatie van GOST-algoritmen uit de Castle Bouncy Castle-bibliotheek, biedt crypto-gost verbeterde versleutelingsefficiëntie met het algoritme 'Kuznechik', lost het afzonderlijke beveiligingsproblemen op en biedt het eenvoudige wrappers die geen diepgaande kennis van cryptografie vereisen. De code wordt geleverd onder een eigen permissieve licentie die distributie, modificatie en het creëren van afgeleide werken zonder beperkingen toestaat.

Ondersteunde algoritmen:

  • GOST R 34.11-2012 (RFC 6986) — hashfunctie 'Streebog' van 256 en 512 bits.
  • GOST R 34.12-2015 — blokversleuteling 'Kuznechik', sleutel van 256 bits.
  • GOST R 34.13-2015 — versleutelingsmodi CBC, CFB, CTR (GAMMA), OFB; authentiekatiemethodes (CMAC).
  • GOST R 34.10-2012 (RFC 7091) — elektronische handtekening van 256 en 512 bits.
  • HMAC-Streebog (RFC 7836, HMAC-Streebog-256 en HMAC-Streebog-512).
  • MGM (Multilinear Galois Mode) — AEAD-modus voor Kuznechik (RFC 9058). Compatibel met OpenSSL.
  • SCrypt (RFC 7914) — een key derivation functie gebaseerd op een wachtwoord.

Bron: opennet.ru

Koop betrouwbare webhosting met bescherming tegen DDoS, VPS VDS servers 🔥 Koop betrouwbare webhosting met bescherming tegen DDoS, VPS VDS servers | ProHoster