De release van FreeBSD 12.3 is gepresenteerd, die is gepubliceerd voor de architecturen amd64, i386, powerpc, powerpc64, powerpcspe, sparc64, en armv6, armv7 en aarch64. Daarnaast zijn er images voorbereid voor virtualisatiesystemen (QCOW2, VHD, VMDK, raw) en cloudomgevingen van Amazon EC2. De release van FreeBSD 13.1 wordt verwacht in de lente van 2022.
Belangrijke vernieuwingen:
- Er is een script /etc/rc.final toegevoegd, dat wordt uitgevoerd in de laatste fase van het proces na het voltooien van alle gebruikersprocessen.
- In het ipfw-filterpakket is de dnctl-commando toegevoegd voor het beheren van de instellingen van het dummynet-verkeerslimiteringssysteem.
- Sysctl kern.crypto is toegevoegd voor het beheren van de cryptosubsystemen van de kernel, evenals de debug sysctl debug.uma_reclaim.
- Sysctl net.inet.tcp.tolerate_missing_ts is toegevoegd, wat TCP-pakketten zonder tijdstempels toestaat (timestamp-optie, RFC 1323/RFC 7323).
- In de GENERIC-kernel voor de amd64-architectuur is de optie COMPAT_LINUXKPI ingeschakeld en is de mlx5en-driver (NVIDIA Mellanox ConnectX-4/5/6) geactiveerd.
- In de bootloader is de mogelijkheid toegevoegd om het besturingssysteem vanaf een ramdisk te laden, en is ondersteuning gerealiseerd voor ZFS-opties com.delphix:bookmark_written en com.datto:bookmark_v2.
- In de fetch-bibliotheek is ondersteuning voor FTP-proxys bovenop HTTPS toegevoegd.
- In de pkg-package manager zijn de commando's "bootstrap" en "add" uitgebreid met de vlag "-r" voor het opgeven van de repository. Er is gebruik gemaakt van omgevingsvariabelen uit het pkg.conf-bestand.
- In de growfs-tool is de mogelijkheid toegevoegd om te werken met bestandssystemen die in lees- en schrijfbewerking zijn gemount.
- In de etcupdate-tool is een modus voor het terugdraaien van wijzigingen geïmplementeerd voor het herstellen van één of meerdere bestanden. De vlag "-D" is toegevoegd voor het opgeven van de doelmap. Er is voorzien in gegevensherstel met gebruik van een tijdelijke map en er is ondersteuning voor SIGINT toegevoegd.
- In de tools freebsd-update en freebsd-version is de vlag "-j" toegevoegd voor ondersteuning van jail-omgevingen.
- De cpuset-tool kan nu worden gebruikt in jail-omgevingen om de parameters van sub-jails te wijzigen.
- In de cmp-tool zijn de opties toegevoegd: "-b" (—print-bytes) voor het afdrukken van verschillende bytes, "-i" (—ignore-initial) voor het negeren van een bepaald aantal initiële bytes, "-n" (—bytes) voor het beperken van het aantal te vergelijken bytes.
- In de daemon-tool is de vlag "-H" toegevoegd voor de verwerking van SIGHUP en het heropenen van het bestand waarin uitvoer plaatsvindt (toegevoegd voor ondersteuning van newsyslog).
- In de fstyp-tool is het mogelijk om bestandssystemen van het type exFAT te identificeren en weer te geven met de vlag "-l".
- In de tool mergemaster is de verwerking van symbolische koppelingen tijdens de update gerealiseerd.
- In de tool newsyslog is de vlag "E" toegevoegd om het roteren van lege logs uit te schakelen.
- In de tool tcpdump is de mogelijkheid toegevoegd om pakketten op pfsync-interfaces te decoderen.
- In de tool top is de filteropdracht "/" toegevoegd om alleen processen of argumenten weer te geven die overeenkomen met de opgegeven string.
- De ondersteuning voor wachtwoordbeschermde archieven is toegevoegd in unzip.
- De hardwareondersteuning is verbeterd. PCI-apparaat-id's zijn toegevoegd voor AHCI-controllers van ASMedia ASM116x en I2C-controllers van Intel Gemini Lake. Ondersteuning voor netwerkadapters van Mikrotik 10/25G en draadloze kaarten van Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14 is gerealiseerd. Een nieuwe driver igc is toegevoegd voor ethernet-controllers van Intel I225 2.5G/1G/100MB/10MB.
- De Netgraph-knoop ng_bridge is aangepast voor SMP-systemen. In de knoop ng_nat is ondersteuning voor CGN (Carrier Grade NAT, RFC 6598) toegevoegd. Het is mogelijk om de knoop ng_source op elke plaats in het Netgraph-netwerk in te voegen.
- In de driver rctl, die wordt gebruikt voor het beperken van bronnen, is de mogelijkheid toegevoegd om de limiet voor het verbruik van bronnen op 0 in te stellen.
- In de vlan-interface is ondersteuning voor verkeersprioritering en bandbreedtebeheer met ALTQ toegevoegd.
- In de drivers amdtemp en amdsmn is de ondersteuning voor CPU Zen 3 "Vermeer" en APU Ryzen 4000 (Zen 2, "Renoir") gerealiseerd.
- De versies van de in het basis systeem opgenomen externe applicaties zijn bijgewerkt: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. De tool unzip is gesynchroniseerd met de codebasis van NetBSD.
Bron: opennet.ru
