Na vijf maanden ontwikkeling is de release van de OpenSSL 3.3.0-bibliotheek gevormd met de implementatie van SSL/TLS-protocollen en verschillende versleutelingsalgoritmen. De ondersteuning voor OpenSSL 3.3 zal worden voortgezet tot april 2026. De ondersteuning voor eerdere versies van OpenSSL 3.2, 3.1 en 3.0 LTS loopt af in november 2025, maart 2025 en september 2026 respectievelijk. De code van het project wordt verspreid onder de Apache 2.0-licentie.
Belangrijkste vernieuwingen van OpenSSL 3.3.0:
- De integratie van ondersteuning voor het QUIC-protocol (RFC 9000) is voortgezet, dat een uitbreiding bovenop het UDP-protocol vertegenwoordigt, gebruikt als transport in het HTTP/3-protocol. In deze nieuwe release:
- Ondersteuning voor het traceren van QUIC-verbindingen is toegevoegd via het bijhouden van een diagnostisch logboek in qlog-formaat.
- Ondersteuning voor polling in niet-blokkerende modus voor QUIC-verbindingen en streamingobjecten is toegevoegd.
- De mogelijkheid voor geoptimaliseerde streaming beëindigingsframes voor QUIC-verbindingen is geïmplementeerd.
- Mogelijkheid geboden om de verwerking van QUIC-gebeurtenissen uit te schakelen bij het aanroepen van de API.
- Ondersteuning toegevoegd voor het instellen van een inactiviteitstime-out voor QUIC.
- Een API is toegevoegd voor het aanvragen van de grootte en de mate van bufferbezetting voor QUIC-stromen.
- Uitbreidingen van het Certificate Management Protocol (CMP) zijn geïmplementeerd, gedefinieerd in de specificaties RFC 9480 (definitie van het CMPv3-protocol) en RFC 9483 (lichte profiel voor low-power apparaten).
- De mogelijkheid om bij het bouwen het gebruik van de functie atexit uit te schakelen is toegevoegd.
- Een variant van de SSL_SESSION API is toegevoegd, vrij van het probleem van 2038: functies SSL_SESSION_get_time_ex() en SSL_SESSION_set_time_ex() zijn toegevoegd en gebruiken 64-bits type time_t op 32-bits systemen.
- In de functie EVP_PKEY_fromdata is de mogelijkheid toegevoegd voor automatische afleiding van de parameters van de Chinese reststelling (CRT, Chinese Remainder Theorem).
- De mogelijkheid om onbekende namen van handtekeningalgoritmen, gespecificeerd in de TLS SignatureAlgorithms- en ClientSignatureAlgorithms-configuratieparameters, te negeren is toegevoegd.
- De mogelijkheid om de prioriteit van PSK-sleutels in te stellen voor de server TLS 1.3 tijdens sessieherstel is toegevoegd.
- De functie EVP_DigestSqueeze() is toegevoegd, waarmee de grootte van de SHAKE-hash kan worden verkleind (verwijdering van de meest significante bits), door meerdere iteraties met verschillende uitvoergroottes te gebruiken.
- Ondersteuning voor het exporteren van build-bestanden voor CMake op Unix-achtige systemen en Windows toegevoegd (naast export op basis van pkg-config).
- Prestatieoptimalisaties aangebracht: De werking van het AES-GCM-algoritme is geoptimaliseerd op apparaten met Microsoft Azure Cobalt 100-chips. In de implementatie van AES-CTR is ondersteuning toegevoegd voor versnelling met behulp van ARM Neoverse V1 en V2-uitbreidingen. AES en SHA3 zijn geoptimaliseerd voor systemen van Apple met M3-chips. Vectoruitbreidingen van RISC-V zijn in verschillende cryptografische functies gebruikt. Een assemblerimplementatie van md5 is toegevoegd voor CPU Loongarch64.
Bron: opennet.ru
