Categorie: Blog

De release van OpenRGB 0.6, een toolkit voor het beheren van RGB-verlichtingsapparaten

Er is een nieuwe release van OpenRGB 0.6 uitgebracht, een gratis toolkit voor het beheren van apparaten met RGB-verlichting. Het pakket ondersteunt moederborden van ASUS, Gigabyte, ASRock en MSI met RGB-subsystemen voor behuizingverlichting, geheugenmodules met verlichting van ASUS, Patriot, Corsair en HyperX, grafische kaarten van ASUS Aura/ROG, MSI GeForce, Sapphire Nitro en Gigabyte Aorus, verschillende LED-controller (ThermalTake, Corsair, NZXT Hue+), […]

Voor de taal D is er een runtime gepresenteerd voor het programmeren van microcontrollers

Dylan Graham heeft een lichtgewicht runtime LWDR gepresenteerd voor het programmeren in de taal D van microcontrollers die uitgerust zijn met real-time besturingssystemen (RTOS). De huidige versie is gericht op ARM Cortex-M microcontrollers. De ontwikkeling is niet bedoeld om alle mogelijkheden van D volledig te dekken, maar biedt wel basisfunctionaliteiten. Geheugenbeheer gebeurt handmatig (new / delete), een garbage collector is niet geïmplementeerd, maar er zijn verschillende hooks voor […]

Release van de applicatieserver NGINX Unit 1.24.0

De release van de applicatieserver NGINX Unit 1.24 heeft plaatsgevonden, waarin een oplossing wordt ontwikkeld voor het uitvoeren van webapplicaties in verschillende programmeertalen (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js en Java). Onder NGINX Unit kunnen meerdere applicaties in verschillende programmeertalen tegelijkertijd draaien, met opstartparameters die dynamisch kunnen worden gewijzigd zonder aanpassing van configuratiebestanden en zonder herstart. De code […]

Release van Electron 13.0.0, een platform voor het maken van applicaties op basis van de Chromium-engine

De release van het Electron-platform 13.0.0 is voorbereid, dat een zelfstandige framework biedt voor het ontwikkelen van cross-platform desktopapplicaties, gebruikmakend van de componenten van Chromium, V8 en Node.js. De aanzienlijke wijziging van het versienummer is te wijten aan de update naar de Chromium 91 codebase, Node.js 14.16 platform en de V8 9.1 JavaScript-engine. Tot de wijzigingen in deze nieuwe release behoren: Het toevoegen van de eigenschap process.contextIsolated om de uitvoering van de huidige […]

Release van de PCRE2-bibliotheek 10.37

De release van de PCRE2-bibliotheek 10.37 is uitgekomen, die een set functies in de programmeertaal C biedt met implementaties van reguliere expressies en patroonmatching, die syntactisch en semantisch vergelijkbaar zijn met de reguliere expressies van Perl 5. PCRE2 is een herontworpen implementatie van de originele PCRE-bibliotheek met een incompatibele API en uitgebreide mogelijkheden. De bibliotheek is ontwikkeld door de makers van de Exim-mailserver en wordt verspreid […]

Microsoft heeft de Windows Package Manager 1.0 uitgebracht, vergelijkbaar met apt en dnf

Microsoft heeft de release van de Windows Package Manager 1.0 (winget) gepubliceerd, die hulpmiddelen biedt voor het installeren van applicaties via de opdrachtregel. De code is geschreven in C++ en wordt verspreid onder de MIT-licentie. Pakketten worden geïnstalleerd uit een repository, dat wordt ondersteund met medewerking van de gemeenschap. In tegenstelling tot het installeren van programma's vanuit de Microsoft Store, stelt winget gebruikers in staat om applicaties te installeren zonder extra marketing en […]

Release van de package manager Pacman 6.0 en de Archinstall 2.2.0 installer

Nieuwe versies van de pakketbeheerder Pacman 6.0.0 en de installer Archinstall 2.2.0 zijn beschikbaar, die worden gebruikt in de Arch Linux-distributie. De belangrijkste wijzigingen in Pacman 6.0: Ondersteuning voor het downloaden van bestanden in meerdere parallelle stroom. Implementatie van een voortgangsbalk bij het downloaden van gegevens. Om de voortgangsbalk uit te schakelen, kan de optie "—noprogressbar" in pacman.conf worden opgegeven. Automatisch overslaan van mirrors bij toegang tot […]

De code van de wachtwoordcontrole service HaveIBeenPwned is geopend

Troy Hunt heeft de broncode van de wachtwoordcontrole service "Have I Been Pwned?" (haveibeenpwned.com) vrijgegeven, die controleert in een database van 11,2 miljard gecompromitteerde accounts, verkregen door het hacken van 538 websites. Oorspronkelijk werd in augustus vorig jaar aangekondigd dat de code van het project zou worden vrijgegeven, maar het proces is uitgesteld en de code is pas nu gepubliceerd. De code van de service is geschreven in […]

Mozilla heeft plannen samengevat voor de ondersteuning van de derde versie van de Chrome-manifest in Firefox

Mozilla heeft een implementatieplan gepubliceerd voor de derde versie van de Chrome-manifest in Firefox, die de mogelijkheden en middelen voor uitbreidingen definieert. De derde versie van de manifest is bekritiseerd vanwege het verstoren van de werking van veel bekroonde inhoudsblokkeringen en beveiligingsuitbreidingen. In Firefox is men van plan bijna alle functies en beperkingen van de nieuwe manifest te implementeren, inclusief een declaratieve API voor inhoudsfiltering (declarativeNetRequest), […]

Het QUIC-protocol heeft de status van voorgesteld standaard gekregen

De IETF-commissie (Internet Engineering Task Force), die zich bezighoudt met de ontwikkeling van protocollen en architectuur van het internet, heeft de RFC voor het QUIC-protocol afgerond en de bijbehorende specificaties gepubliceerd onder de identificaties RFC 8999 (versie-onafhankelijke eigenschappen van het protocol), RFC 9000 (transport boven UDP), RFC 9001 (TLS-encryptie van de QUIC-communicatielijn) en RFC 9002 (overbelastingsbeheer en pakketverliesdetectie tijdens datatransmissie). […]

Virtuozzo heeft de distributie VzLinux gepubliceerd, gericht op het vervangen van CentOS 8

Het bedrijf Virtuozzo (vroeger een divisie van Parallels), dat serversoftware voor virtualisatie ontwikkelt op basis van open source-projecten, is begonnen met de openbare verspreiding van de VzLinux-distributie, die voorheen als basisbesturingssysteem werd gebruikt voor het platform voor virtualisatie dat door het bedrijf is ontwikkeld, evenals voor verschillende commerciële producten. Voortaan is VzLinux beschikbaar voor iedereen en wordt gepositioneerd als vervanging voor CentOS 8, klaar voor praktische implementaties. Voor download […]

Uitgave van de Simply Linux 9.1-distributie

Het bedrijf Bazalt SPO heeft de uitgave van de Simply Linux 9.1-distributie aangekondigd, die is gebouwd op het negende ALT-platform. Het product wordt verspreid onder een licentieovereenkomst die het recht om de distributie te verspreiden niet overdraagt, maar het gebruik van het systeem zonder beperkingen door zowel natuurlijke als rechtspersonen toestaat. De distributie wordt geleverd in builds voor de architecturen x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (bèta) en kan […]

Koop betrouwbare webhosting met bescherming tegen DDoS, VPS VDS servers 🔥 Koop betrouwbare webhosting met bescherming tegen DDoS, VPS VDS servers | ProHoster