{"id":111732,"date":"2023-11-24T15:10:17","date_gmt":"2023-11-24T13:10:17","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic"},"modified":"2023-11-24T15:10:17","modified_gmt":"2023-11-24T13:10:17","slug":"vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","status":"publish","type":"post","link":"https:\/\/prohoster.info\/nl\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","title":{"rendered":"Uitgave van OpenSSL 3.2.0 met clientondersteuning voor het QUIC-protocol","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>Na acht maanden ontwikkeling is de release van de OpenSSL 3.2.0-bibliotheek met implementatie van SSL\/TLS-protocollen en verschillende versleutelingsalgoritmen vormgegeven. De ondersteuning voor OpenSSL 3.2 zal plaatsvinden tot 23 november 2025. De steun voor de vorige versies OpenSSL 3.1 en 3.0 LTS zal doorgaan tot maart 2025 en september 2026 respectievelijk. De ondersteuning voor versie 1.1.1 is gestopt in september van dit jaar. De broncode van het project wordt verspreid onder de Apache 2.0-licentie.    <\/p>\n<p>Belangrijkste vernieuwingen in OpenSSL 3.2.0:   <\/p>\n<ul>\n<li class=\"l\"> Er is klantondersteuning toegevoegd voor het QUIC-protocol (RFC 9000), dat wordt gebruikt als transport in het HTTP\/3-protocol. De implementatie omvat onder andere de mogelijkheid om meerdere streams via \u00e9\u00e9n verbinding te verzenden. Componenten voor het gebruik van QUIC in <a class=\"wpil_keyword_link\" href=\"https:\/\/prohoster.info\/nl\/server\/dts-gdansk\/\"   title=\"servers\" data-wpil-keyword-link=\"linked\"  data-wpil-monitor-id=\"4541\">servers<\/a> zullen worden opgenomen in de release van OpenSSL 3.3, die uiterlijk op 30 april 2024 zal worden uitgebracht.\n<p>QUIC is een uitbreiding bovenop het UDP-protocol, dat multiplexing van verschillende verbindingen ondersteunt en versleutelingsmethoden biedt die overeenkomen met TLS\/SSL. Het protocol werd in 2013 ontwikkeld door Google als alternatief voor de combinatie TCP+TLS voor het web, waarmee problemen met lange opstarttijden en onderhandelingen over verbindingen in TCP worden opgelost en vertragingen door pakketverlies tijdens gegevensoverdracht worden ge\u00eblimineerd.       <\/p>\n<li class=\"l\"> In TLS is ondersteuning voor een extensie voor het comprimeren van certificaten tijdens de onderhandelingsfase van verbindingen gerealiseerd (RFC 8879), die het opzetten van een verbinding versnelt omdat een groot deel van het verkeer in de onderhandelingsfase gaat naar het verzenden van certificaatgegevens. Compressie met behulp van de zlib-, zstd- en Brotli-bibliotheken wordt ondersteund.\n<li class=\"l\"> Ondersteuning is toegevoegd voor de deterministische variant van digitale handtekeningen ECDSA (Deterministic ECDSA, RFC 6979), waarbij in plaats van een willekeurige sequentie bij het genereren van de handtekening een HMAC-SHA256-hash van de priv\u00e9sleutel en de tekst van het te ondertekenen bericht wordt gebruikt. Dit zorgt ervoor dat altijd dezelfde handtekening wordt verkregen bij verschillende ondertekeningsoperaties, maar voorkomt dat gegevens uitlekken die gebruikt kunnen worden om de priv\u00e9sleutel te achterhalen (de priv\u00e9sleutel kan worden achterhaald als er ten minste twee handtekeningen voor verschillende gegevens zijn gemaakt met behulp van een herhalende willekeurige sequentie).\n<li class=\"l\"> Ondersteuning is toegevoegd voor geavanceerde varianten van digitale handtekeningen met openbare sleutels Ed25519 en Ed448: Ed25519ctx, Ed25519ph en Ed448ph (RFC 8032).\n<li class=\"l\"> Ondersteuning voor de versleuteling modus AES-GCM-SIV (RFC 8452) is toegevoegd, die de hoge prestaties van de GCM-modus (Galois\/Counter Mode) combineert met weerstand tegen lekkage bij hergebruik van de willekeurige nonce-code.\n<li class=\"l\"> De functie voor het genereren van de Argon2-sleutel (RFC 9106) is ge\u00efmplementeerd, die in 2015 de wedstrijd voor wachtwoord-hashfuncties heeft gewonnen. De mogelijkheid om threadpools te gebruiken is toegevoegd.\n<li class=\"l\"> Ondersteuning voor hybride versleuteling op basis van het HPKE-mechanisme (Hybrid Public Key Encryption, RFC 9180) is toegevoegd, dat de eenvoud van sleuteloverdracht bij openbare sleutelversleuteling combineert met de hoge prestaties van symmetrische versleuteling (gegevens worden versleuteld met een snelle symmetrische sleutel, terwijl de sleutel zelf wordt versleuteld met een trage asymmetrische methode).\n<li class=\"l\"> In TLS is implemented the ability to use \"raw\" (raw) public keys (RFC 7250).\n<li class=\"l\"> Support for the TCP Fast Open (TFO \u2014 TCP Fast Open, RFC 7413) mechanism has been added, which reduces the number of steps required to establish a connection by combining the first and second steps of the classic 3-step connection handshake into a single request, and allows for data transmission at the initial connection establishment phase.\n<li class=\"l\"> In TLS is ondersteuning voor uitbreidbare digitale handtekeningschema's ge\u00efmplementeerd, waarmee externe implementaties van algoritmen kunnen worden gebruikt, bijvoorbeeld voor het gebruik van algoritmen die bestand zijn tegen brute force-aanvallen bij kwantumcomputers binnen TLS.\n<li class=\"l\"> In TLS 1.3 is ondersteuning voor beveiligde elliptische curves van Brainpool toegevoegd.\n<li class=\"l\"> Ondersteuning voor de SM4-XTS processorinstructies is toegevoegd.\n<li class=\"l\"> On the Windows platform, the ability to use the system store for root certificates has been implemented (disabled by default). To access certificates in the Windows store, the URI \"org.openssl.winstore:\/\/\" is provided.     <\/ul>\n<p>Bron: <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=60174\">opennet.ru<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 \u043f\u0440\u043e\u0448\u043b\u044b\u0445 \u0432\u0435\u0442\u043e\u043a OpenSSL 3.1 \u0438 3.0 LTS \u043f\u0440\u043e\u0434\u043b\u0438\u0442\u0441\u044f \u0434\u043e \u043c\u0430\u0440\u0442\u0430 2025 \u0433\u043e\u0434\u0430 \u0438 \u0441\u0435\u043d\u0442\u044f\u0431\u0440\u044f 2026 \u0433\u043e\u0434\u0430 \u0441\u043e\u043e\u0442\u0432\u0435\u0442\u0441\u0442\u0432\u0435\u043d\u043d\u043e. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 \u0432\u0435\u0442\u043a\u0438 1.1.1 \u043f\u0440\u0435\u043a\u0440\u0430\u0449\u0435\u043d\u0430 \u0432 \u0441\u0435\u043d\u0442\u044f\u0431\u0440\u0435 \u044d\u0442\u043e\u0433\u043e \u0433\u043e\u0434\u0430. \u041a\u043e\u0434 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-111732","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.3 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/nl\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic\" \/>\n\t\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.3\" \/>\n\t\t<meta property=\"og:locale\" content=\"nl_NL\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u0412\u044b\u043f\u0443\u0441\u043a OpenSSL 3.2.0 \u0441 \u043a\u043b\u0438\u0435\u043d\u0442\u0441\u043a\u043e\u0439 \u043f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u043e\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/nl\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-11-24T13:10:17+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-11-24T13:10:17+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47Release van OpenSSL 3.2.0 met clientondersteuning voor het QUIC-protocol | ProHoster","description":"Na acht maanden ontwikkeling is de release van de OpenSSL 3.2.0-bibliotheek met implementatie van SSL\/TLS-protocollen en verschillende versleutelingsalgoritmen gevormd. De ondersteuning voor OpenSSL 3.2 zal plaatsvinden tot 23 november 2025.","canonical_url":"https:\/\/prohoster.info\/nl\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"nl_NL","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u0412\u044b\u043f\u0443\u0441\u043a OpenSSL 3.2.0 \u0441 \u043a\u043b\u0438\u0435\u043d\u0442\u0441\u043a\u043e\u0439 \u043f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u043e\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC | ProHoster","og:description":"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.","og:url":"https:\/\/prohoster.info\/nl\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-11-24T13:10:17+00:00","article:modified_time":"2023-11-24T13:10:17+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/nl\/wp-json\/wp\/v2\/posts\/111732","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/nl\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/nl\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/nl\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/nl\/wp-json\/wp\/v2\/comments?post=111732"}],"version-history":[{"count":1,"href":"https:\/\/prohoster.info\/nl\/wp-json\/wp\/v2\/posts\/111732\/revisions"}],"predecessor-version":[{"id":164419,"href":"https:\/\/prohoster.info\/nl\/wp-json\/wp\/v2\/posts\/111732\/revisions\/164419"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/nl\/wp-json\/wp\/v2\/media?parent=111732"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/nl\/wp-json\/wp\/v2\/categories?post=111732"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/nl\/wp-json\/wp\/v2\/tags?post=111732"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}