Utgivelse av OpenBSD 7.2

Utgitt versjon av det frie UNIX-liknende operativsystemet OpenBSD 7.2. OpenBSD-prosjektet ble grunnlagt av Theo de Raadt i 1995 etter en konflikt med utviklerne av NetBSD, som førte til at Theo mistet tilgang til CVS-repositoriet til NetBSD. Deretter opprettet Theo de Raadt, sammen med en gruppe likesinnede, et nytt åpent operativsystem basert på kilden til NetBSD, med de viktigste utviklingsmålene å være portabilitet (støtte for 13 maskinvareplattformer), standardisering, korrekt drift, proaktiv sikkerhet og integrerte kryptografiske verktøy. Størrelsen på den fullstendige installasjons-ISO-bildet av OpenBSD 7.2-basisystemet er 556 MB.

I tillegg til selve operativsystemet er OpenBSD-prosjektet kjent for sine komponenter, som har blitt distribuerte i andre systemer og har vist seg å være noen av de sikreste og mest kvalitetsløsningene. Blant dem er: LibreSSL (en fork av OpenSSL), OpenSSH, pakkefilteret PF, ruterdemonene OpenBGPD og OpenOSPFD, NTP-serveren OpenNTPD, postserveren OpenSMTPD, tekstterminalmultiplexeren (tilsvarende GNU-screen) tmux, demon identd med IMPLEMENTASJON av IDENT-protokollen, BSDL-alternativet til GNU groff-pakken - mandoc, protokollen for oppsett av feilfrie systemer CARP (Common Address Redundancy Protocol), en lettvekts HTTP-server, og filsynkroniseringsverktøyet OpenRSYNC.

Hovedforbedringer:

  • Forbedret støtte for systemer basert på ARM-arkitekturen, inkludert støtte for Apple M2 ARM-brikker og Ampere Altra. Støtte for Lenovo ThinkPad x13s-laptop og andre enheter basert på SoC Qualcomm Snapdragon 8cx Gen 3 (SC8280XP) er lagt til.
  • Mulighet for å starte opp i Oracle Cloud-miljøer med kerner for ram-disk (bsd.rd) og kerner for flerprosessorsystemer (bsd.mp) er lagt til.
  • Inkludert kstat-enhet som eksporterer statistikk om kjernens ytelse, som kan vises med verktøyet kstat.
  • For hver prosessorkjerne med støtte for MPERF/APERF er det implementert sensorer for CPU-frekvens. Ved drift på batteri er frekvensjustering for CPU aktive avhengig av belastningen.
  • Startstøtte for dvalemodus er lagt til på ARM64-systemer. Grensen for antall støttede CPU-er er økt til 256. Implementert muligheten for å bytte fra framebuffer-basert konsoll (glass console) til konsoll basert på seriemenning (serial console).
  • Koden for å identifisere CPU 386sx/386dx, NexGen, Rise og eldre Cyrix-prosessorer, utgitt før Cyrix M2-brikken, er fjernet.
  • Støtten for flerprosessorsystemer (SMP) er forbedret. Funksjonene for båndbreddebegrensning (rate limit), ARP-oppdagelse og route timer er overført til mp-safe. Det er implementert muligheten for parallell behandling av operasjoner som ombygging av IPv4-pakker og videresending av IP-pakker. Det er lagt til låser for sokkler i behandlingen av innkommende UDP- og IP-pakker, som bruker mutex. Systemanropene kbind og pledge er frigjort fra låser. Implementert erotokker for UNIX-sokkler som opererer på nivået av individuelle sokkler.
  • Implementasjonen av DRM-rammeverket (Direct Rendering Manager) er synkronisert med Linux-kjernen 5.15.69 (forrige utgave var 5.15.26). Intel-drivermodulen har fått støtte for Intel-brikker basert på Alder Lake- og Raptor Lake-mikroarkitekturer. Støtte for rammebufferne som ikke er justert til minnesidegrensen er blitt implementert (brukt for eksempel i MacBook Pro 2021 14" og 16").
  • Det er gjort forbedringer i hypervisoren VMM. VMD har fått støtte for håndterere i brukerrommet basert på MMIO. I VMM er emuleringen av inn- og utgangsportene flyttet til brukerrommet. De interne strukturene og grensesnittene i VMD, VMCTL og VMM er blitt enhetlig. Muligheten for overvåking virtual machines ved hjelp av SNMP AgentX, med VM-MIB-parametere (RFC7666).
  • Variabelen $rcexec i initialiseringsskriptene rc.d er blitt ombyttet til funksjonen rc_exec. Den nye variabelen daemon_execdir er lagt til, noe som gjør det mulig å endre katalog før funksjonen rc_exec utføres. Det er lagt til en ny handling configtest i rc.d og rcctl for å sjekke syntaksen i konfigurasjonen.
  • Sammensetningen inkluderer verktøyet ts, som legger til tid til linjene som mottas via standard inngang, som gjenspeiler tidspunktet for hver linje.
  • Verktøyet ps har fått alternativet "-f" for trestrukturert gruppering av prosesser, som gjenspeiler forholdet mellom foreldremessige og barneprosesser.
  • I verktøyet openrsync er alternativet "—contimeout" implementert for å definere tidsavbrudd ved tilkobling.
  • I verktøyet pkg_add er caching aktivert som standard, arbeidet med pakker er optimalisert, og det er sikret at det vises en fremdriftsindikator under databasert overføring.
  • I fdisk er arbeidet med GPT- og MBR-tabeller forbedret, og det er lagt til advarsler ved feilplassering av MBR- og GPT-partisjoner.
  • Verktøyet disklabel har fått støtte for nøkkelordet raid i malene for automatisk plassering av partisjoner med RAID. Redigering av diskgeometri-informasjonen er blitt stoppet. Støtte for attributter 'bs' (størrelse på oppstartblock), 'sb' (størrelse på superblokken) og d[0-4] (diskdata) er blitt fjernet.
  • I katalogen /usr/share/btrace er det plassert et utvalg nyttige btrace-skript for dynamisk sporing og inspeksjon av applikasjoner.
  • I lydbiblioteket sndio er det lagt til en funksjon sio_flush for umiddelbar stans av avspillingen.
  • Verktøyet llvm-profdata for profileringsdata er inkludert.
  • I verktøyet wc er ordtelling blitt akselerert.
  • Støtte for nytt utstyr er lagt til, inkludert nye drivere:
    • aplaudio (lydsubsystem for Apple).
    • aplmca (MCA-kontroller for Apple).
    • aplsart (Apple SART).
    • alpdc, apldchidev, apldckbd, apldcms, aplrtk (tastatur og pekeflate for Apple M2).
    • qcgpio, qciic (GPIO og GENI I2C-kontrollere for Qualcomm Snapdragon).
    • sfgpio, stfclock, stfpinctrl, stftemp (drivere for GPIO, timer og sensorer på SiFive-kort).
    • sxirintc (interrrupt-kontroller for Allwinner-brikker).
    • gpiorestart (driver for tilbakestilling via GPIO).
    • I ipmi er støtten for strømsensorer utvidet.
    • I ehci er støtte for kontrolleren som brukes i Marvell 3720-kort lagt til.
  • I igc-driveren for gigabit Ethernet-adaptere Intel I225 er maskinvareakselerasjon for beregning av kontrollsummer for IPv4, TCP og UDP lagt til. I ix-driveren for Ethernet-adaptere Intel 82598/82599/X540/X550 er maskinvareakselerasjon for TCP-segmentbehandling (Large Receive Offloading) implementert, aktivert med opsjonen tso i ifconfig.
  • I iwx-driveren er støtte for Intel AX210/AX211-brikker implementert, og spekteret av definerte trådløse enheter er utvidet.
  • Muligheten for oppstart fra programmerte RAID 1 (softraid) partisjoner på systemer amd64, sparc64 og arm64 er lagt til.
  • I snmpd og xlock er privilegiedeling implementert.
  • I funksjonene bind og connect for UNIX-sokler er isolering basert på systemanropet unveil sikret.
  • En ny systemanrop ypconnect er lagt til for å opprette en sokkel for tilkobling til serveren YP, ved å bruke IP-adressen fra den blokkerte filen ypbinding. I ypldap er en 'local bind'-modus lagt til, der RPC-sokkelbindingen skjer til loopback-grensesnittet for å unngå eksterne tilkoblinger til serveren.
  • Programmene hcpleased, mountd, nfsd, pflogd, resolvd, slaacd og unwind i katalogen /sbin er overført til dynamisk sammenkobling for å aktivere ekstra sikkerhetsverktøy som gjelder for dynamisk sammenbundne kjørbare filer.
  • I nettverksstakken er systemanropene sendmmsg og recvmmsg implementert, som tillater sending og lesing av flere meldinger i ett systemanrop, som tidligere ville krevd separate anrop av sendmsg og recvmsg.
  • I paketfilteret pf er behandlingen av IGMP og ICMP6 MLD (Multicast Listener Discovery) endret, noe som har gjort det mulig å håndtere styrings multicast-pakker i standardkonfigurasjonen. En strengere sjekk av IGMP/MLD-meldinger er implementert.
  • IPsec har fått forbedret håndtering av sertifikater. Iked har fått bedre kompatibilitet med OpenIKED. I kommandoen ikectl show stats er det lagt til visning av statistikk for vellykkede og mislykkede tilkoblinger til iked.
  • I bgpd er det lagt til en max-communities-filter for å begrense antallet tillatte community, implementert RFC 9234 (Route Leak Prevention and Detection Using Roles in UPDATE and OPEN Messages), full støtte for RFC 7911 (Advertisement of Multiple Paths in BGP) er sikret, statiske hasher er blitt erstattet med RB-trær for å øke ytelsen i store systemer. Det er lagt til en bgplgd-prosess med implementering av FastCGI-server, som gir REST API for bgpctl-kommandoene.
  • I rpki-client er det tillatt å bruke mer enn ett CRL URI i sertifikater, parameteret skiplist for å ignorere domener er implementert, muligheten for å kontrollere ASPA (Autonomous System Provider Authorization) og sig-filer er lagt til, dekodering av TAL (RFC 8630) er implementert, kontrollen av EE-sertifikater er strammet inn, og kompatibiliteten med HTTP-spesifikasjoner er forbedret.
  • I snmpd er bruken av objekt-navn i snmpd.conf tillatt, i tillegg til OID. Muligheten for å opprette en svarteliste for å ekskludere undermapper fra utdata er implementert. Støtte for master-agent er lagt til i implementeringen av AgentX-protokollen.
  • I httpd er det blitt foreslått nye definisjoner av MIME-typer.
  • Ftp-verktøyet er overført til å bruke tilkoblinger behandlet i ikke-blokkerende modus ved hjelp av ppoll.
  • I tmux ('terminal multiplexer') er det lagt til støtte for å bruke ACL for å organisere flere brukeres tilkobling gjennom én sokkel.
  • Pakkene LibreSSL og OpenSSH er oppdatert. En detaljert oversikt over forbedringene kan sees i oversiktene over LibreSSL 3.6.0 og OpenSSH 9.1.
  • Antallet porter for AMD64-arkitekturen er 11451 (det var 11301), for aarch64 - 11261 (det var 11081), for i386 - 10225 (det var 10136). Blant versjonene av applikasjoner i porter:
    • Asterisk 16.28.0, 18.14.0 og 19.6.0
    • Audacity 2.4.2
    • CMake 3.24.2
    • Chromium 105.0.5195.125
    • Emacs 28.2
    • FFmpeg 4.4.2
    • GCC 8.4.0 og 11.2.0
    • GHC 9.2.4
    • GNOME 42.4
    • Go 1.19.1
    • JDK 8u342, 11.0.16 og 17.0.4
    • KDE Gear 22.08.1
    • KDE Frameworks 5.98.0
    • Krita 5.1.1
    • LLVM/Clang 13.0.0
    • LibreOffice 7.4.1.2
    • Lua 5.1.5, 5.2.4 og 5.3.6
    • MariaDB 10.9.3
    • Mono 6.12.0.182
    • Mozilla Firefox 105.0.1 og ESR 102.3.0
    • Mozilla Thunderbird 102.3.0
    • Mutt 2.2.7 og NeoMutt 20220429
    • Node.js 16.17.1
    • OCaml 4.12.1
    • OpenLDAP 2.6.3
    • PHP 7.4.30, 8.0.23 og 8.1.10
    • Postfix 3.7.2
    • PostgreSQL 14.5
    • Python 2.7.18, 3.9.14 og 3.10.7
    • Qt 5.15.6 og 6.3.1
    • R 4.2.1
    • Ruby 2.7.6, 3.0.4 og 3.1.2
    • Rust 1.63.0
    • SQLite 3.39.3
    • Shotcut 22.06.23
    • Sudo 1.9.11.2
    • Suricata 6.0.6
    • Tcl/Tk 8.5.19 og 8.6.12
    • TeX Live 2021
    • Vim 9.0.0192 og Neovim 0.7.2
    • Xfce 4.16
  • Komponentene fra tredjeparter som inngår i OpenBSD 7.2 er oppdatert:
    • Xenocara grafikkstabel basert på X.Org 7.7 med xserver 1.21.4 + patcher, freetype 2.12.1, fontconfig 2.13.94, Mesa 22.1.7, xterm 372, xkeyboard-config 2.20, fonttosfnt 1.2.2.
    • LLVM/Clang 13.0.0 (+ patch)
    • GCC 4.2.1 (+ patch) og 3.3.6 (+ patch)
    • Perl 5.32.1 (+ patcher)
    • NSD 4.6.0
    • Unbound 1.16.3
    • Ncurses 5.7
    • Binutils 2.17 (+ patch)
    • Gdb 6.3 (+ patch)
    • Awk 12.9.2022
    • Expat 2.4.9

Kilde: opennet.ru

Kjøp pålitelig hosting for nettsteder med DDoS-beskyttelse, VPS VDS-servere 🔥 Kjøp pålitelig hosting for nettsteder med DDoS-beskyttelse, VPS VDS-servere | ProHoster