Postfix 3.10.0 har blitt publisert

Etter nesten ett Ă„rs utvikling er den nye stabile versjonen av e-postserveren Postfix – 3.10.0 – nĂ„ tilgjengelig. Samtidig er det kunngjort at stĂžtte for versjon 3.6 av Postfix, som ble utgitt tidlig i 2021, vil bli avsluttet. Prosjektkoden er skrevet i C og distribueres under lisensene EPL 2.0 (Eclipse Public License) og IPL 1.0 (IBM Public License).

Postfix er et av de fÄ prosjektene som kombinerer hÞy sikkerhet, pÄlitelighet og ytelse, noe som er oppnÄdd gjennom en flerprosessarkitektur som isolerer enkeltbehandlere, samt en streng kodeformateringspolitikk og revisjon av patcher. For Ä beskytte mot feil ved minnehÄndtering bruker prosjektet sikre alternativer for funksjoner som allokerer og frigjÞr minne, samt et sett med abstrakte omslagsfunksjoner for bufferhÄndtering (som sjekker grenseoverskridelser og tilgang til frigitt minne), filoperasjoner, formatering av utdata, bufret inndata og manipulasjoner med strenger (inkludert muligheter for hÄndtering av strenger av vilkÄrlig stÞrrelse og automatisk strammes tilpassning av strenger).

I henhold til den automatiserte undersĂžkelsen i februar bruker omtrent 550 000 e-post serverePostfix pĂ„ 37.64% (for ett Ă„r siden 36.81%) av e-postserverne, andelen Exim er pĂ„ 56.03% (for ett Ă„r siden 56.61%), Sendmail – 3.39% (3.60%), MailEnable – 1.80% (1.82%), MDaemon – 0.39% (0.40%), Microsoft Exchange – 0.19% (0.19%), OpenSMTPD – 0.10% (0.09%).

Postfix 3.10.0 har blitt publisert

Hovudnyhende:

  • Muligheten for Ă„ bruke TLS-kryptoalgoritmer som er motstandsdyktige mot kvanteangrep, er lagt til. For Ă„ bruke disse algoritmene kreves OpenSSL 3.5-biblioteket, som fortsatt er under utvikling. For valg av post-kvantealgoritmer i Postfix har de unngĂ„tt Ă„ innfĂžre en ny syntaks for TLS-grupper, og baserer seg heller pĂ„ innstillingene til OpenSSL, som vil bli brukt ved konfigurasjon av parametrene «tls_eecdh_auto_curves» og «tls_ffdhe_auto_groups» med tomme verdier.
  • StĂžtte for meldingsoverskriften «TLS-Required: no» (RFC 8689) er lagt til, noe som gjĂžr at leveransen vil bli utfĂžrt selv nĂ„r det ikke er mulig Ă„ implementere den sikkerhetspolicyen for TLS som er satt. Med denne overskriften fungerer SMTP-klienten i modusen «smtp_tls_security_level = may», dvs. den kontrollerer ikke sertifikatet. serveren og kan falle tilbake til en tilkobling med overfĂžring av data i klartekst. I den neste betydelige grenen av Postfix, planlegger vi Ă„ implementere SMTP-utvidelsen REQUIRETLS.
  • StĂžtte for TLS-RPT (Transport Layer Security Reporting) er lagt til, noe som muliggjĂžr sporing av feil ved levering av meldinger som oppstĂ„r nĂ„r det ikke er mulig Ă„ etablere en kryptert tilkobling i henhold til bruken av DANE (DNS-basert autentisering av navngitte enheter) eller MTA-STS (MTA Strict Transport Security)-utvidelser. Eieren av e-postdomenet definerer i DNS parametere for TLS-RPT, hvoretter e-postservere vil sende rapporter med informasjon om vellykkede og mislykkede TLS-tilkoblinger til MX-serverne som betjener domenet. Implementeringen er basert pĂ„ libtlsrpt-biblioteket.
  • Innstillingen «smtpd_hide_client_session = yes» er lagt til for Ă„ deaktivere innsetting av informasjon om klientĂžkten nĂ„r SMTP-serveren setter inn «Received:»-overskriften. Eksempel pĂ„ en forkortet overskrift: «Received: by mail.example.com (Postfix) id postfix-queue-id for ; Day, dd Mon yyyy hh:mm:ss tz-offset (zone)».
  • Muligheten for MIME-koding (RFC 2047) av navn i genererte Postfix-overskrifter «From:», som inkluderer ikke-ASCII-tegn, er lagt til. Den foreslĂ„tte kodingsskjemaet tillater Ă„ unngĂ„ bruken av SMTPUTF8-utvidelsen (RFC 6531), som ikke stĂžttes av alle applikasjoner. Resultatet av MIME-koding ser slik ut: '"=?charset?Q?gibberish?=:'. For Ă„ bestemme den opprinnelige kodingen av navn, er parameteren «full_name_encoding_charset» lagt til, med standardverdi satt til utf8.
  • Logikken for behandling av mislykkede tilkoblinger nĂ„r det i innstillingene angis «mysql:» eller «pgsql:» med kun Ă©n server, er endret. En slik server oppfattes nĂ„ som en lastbalanserer, og ved enkeltfeil sendes den gjentatte forespĂžrselen umiddelbart, uten en forsinkelse pĂ„ 60 sekunder.
  • I Milter er det implementert logging av informasjon med Ă„rsaken til at meldingen settes i karantene.
  • I SMTP-serveren er det sikret logging av kĂžens identifikator eller verdien «NOQUEUE» ved avslutning av tilkoblingen pĂ„ grunn av timeout, avbrudd eller overskridelse av feiltoleranse. RengjĂžringsprosessen logger da «queueid: canceled» for meldinger med en transaksjon som er startet, men ikke fullfĂžrt.
  • I Dovecot SASL-klienten viser loggen meldinger om «Invalid authentication mechanism» nĂ„ den autentiseringsmekanismen som ikke kunne brukes.
  • PĂ„ grunn av endringen i den interne protokollen som brukes i leveringsagenten, kreves det en omstart med kommandoen «postfix reload» eller kommandoene «postfix stop» og «postfix start» etter oppdatering av Postfix-versjonen. Ellers vil det vises en advarsel i loggen «unexpected attribute smtputf8 from xxx socket (expecting: sendopts)».

Kilde: opennet.ru

KjĂžp pĂ„litelig hosting for nettsteder med DDoS-beskyttelse, VPS VDS-servere đŸ”„ KjĂžp pĂ„litelig hosting for nettsteder med DDoS-beskyttelse, VPS VDS-servere | ProHoster