Utgivelse av DNS-server BIND 9.16.0

Etter 11 mÄneder med utvikling har konsortiet ISC har presentert lansert den fÞrste stabile utgaven av den nye betydelige grenen av DNS-serveren BIND 9.16. StÞtten for versjon 9.16 vil bli opprettholdt i tre Är frem til 2. kvartal 2023 som del av et utvidet vedlikeholdssyklus. Oppdateringer for den tidligere LTS-versjonen 9.11 vil fortsette Ä bli utgitt til desember 2021. StÞtten for versjon 9.14 vil opphÞre om tre mÄneder.

Viktige nyheter:

  • KASP (Key and Signing Policy) er lagt til, en forenklet mĂ„te Ă„ administrere nĂžkler og digitale signaturer for DNSSEC, basert pĂ„ regler definert ved hjelp av direktivet «dnssec-policy». Dette direktivet gjĂžr det mulig Ă„ konfigurere genereringen av nĂždvendige nye nĂžkler for DNS-soner og automatisk bruke nĂžklene ZSK og KSK.
  • Nettverksunderdelen er betydelig omarbeidet og overfĂžrt til en mekanisme for asynkron behandling av forespĂžrslene, implementert basert pĂ„ biblioteket libuv.
    Omarbeidingen har ennÄ ikke fÞrt til synlige endringer, men i fremtidige utgivelser vil det gi mulighet til Ä implementere betydelige ytelsesforbedringer og legge til stÞtte for nye protokoller som DNS over TLS.
  • Prosessen for Ă„ administrere DNSSEC tillitsanker (Trust anchor, knyttet til sonens offentlige nĂžkkel for Ă„ verifisere autentisiteten til denne sonen) er forbedret. I stedet for de nĂ„ utdaterte innstillingene trusted-keys og managed-keys, er det introdusert et nytt direktiv trust-anchors, som lar deg administrere begge nĂžkkeltypene.

    NÄr du bruker trust-anchors med nÞkkelordet initial-key, er oppfÞrselen til dette direktivet identisk med managed-keys, dvs. det definerer innstillingen for tillitsankeret i henhold til RFC 5011. NÄr du bruker trust-anchors med nÞkkelordet static-key, tilsvarer oppfÞrselen direktivet trusted-keys, dvs. det angir en permanent nÞkkel som ikke oppdateres automatisk. I trust-anchors er det ogsÄ introdusert to nÞkkelord initial-ds og static-ds, som lar deg bruke tillitsanker i format DS (Delegation Signer) i stedet for DNSKEY, noe som gir mulighet for Ä konfigurere anker for ennÄ ikke publiserte nÞkler (i fremtiden har IANA planer om Ä bruke DS-formatet til de primÊre sonenes nÞkler).

  • VerktĂžyene dig, mdig og delv har fĂ„tt alternativet «+yaml» for utdata i YAML-format.
  • I verktĂžyet dig er alternativet «+[no]unexpected» lagt til, som tillater mottak av svar fra verter som er forskjellige fra serveren som forespĂžrselen ble sendt til.
  • I verktĂžyet dig har det blitt lagt til et alternativ «+[no]expandaaaa», der IPv6-adresser i AAAA-postene vises i full 128-bits representasjon, i stedet for RFC 5952-format.
  • Muligheten for Ă„ bytte mellom statistikkkanaler er lagt til.
  • DS- og CDS-poster genereres nĂ„ kun basert pĂ„ SHA-256-hashverdi (generering basert pĂ„ SHA-1 er stoppet).
  • For DNS Cookie (RFC 7873) er algoritmen SipHash 2-4 som standard aktivert, mens HMAC-SHA-stĂžtten er avsluttet (AES er fortsatt tilgjengelig).
  • Utdata fra kommandoene dnssec-signzone og dnssec-verify gĂ„r nĂ„ til standard utdata (STDOUT), mens informasjon om feil og advarsler kun vises i STDERR (ved Ă„ spesifisere alternativet «-f» vises ogsĂ„ den signerte sonen). For Ă„ dempe utdataene er alternativet «-q» lagt til.
  • Koden for DNSSEC-validering er omarbeidet, og unngĂ„r nĂ„ duplisering av kode med andre undertjenester.
  • For Ă„ vise statistikk i JSON-format kan nĂ„ kun JSON-C-biblioteket brukes. Konfigurasjonsalternativet «—with-libjson» er omdĂžpt til «—with-json-c».
  • I konfigurasjonsskriptet settes ikke alternativet «—sysconfdir» lenger til /etc som standard, og «—localstatedir» til /var, med mindre «—prefix» er spesifisert. Som standard brukes nĂ„ stiene $prefix/etc og $prefix/var som brukes i Autoconf.
  • Koden som implementerte DLV-tjenesten (Domain Look-aside Verification, alternativ dnssec-lookaside) har blitt fjernet, ettersom den ble erklĂŠrt utdatert i BIND 9.12, og den tilknyttede behandleren dlv.isc.org ble stengt i 2017. Fjerning av DLV har gjort BIND-koden mindre komplisert.

Kilde: opennet.ru

KjĂžp pĂ„litelig hosting for nettsteder med DDoS-beskyttelse, VPS VDS-servere đŸ”„ KjĂžp pĂ„litelig hosting for nettsteder med DDoS-beskyttelse, VPS VDS-servere | ProHoster