Etter nesten ett Ă„rs utvikling er den nye stabile versjonen av e-postserveren Postfix â 3.10.0 â nĂ„ tilgjengelig. Samtidig er det kunngjort at stĂžtte for versjon 3.6 av Postfix, som ble utgitt tidlig i 2021, vil bli avsluttet. Prosjektkoden er skrevet i C og distribueres under lisensene EPL 2.0 (Eclipse Public License) og IPL 1.0 (IBM Public License).
Postfix er et av de fÄ prosjektene som kombinerer hÞy sikkerhet, pÄlitelighet og ytelse, noe som er oppnÄdd gjennom en flerprosessarkitektur som isolerer enkeltbehandlere, samt en streng kodeformateringspolitikk og revisjon av patcher. For Ä beskytte mot feil ved minnehÄndtering bruker prosjektet sikre alternativer for funksjoner som allokerer og frigjÞr minne, samt et sett med abstrakte omslagsfunksjoner for bufferhÄndtering (som sjekker grenseoverskridelser og tilgang til frigitt minne), filoperasjoner, formatering av utdata, bufret inndata og manipulasjoner med strenger (inkludert muligheter for hÄndtering av strenger av vilkÄrlig stÞrrelse og automatisk strammes tilpassning av strenger).
I henhold til den automatiserte undersĂžkelsen i februar bruker omtrent 550 000 e-post serverePostfix pĂ„ 37.64% (for ett Ă„r siden 36.81%) av e-postserverne, andelen Exim er pĂ„ 56.03% (for ett Ă„r siden 56.61%), Sendmail â 3.39% (3.60%), MailEnable â 1.80% (1.82%), MDaemon â 0.39% (0.40%), Microsoft Exchange â 0.19% (0.19%), OpenSMTPD â 0.10% (0.09%).

Hovudnyhende:
- Muligheten for Ä bruke TLS-kryptoalgoritmer som er motstandsdyktige mot kvanteangrep, er lagt til. For Ä bruke disse algoritmene kreves OpenSSL 3.5-biblioteket, som fortsatt er under utvikling. For valg av post-kvantealgoritmer i Postfix har de unngÄtt Ä innfÞre en ny syntaks for TLS-grupper, og baserer seg heller pÄ innstillingene til OpenSSL, som vil bli brukt ved konfigurasjon av parametrene «tls_eecdh_auto_curves» og «tls_ffdhe_auto_groups» med tomme verdier.
- StÞtte for meldingsoverskriften «TLS-Required: no» (RFC 8689) er lagt til, noe som gjÞr at leveransen vil bli utfÞrt selv nÄr det ikke er mulig Ä implementere den sikkerhetspolicyen for TLS som er satt. Med denne overskriften fungerer SMTP-klienten i modusen «smtp_tls_security_level = may», dvs. den kontrollerer ikke sertifikatet. serveren og kan falle tilbake til en tilkobling med overfÞring av data i klartekst. I den neste betydelige grenen av Postfix, planlegger vi Ä implementere SMTP-utvidelsen REQUIRETLS.
- StÞtte for TLS-RPT (Transport Layer Security Reporting) er lagt til, noe som muliggjÞr sporing av feil ved levering av meldinger som oppstÄr nÄr det ikke er mulig Ä etablere en kryptert tilkobling i henhold til bruken av DANE (DNS-basert autentisering av navngitte enheter) eller MTA-STS (MTA Strict Transport Security)-utvidelser. Eieren av e-postdomenet definerer i DNS parametere for TLS-RPT, hvoretter e-postservere vil sende rapporter med informasjon om vellykkede og mislykkede TLS-tilkoblinger til MX-serverne som betjener domenet. Implementeringen er basert pÄ libtlsrpt-biblioteket.
- Innstillingen «smtpd_hide_client_session = yes» er lagt til for Ä deaktivere innsetting av informasjon om klientÞkten nÄr SMTP-serveren setter inn «Received:»-overskriften. Eksempel pÄ en forkortet overskrift: «Received: by mail.example.com (Postfix) id postfix-queue-id for ; Day, dd Mon yyyy hh:mm:ss tz-offset (zone)».
- Muligheten for MIME-koding (RFC 2047) av navn i genererte Postfix-overskrifter «From:», som inkluderer ikke-ASCII-tegn, er lagt til. Den foreslÄtte kodingsskjemaet tillater Ä unngÄ bruken av SMTPUTF8-utvidelsen (RFC 6531), som ikke stÞttes av alle applikasjoner. Resultatet av MIME-koding ser slik ut: '"=?charset?Q?gibberish?=:'. For Ä bestemme den opprinnelige kodingen av navn, er parameteren «full_name_encoding_charset» lagt til, med standardverdi satt til utf8.
- Logikken for behandling av mislykkede tilkoblinger nÄr det i innstillingene angis «mysql:» eller «pgsql:» med kun én server, er endret. En slik server oppfattes nÄ som en lastbalanserer, og ved enkeltfeil sendes den gjentatte forespÞrselen umiddelbart, uten en forsinkelse pÄ 60 sekunder.
- I Milter er det implementert logging av informasjon med Ärsaken til at meldingen settes i karantene.
- I SMTP-serveren er det sikret logging av kÞens identifikator eller verdien «NOQUEUE» ved avslutning av tilkoblingen pÄ grunn av timeout, avbrudd eller overskridelse av feiltoleranse. RengjÞringsprosessen logger da «queueid: canceled» for meldinger med en transaksjon som er startet, men ikke fullfÞrt.
- I Dovecot SASL-klienten viser loggen meldinger om «Invalid authentication mechanism» nÄ den autentiseringsmekanismen som ikke kunne brukes.
- PÄ grunn av endringen i den interne protokollen som brukes i leveringsagenten, kreves det en omstart med kommandoen «postfix reload» eller kommandoene «postfix stop» og «postfix start» etter oppdatering av Postfix-versjonen. Ellers vil det vises en advarsel i loggen «unexpected attribute smtputf8 from xxx socket (expecting: sendopts)».
Kilde: opennet.ru
