FreeBSD 12.3 er blitt lansert og er tilgjengelig for arkitekturene amd64, i386, powerpc, powerpc64, powerpcspe, sparc64 samt armv6, armv7 og aarch64. Det er også forberedt bilder for virtualiseringssystemer (QCOW2, VHD, VMDK, raw) og Amazon EC2 skymiljøer. FreeBSD 13.1 er forventet våren 2022.
Nøkkelnyheter:
- Det er lagt til et skript /etc/rc.final, som kjøres på det siste stadiet av oppstart etter at alle brukerprosesser er fullført.
- I pakkevannfilteret ipfw er kommandoen dnctl lagt til for å administrere innstillingene i dummynet trafikkgrense.
- Sysctl kern.crypto er lagt til for å administrere kryptosystemet i kjernen, samt en debug sysctl debug.uma_reclaim.
- Sysctl net.inet.tcp.tolerate_missing_ts er lagt til, som tillater TCP-pakker uten tidsstempler (timestamp, RFC 1323/RFC 7323).
- I GENERIC-kjernen for amd64-arkitekturen er alternativet COMPAT_LINUXKPI inkludert, og driveren mlx5en (NVIDIA Mellanox ConnectX-4/5/6) er aktivert.
- I oppstartslasteren er muligheten for å laste operativsystemet fra ramdisk lagt til, samt støtte for ZFS-alternativene com.delphix:bookmark_written og com.datto:bookmark_v2 er implementert.
- I fetch-biblioteket er støtte for FTP-proxying over HTTPS lagt til.
- I pakkehåndtereren pkg for kommandoene «bootstrap» og «add» er flagget «-r» implementert for å spesifisere depotet. Det er sikret bruk av miljøvariabler fra pkg.conf-filen.
- I verktøyet growfs er det nå mulighet for å jobbe med filsystemer montert i lesing og skriving.
- I verktøyet etcupdate er en tilbakeføringsmodus implementert for å gjenopprette en eller flere filer. Flagget «-D» er lagt til for å spesifisere målmappen. Det er sikret datainnhenting ved bruk av en midlertidig mappe, og behandling av SIGINT er lagt til.
- I verktøyene freebsd-update og freebsd-version er flagget «-j» lagt til for støtte av jail-miljøer.
- Verktøyet cpuset kan nå brukes i jail-miljøer for å endre innstillinger for under-jail.
- I verktøyet cmp er alternativene lagt til: «-b» (—print-bytes) for å vise forskjellige byte, «-i» (—ignore-initial) for å ignorere et bestemt antall innledende byte, «-n» (—bytes) for å begrense antall sammenlignede byte.
- I verktøyet daemon er flagget «-H» lagt til for å håndtere SIGHUP og gjenåpne filene der utdataene skrives (lagt til for støtte av newsyslog).
- I verktøyet fstyp, ved å spesifisere flagget «-l», er det sikret at filsystemer exFAT identifiseres og vises.
- Verktøyet mergemaster har implementert behandling av symboliske lenker under oppdateringsprosessen.
- Verktøyet newsyslog har fått flagget «E» for å deaktivere rotering av tomme logger.
- Verktøyet tcpdump har fått muligheten til å dekode pakker på pfsync-grensesnitt.
- Verktøyet top har fått en filterkommando «/» for å vise bare prosesser eller argumenter som samsvarer med angitt tekst.
- Unzip har fått støtte for passordbeskyttede arkiv.
- Støtten for maskinvare er forbedret. PCI-enhetsidentifikatorer for AHCI-kontrollere ASMedia ASM116x og I2C-kontrollere Intel Gemini Lake er lagt til. Støtte for nettverksadaptere Mikrotik 10/25G og trådløse kort Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14 er implementert. Den nye driveren igc for ethernetkontrollere Intel I225 2.5G/1G/100MB/10MB er lagt til.
- Netgraph-noden ng_bridge er tilpasset for SMP-systemer. Noden ng_nat har fått støtte for CGN (Carrier Grade NAT, RFC 6598). Muligheten for å bruke ng_source-noden hvor som helst i Netgraph-nettverket er gitt.
- I rctl-driveren, som brukes til ressursbegrensning, er det lagt til en funksjon for å sette ressursforbruket til 0.
- I vlan-grensesnittet er det lagt til støtte for prioriteringssystem for trafikk og administrasjon av båndbredde med ALTQ.
- I driverne amdtemp og amdsmn er support for CPU Zen 3 «Vermeer» og APU Ryzen 4000 (Zen 2, «Renoir») implementert.
- Versjonene av tredjepartsprogrammer som er inkludert i basisystemet er oppdatert: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. Verktøyet unzip er synkronisert med kodebasen til NetBSD.
Kilde: opennet.ru
