Lighttpd 1.4.65, en lettvekts http-server, har blitt lansert. Den forsøker å kombinere høy ytelse, sikkerhet, standardoverholdelse og konfigurerbarhet. Lighttpd er egnet for bruk i høybelastede systemer og fokuserer på lavt minne- og CPU-forbruk. Den nye versjonen inneholder 173 endringer. Prosjektkoden er skrevet i C og distribueres under BSD-lisens.
Hovudnyhende:
- Støtte for WebSocket over HTTP/2 er lagt til, samt implementering av RFC 8441, som beskriver mekanismen for å starte WebSocket-protokollen i én tråd innenfor en HTTP/2-forbindelse.
- Det er implementert et utvidet prioriteringsstyringssystem, som gjør det mulig for klienten å påvirke prioriteten til de overførte serveren responsene (RFC 9218), samt styre prioriteringene ved omdirigering av forespørslene. For HTTP/2 er støtte for PRIORITY_UPDATE-rammen gitt.
- I lighttpd.conf er støtte for betingede sammenligninger med tilknytning til start (=^) og slutt (=$) av strengen lagt til. Slike strengekontroller er betydelig raskere enn regulære uttrykk og er tilstrekkelige for mange enkle kontroller.
- I mod_webdav er støtte for delvise PUT-operasjoner (som dekker en del data ved hjelp av Range-headeren) lagt til. For å aktivere dette kan alternativet 'webdav.opts += ("partial-put-copy-modify" => "enable")' brukes.
- I mod_accesslog er alternativet 'accesslog.escaping = "json"' lagt til.
- I mod_deflate er støtte for bygging med libdeflate lagt til.
- Overføringen av forespørselens kropp via HTTP/2 er akselerert.
- Standardverdien for parameteren server.max-keep-alive-requests er endret fra 100 til 1000.
- I MIME-typelisten er 'application/javascript' erstattet med 'text/javascript' (RFC 9239).
Det er planlagt å bruke strengere krypteringsinnstillinger for TLS i fremtiden og å deaktivere utdaterte krypteringer som standard. Innstillingen CipherString vil bli endret fra verdien 'HIGH' til 'EECDH+AESGCM:AES256+EECDH:CHACHA20:SHA256:!SHA384'. Utdaterte TLS-alternativer som ssl.honor-cipher-order, ssl.dh-file, ssl.ec-curve, ssl.disable-client-renegotiation, ssl.use-sslv2, ssl.use-sslv3 vil også bli fjernet. I tillegg vil det fortsette en rensing av mini-moduler, som kan erstattes med en mer fleksibel Lua-implementering av mod_magnet. Spesielt er det planlagt å fjerne modulene mod_evasive, mod_secdownload, mod_uploadprogress og mod_usertrack.
Kilde: opennet.ru
