{"id":112077,"date":"2023-12-08T15:10:14","date_gmt":"2023-12-08T13:10:14","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp"},"modified":"2023-12-08T15:10:14","modified_gmt":"2023-12-08T13:10:14","slug":"avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","status":"publish","type":"post","link":"https:\/\/prohoster.info\/no\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","title":{"rendered":"Skaperen av GnuPG grunnla LibrePGP, en fork av OpenPGP-standarden","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>Werner Koch, hovedutvikler og skaperen av prosjektet GnuPG (GNU Privacy Guard), startet prosjektet LibrePGP, som er fokusert p\u00e5 utviklingen av en oppdatert spesifikasjon, alternativ til standarden OpenPGP. Forken ble laget som svar p\u00e5 endringer planlagt av IETF arbeidsgruppen for \u00e5 innf\u00f8re i neste oppdatering av spesifikasjonen OpenPGP (RFC-4880), som Koch ans\u00e5 som tvilsomme med hensyn til opprettholdelse av kompatibilitet og sikkerhet. Utviklerne bak prosjektene GnuPG, RNP (OpenPGP-implementering fra Thunderbird) og Gpg4win som st\u00f8ttet fork, frykter at de planlagte endringene vil v\u00e6re skadelige for eksisterende implementeringer av applikasjoner basert p\u00e5 OpenPGP, hvis brukere forventer stabilitet i spesifikasjonen p\u00e5 lang sikt og ikke er villige til \u00e5 akseptere endringer som bryter kompatibiliteten.    <\/p>\n<p>LibrePGP inkluderer nyttige forbedringer, utviklet de siste \u00e5rene for den fremtidige versjonen av spesifikasjonen OpenPGP, men utelukker samtidig endringer som negativt p\u00e5virker opprettholdelsen av kompatibilitet. For eksempel, sammenlignet med den gjeldende standarden RFC-4880, er det i LibrePGP vedtatt slike muligheter som:  <\/p>\n<ul>\n<li class=\"l\"> St\u00f8tte for krypteringsalgoritmen Camellia (RFC-5581),\n<li class=\"l\"> Utvidelser av ECC (Elliptic Curve Cryptography) for OpenPGP (RFC-6637).\n<li class=\"l\"> Obligatorisk st\u00f8tte for hashene SHA2-256 (SHA-1 og MD5 er kategorisert som ikke anbefalt, og muligheten for dekryptering av data uten verifikasjon av integritet er kategorisert som helt foreldet).\n<li class=\"l\"> \u00d8kning av st\u00f8rrelsen p\u00e5 kontrollerende fingeravtrykk (fingerprint) til 256 biter.\n<li class=\"l\"> St\u00f8tte for digitale signaturordninger EdDSA og elliptiske kurver BrainpoolP256r1, BrainpoolP384r1, BrainpoolP512r1, Ed25519, Curve25519, Ed488 og X448.\n<li class=\"l\"> St\u00f8tte for algoritmen CRYSTALS-Kyber, motstandsdyktig mot kvantecomputing.\n<li class=\"l\"> St\u00f8tte for autentiseringskrypteringsmodus OCB (Offset codebook mode).\n<li class=\"l\"> Implementering av femte versjon av formatet for digitale signaturer med beskyttelse av metadata.\n<li class=\"l\"> St\u00f8tte for utvidede underpakker med digitale signaturer.  <\/ul>\n<p>Hovedpunktene i kritikken av den nye spesifikasjonen OpenPGP:  <\/p>\n<ul>\n<li class=\"l\"> IETF arbeidsgruppen har, i stedet for en gradvis inkrementell oppdatering av spesifikasjonen, fors\u00f8kt \u00e5 gjenskape standarden fra bunnen av og innf\u00f8re betydelige endringer som bryter kompatibiliteten.\n<li class=\"l\"> Innf\u00f8ring av st\u00f8tte for symmetrisk krypteringsmodus GCM (Galois\/Counter Mode), som er vanskelig \u00e5 implementere korrekt, samtidig som OCB-modus (Offset Codebook Mode) ignoreres, hvis patenter har utl\u00f8pt for flere \u00e5r siden.\n<li class=\"l\"> Legge til valgfrie pakker med tilfeldig fyll for beskyttelse mot trafikkanalyse. If\u00f8lge skaperne av LibrePGP skaper slike pakker med ukontrollerbar tilfeldig fyll en trussel for bruk som skjulte datakanaler og omg\u00e5else av systemer for datalekkasjebeskyttelse. Tidligere ble ideen om \u00e5 inkludere ekstra fyll avvist, da den ble ansett som et problem p\u00e5 applikasjonsniv\u00e5, ikke p\u00e5 krypteringsniv\u00e5.\n<li class=\"l\"> Bruke en modifisert ECDH-krypteringsskjema (endring av OID-formatet), i stedet for \u00e5 bruke den allerede beskrevet varianten i RFC-6637 som er implementert i PGP og GnuPG.\n<li class=\"l\"> Fjerning av enkelte praktiske muligheter, som den klassiske metoden for \u00e5 tilbakekalle n\u00f8kler, flagget &#171;m&#187; for \u00e5 merke MIME-data, og flagget &#171;t&#187; for \u00e5 skille tekstdata fra bin\u00e6re (i stedet for flagget &#171;t&#187; kom flagget &#171;u&#187; for tekst i UTF-8-koding).\n<li class=\"l\"> Avsl\u00e5 \u00e5 inkludere beskyttelse av metadata fra den signerte filen i det nye signaturformatet (for eksempel kan man endre filnavn uten \u00e5 bryte signaturen).\n<li class=\"l\"> Tvilsom mulighet for \u00e5 legge til &#171;salt&#187; til signaturer (Salted signature) for \u00e5 styrke beskyttelsen mot kollisjonsangrep med et angitt prefiks. Verdien med salt kan brukes som en ikke-frakoblet, skjult kanal for \u00e5 sende 32 byte med data i signaturen.\n<li class=\"l\"> Forskyvning av standarden mot prim\u00e6r bruk for online kommunikasjon, uten \u00e5 ta hensyn til behovene for langsiktig datalagring.  <\/ul>\n<p>Forkjempere for OpenPGP har allerede publisert kritikk av kritikken. Som et resultat, hvis det ikke lykkes \u00e5 finne et kompromiss, kan splittelsen f\u00f8re til \u00f8kende inkompatibiliteter i OpenPGP\/LibrePGP-implementasjoner. Dels for \u00e5 l\u00f8se dette problemet, har utviklerne av OpenPGP fastsl\u00e5tt den femte versjonen av signaturformatet i en kompatibel versjon med LibrePGP og g\u00e5tt videre med arbeidet med den sjette versjonen.<br \/>\n<br \/>Kilde: <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=60256\">opennet.ru<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP. \u0424\u043e\u0440\u043a \u0431\u044b\u043b \u0441\u043e\u0437\u0434\u0430\u043d \u0432 \u043e\u0442\u0432\u0435\u0442 \u043d\u0430 \u0438\u0437\u043c\u0435\u043d\u0435\u043d\u0438\u044f, \u043d\u0430\u043c\u0435\u0447\u0435\u043d\u043d\u044b\u0435 \u0440\u0430\u0431\u043e\u0447\u0435\u0439 \u0433\u0440\u0443\u043f\u043f\u043e\u0439 IETF \u0434\u043b\u044f \u0432\u043d\u0435\u0441\u0435\u043d\u0438\u044f \u0432 \u0441\u043b\u0435\u0434\u0443\u044e\u0449\u0435\u0435 \u043e\u0431\u043d\u043e\u0432\u043b\u0435\u043d\u0438\u0435 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438 OpenPGP (RFC-4880) \u0438 \u0432\u043e\u0441\u043f\u0440\u0438\u043d\u044f\u0442\u044b\u0435 \u041a\u043e\u0445\u043e\u043c \u043a\u0430\u043a \u0441\u043e\u043c\u043d\u0438\u0442\u0435\u043b\u044c\u043d\u044b\u0435 \u0441 \u0442\u043e\u0447\u043a\u0438 \u0437\u0440\u0435\u043d\u0438\u044f \u0441\u043e\u0445\u0440\u0430\u043d\u0435\u043d\u0438\u044f \u0441\u043e\u0432\u043c\u0435\u0441\u0442\u0438\u043c\u043e\u0441\u0442\u0438 \u0438 \u043e\u0431\u0435\u0441\u043f\u0435\u0447\u0435\u043d\u0438\u044f [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-112077","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.5 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/no\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp\" \/>\n\t\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.5\" \/>\n\t\t<meta property=\"og:locale\" content=\"nn_NO\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u0410\u0432\u0442\u043e\u0440 GnuPG \u043e\u0441\u043d\u043e\u0432\u0430\u043b LibrePGP, \u0444\u043e\u0440\u043a \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0430 OpenPGP | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/no\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-12-08T13:10:14+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-12-08T13:10:14+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47GnuPGs forfatter grunnla LibrePGP, en forgrening av OpenPGP-standarden | ProHoster","description":"Werner Koch, hovedutvikler og skaper av GnuPG-prosjektet (GNU Privacy Guard), grunnla LibrePGP-prosjektet, som fokuserer p\u00e5 utviklingen av en oppdatert spesifikasjon, alternativ til OpenPGP-standarden.","canonical_url":"https:\/\/prohoster.info\/no\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"nn_NO","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u0410\u0432\u0442\u043e\u0440 GnuPG \u043e\u0441\u043d\u043e\u0432\u0430\u043b LibrePGP, \u0444\u043e\u0440\u043a \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0430 OpenPGP | ProHoster","og:description":"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.","og:url":"https:\/\/prohoster.info\/no\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-12-08T13:10:14+00:00","article:modified_time":"2023-12-08T13:10:14+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/no\/wp-json\/wp\/v2\/posts\/112077","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/no\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/no\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/no\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/no\/wp-json\/wp\/v2\/comments?post=112077"}],"version-history":[{"count":0,"href":"https:\/\/prohoster.info\/no\/wp-json\/wp\/v2\/posts\/112077\/revisions"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/no\/wp-json\/wp\/v2\/media?parent=112077"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/no\/wp-json\/wp\/v2\/categories?post=112077"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/no\/wp-json\/wp\/v2\/tags?post=112077"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}